aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-11-30 06:13:34 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-11-30 06:13:34 +0000
commitbf43557044604cb6487fc1aa24ce2c210ae789da (patch)
tree10dd7508accfa6a3ffc8e631ba63a22cc2fdeb6b /graphics
parente3b0bf80d1a7a3579b4284ef20edfdcdcefac2a7 (diff)
downloadports-bf43557044604cb6487fc1aa24ce2c210ae789da.tar.gz
ports-bf43557044604cb6487fc1aa24ce2c210ae789da.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aseprite/Makefile1
-rw-r--r--graphics/code-eli/Makefile1
-rw-r--r--graphics/exact-image/Makefile1
-rw-r--r--graphics/exrtools/Makefile1
-rw-r--r--graphics/hiptext/Makefile1
-rw-r--r--graphics/lightzone/Makefile1
-rw-r--r--graphics/opencolorio/Makefile1
-rw-r--r--graphics/pencil/Makefile1
-rw-r--r--graphics/picpuz/Makefile1
-rw-r--r--graphics/pixie/Makefile1
-rw-r--r--graphics/s10sh/Makefile1
11 files changed, 11 insertions, 0 deletions
diff --git a/graphics/aseprite/Makefile b/graphics/aseprite/Makefile
index 7427e13283f1..420ade1acbc8 100644
--- a/graphics/aseprite/Makefile
+++ b/graphics/aseprite/Makefile
@@ -26,6 +26,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
BROKEN_aarch64= fails to compile: undefined reference to __va_copy
BROKEN_armv6= fails to compile: undefined reference to __va_copy
+BROKEN_armv7= fails to compile: undefined reference to __va_copy
BROKEN_powerpc64= fails to compile: arena.h: Failed assertion: "arena_mapbits_allocated_get(chunk, pageind) != 0"
BROKEN_sparc64= fails to compile: vsnprintf is not a member of std
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
index 3a2c6bc60e89..10fdc146cf05 100644
--- a/graphics/code-eli/Makefile
+++ b/graphics/code-eli/Makefile
@@ -36,6 +36,7 @@ DOXYGEN_ALL_TARGET= doc
DOXYGEN_PORTDOCS= html latex
BROKEN_armv6= fails to compile: undefined reference to cbrtl
+BROKEN_armv7= fails to compile: undefined reference to cbrtl
BROKEN_powerpc64= fails to compile: there are no arguments to 'printf' that depend on a template parameter
post-patch-EXAMPLES-off:
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index edacd4b24b42..226646f2e6dd 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS= libagg.so:graphics/agg \
libexpat.so:textproc/expat2
BROKEN_armv6= fails to configure: C++ compiler is not installed or does not work correctly
+BROKEN_armv7= fails to configure: C++ compiler is not installed or does not work correctly
#hack to get custom exactcode configure script to enable tiff support with
#broken headers on c++ in base system:
diff --git a/graphics/exrtools/Makefile b/graphics/exrtools/Makefile
index 10df0ce8c761..b3e35d98983b 100644
--- a/graphics/exrtools/Makefile
+++ b/graphics/exrtools/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libImath-2_2.so:graphics/ilmbase \
libIlmImf.so:graphics/OpenEXR
BROKEN_armv6= fails to configure: checking for /nxb-bin/usr/bin/cc... no
+BROKEN_armv7= fails to configure: checking for /nxb-bin/usr/bin/cc... no
GNU_CONFIGURE= yes
USES= gmake jpeg pkgconfig
diff --git a/graphics/hiptext/Makefile b/graphics/hiptext/Makefile
index 254a08341456..85185b24b1e6 100644
--- a/graphics/hiptext/Makefile
+++ b/graphics/hiptext/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:x11-fonts/dejavu
BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
+BROKEN_armv7= fails to compile: error: the clang compiler does not support -march=native
USE_GITHUB= yes
GH_ACCOUNT= jart
diff --git a/graphics/lightzone/Makefile b/graphics/lightzone/Makefile
index c5e210813dbf..8875c6c11c42 100644
--- a/graphics/lightzone/Makefile
+++ b/graphics/lightzone/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
RUN_DEPENDS= jhindexer:java/javahelp
BROKEN_armv6= fails to compile: build.xml: exec returned: 1
+BROKEN_armv7= fails to compile: build.xml: exec returned: 1
USE_GITHUB= yes
GH_ACCOUNT= ktgw0316
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index 5c746c122f2b..41840c7859e6 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -37,6 +37,7 @@ SHEBANG_FILES= share/sphinx/ExtractRstFromSourceCPP.py \
BROKEN_aarch64= Does not compile: error: use of undeclared identifier __builtin_ia32_emms
BROKEN_armv6= Does not compile: error: use of undeclared identifier __builtin_ia32_emms
+BROKEN_armv7= Does not compile: error: use of undeclared identifier __builtin_ia32_emms
BROKEN_mips64= Does not compile: error: unrecognized command line option -msse2
BROKEN_powerpc64= Does not compile: error: unrecognized command line option -msse2
BROKEN_sparc64= Does not compile: error: unrecognized command line option -msse2
diff --git a/graphics/pencil/Makefile b/graphics/pencil/Makefile
index 4c7a5e661fc2..1148d600bb1a 100644
--- a/graphics/pencil/Makefile
+++ b/graphics/pencil/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libming.so:graphics/ming \
libpng.so:graphics/png
BROKEN_armv6= fails to compile: no matching function for call to 'qMax'
+BROKEN_armv7= fails to compile: no matching function for call to 'qMax'
USES= qmake zip
USE_QT4= gui opengl xml moc_build rcc_build
diff --git a/graphics/picpuz/Makefile b/graphics/picpuz/Makefile
index d53a339e80fd..c9f6db74855c 100644
--- a/graphics/picpuz/Makefile
+++ b/graphics/picpuz/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= devel@stasyan.com
COMMENT= Jigsaw puzzle program
BROKEN_armv6= fails to compile: use of undeclared identifier __NR_SYSCALL_BASE
+BROKEN_armv7= fails to compile: use of undeclared identifier __NR_SYSCALL_BASE
USES= dos2unix gmake pkgconfig
DOS2UNIX_GLOB= *.h
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index 2360cece4ddf..603d95041132 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
BROKEN_aarch64= fails to compile: use of undeclared identifier CRenderer
BROKEN_armv6= fails to compile: use of undeclared identifier CRenderer
+BROKEN_armv7= fails to compile: use of undeclared identifier CRenderer
BROKEN_sparc64= fails to compile
USE_GL= glu
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index 72a344b045b1..933a72b9cfbc 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -16,6 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= Fails to build: error: can not find the byte order for this architecture, fix bytesex.h
BROKEN_armv6= Fails to build: error: can not find the byte order for this architecture, fix bytesex.h
+BROKEN_armv7= Fails to build: error: can not find the byte order for this architecture, fix bytesex.h
USES= ncurses readline