aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-07-01 09:17:45 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-07-01 09:17:45 +0000
commitc7df1277c6283a340bd9eefc52a20ae4a157aa22 (patch)
tree03d0951296a7fc3c7578f9a9a0fe576a50e1e2bb /graphics
parent67106e11a36ae3527db6b0271be16c47ca68b6d4 (diff)
downloadports-c7df1277c6283a340bd9eefc52a20ae4a157aa22.tar.gz
ports-c7df1277c6283a340bd9eefc52a20ae4a157aa22.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/freeimage/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 371db8b157e7..dea5ab71fa35 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -14,6 +14,9 @@ DISTNAME= FreeImage${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple C/C++ bitmap graphics library
+BROKEN_mips= fails to compile: opcode not supported on this processor: mips3 (mips3) `madd $16,$6'
+BROKEN_mips64= fails to compile: opcode not supported on this processor: mips3 (mips3) 'madd $4,$5'
+
USES= dos2unix gmake zip
DOS2UNIX_FILES= Source/LibOpenJPEG/opj_malloc.h \
Source/LibRawLite/dcraw/dcraw.c \
@@ -40,7 +43,7 @@ PLIST_FILES= include/FreeImage.h \
.include <bsd.port.options.mk>
-.if ${ARCH} == amd64 || ${ARCH} == powerpc
+.if ${ARCH} == amd64 || ${ARCH} == powerpc || ${ARCH} == powerpc64 || ${ARCH} == sparc64
USES+= compiler:c++0x
.endif