aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-24 19:10:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-24 19:10:40 +0000
commitcb76fc356e75aa393957e430352a60f7546cec8a (patch)
tree530763c10f386bd630f26381e9041f6a7bc94f85 /graphics
parent3bb5f733f09bfd145be6dbf7da9ef909c3742d5f (diff)
downloadports-cb76fc356e75aa393957e430352a60f7546cec8a.tar.gz
ports-cb76fc356e75aa393957e430352a60f7546cec8a.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg-devel/Makefile16
-rw-r--r--graphics/osg-devel/distinfo4
-rw-r--r--graphics/osg-devel/files/patch-CMakeLists.txt17
-rw-r--r--graphics/osg-devel/files/patch-CMakeModules__FindGStreamer.cmake11
-rw-r--r--graphics/osg-devel/pkg-plist60
5 files changed, 74 insertions, 34 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 44e683579073..d010395ab42a 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= osg
-PORTVERSION= 3.3.2
-PORTREVISION= 5
+PORTVERSION= 3.3.3
CATEGORIES= graphics
MASTER_SITES= http://trac.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
@@ -30,17 +29,18 @@ USE_XORG= x11
USE_LDCONFIG= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=112 \
+ OSG_SHLIBVER=115 \
OPENTHREADS_VERSION=3.3.0 \
OPENTHREADS_SHLIBVER=20
PORTSCOUT= limitw:1,odd
-OPTIONS_DEFINE= CURL FREETYPE GDAL GIF INVENTOR JASPER XINE GTA \
- VNC OPENEXR FFMPEG SVG PDF SDL NVTT QT4 XRANDR \
- LUA V8 PYTHON
+OPTIONS_DEFINE= CURL FFMPEG FREETYPE GDAL GIF GSTREAMER GTA INVENTOR \
+ JASPER LIBLAS LUA NVTT OPENEXR PDF PYTHON QT4 SDL \
+ SVG V8 VNC XINE XRANDR
OPTIONS_DEFAULT=FREETYPE GIF FFMPEG XRANDR
+LIBLAS_DESC= liblas support
GDAL_DESC= GDAL support
INVENTOR_DESC= SGI OpenInventor support
GTA_DESC= GTA file format support
@@ -54,9 +54,11 @@ PYTHON_DESC= Python script engine support
OPTIONS_SUB= yes
CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+LIBLAS_LIB_DEPENDS= liblas.so:${PORTSDIR}/devel/liblas
FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
GDAL_LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal
GIF_LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib
+GSTREAMER_USE= GNOME=glib20 GSTREAMER1=yes
INVENTOR_LIB_DEPENDS= libInventor.so:${PORTSDIR}/graphics/inventor
JASPER_LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper
XINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
@@ -80,7 +82,7 @@ PYTHON_USES= python:2
.include <bsd.port.options.mk>
# GUI toolkits are only needed for building examples, which are not even installed
-FORCE_IGNORE= FLTK GLUT FOX Qt3 Qt5Widgets wxWidgets OpenAL GtkGl # only for examples
+FORCE_IGNORE= FLTK GLUT FOX Qt3 Qt5Widgets wxWidgets OpenAL GtkGl SDL2 # only for examples
FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL FBX # not in ports
FORCE_IGNORE+= OpenVRML # ports version too old
FORCE_IGNORE+= ITK # ports version doesn't build on 10.x
diff --git a/graphics/osg-devel/distinfo b/graphics/osg-devel/distinfo
index 58ccececb61c..e69f5ac52cc6 100644
--- a/graphics/osg-devel/distinfo
+++ b/graphics/osg-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (OpenSceneGraph-3.3.2.zip) = 759676cdccd0b88e60dc1f86ee143c7598a817506fce9a6d8a388998f4230099
-SIZE (OpenSceneGraph-3.3.2.zip) = 8089660
+SHA256 (OpenSceneGraph-3.3.3.zip) = b81cda123ffb3bd108e0fe4be4fff1351d6636e6fb0a1475b2c4fb9618d3ae2b
+SIZE (OpenSceneGraph-3.3.3.zip) = 8227832
diff --git a/graphics/osg-devel/files/patch-CMakeLists.txt b/graphics/osg-devel/files/patch-CMakeLists.txt
index f1df43923067..33c214607df1 100644
--- a/graphics/osg-devel/files/patch-CMakeLists.txt
+++ b/graphics/osg-devel/files/patch-CMakeLists.txt
@@ -1,6 +1,15 @@
---- CMakeLists.txt.orig 2011-07-31 11:50:34.000000000 +0400
-+++ CMakeLists.txt 2012-03-05 05:54:52.485029323 +0400
-@@ -588,7 +588,7 @@
+--- CMakeLists.txt.orig 2014-12-18 20:47:08.000000000 +0300
++++ CMakeLists.txt 2015-01-24 21:51:57.000000000 +0300
+@@ -629,7 +629,7 @@
+ FIND_PACKAGE(LibVNCServer)
+ FIND_PACKAGE(OurDCMTK)
+ FIND_PACKAGE(FFmpeg)
+- FIND_PACKAGE(GStreamer COMPONENTS gstreamer-app gstreamer-pbutils)
++ FIND_PACKAGE(GStreamer COMPONENTS app pbutils)
+ FIND_PACKAGE(GLIB COMPONENTS gobject)
+ FIND_PACKAGE(DirectShow)
+ FIND_PACKAGE(SDL2)
+@@ -805,7 +805,7 @@
IF(UNIX AND NOT WIN32 AND NOT APPLE)
IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
@@ -9,7 +18,7 @@
MARK_AS_ADVANCED(LIB_POSTFIX)
ENDIF()
ENDIF()
-@@ -972,7 +972,7 @@
+@@ -1234,7 +1234,7 @@
${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc
@ONLY
)
diff --git a/graphics/osg-devel/files/patch-CMakeModules__FindGStreamer.cmake b/graphics/osg-devel/files/patch-CMakeModules__FindGStreamer.cmake
new file mode 100644
index 000000000000..608032dc4d78
--- /dev/null
+++ b/graphics/osg-devel/files/patch-CMakeModules__FindGStreamer.cmake
@@ -0,0 +1,11 @@
+--- CMakeModules/FindGStreamer.cmake.orig 2014-12-18 12:03:15.000000000 +0300
++++ CMakeModules/FindGStreamer.cmake 2015-01-24 21:36:08.000000000 +0300
+@@ -104,7 +104,7 @@
+
+ # 1.1. Find headers and libraries
+ FIND_GSTREAMER_COMPONENT(GSTREAMER gstreamer-1.0 gst/gst.h gstreamer-1.0)
+-#FIND_GSTREAMER_COMPONENT(GSTREAMER_BASE gstreamer-base-1.0 gst/gst.h gstbase-1.0)
++FIND_GSTREAMER_COMPONENT(GSTREAMER_BASE gstreamer-base-1.0 gst/gst.h gstbase-1.0)
+
+
+ # 1.2. Check GStreamer version
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index 347b83a741d9..86e27b69757d 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -11,26 +11,6 @@ include/OpenThreads/Condition
include/OpenThreads/Config
include/OpenThreads/Exports
include/OpenThreads/Mutex
-include/osg/Callback
-include/osgGA/Event
-include/osgGA/EventHandler
-include/osgGA/Widget
-include/osgPresentation/PresentationInterface
-include/osgUI/AlignmentSettings
-include/osgUI/ColorPalette
-include/osgUI/ComboBox
-include/osgUI/Dialog
-include/osgUI/Export
-include/osgUI/FrameSettings
-include/osgUI/Label
-include/osgUI/LineEdit
-include/osgUI/Popup
-include/osgUI/PushButton
-include/osgUI/Style
-include/osgUI/TextSettings
-include/osgUI/Widget
-include/osgVolume/MultipassTechnique
-include/osgVolume/VolumeScene
include/OpenThreads/ReadWriteMutex
include/OpenThreads/ReentrantMutex
include/OpenThreads/ScopedLock
@@ -47,14 +27,19 @@ include/osg/AutoTransform
include/osg/Billboard
include/osg/BlendColor
include/osg/BlendEquation
+include/osg/BlendEquationi
include/osg/BlendFunc
+include/osg/BlendFunci
include/osg/BoundingBox
include/osg/BoundingSphere
include/osg/BoundsChecking
include/osg/BufferIndexBinding
include/osg/BufferObject
+include/osg/BufferTemplate
+include/osg/Callback
include/osg/Camera
include/osg/CameraView
+include/osg/Capability
include/osg/ClampColor
include/osg/ClearNode
include/osg/ClipNode
@@ -62,6 +47,7 @@ include/osg/ClipPlane
include/osg/ClusterCullingCallback
include/osg/CollectOccludersVisitor
include/osg/ColorMask
+include/osg/ColorMaski
include/osg/ColorMatrix
include/osg/ComputeBoundsVisitor
include/osg/Config
@@ -88,6 +74,7 @@ include/osg/FrontFace
include/osg/GL
include/osg/GL2Extensions
include/osg/GLBeginEndAdapter
+include/osg/GLDefines
include/osg/GLExtensions
include/osg/GLObjects
include/osg/GLU
@@ -219,6 +206,7 @@ include/osg/Vec4ub
include/osg/Vec4ui
include/osg/Vec4us
include/osg/Version
+include/osg/VertexAttribDivisor
include/osg/VertexProgram
include/osg/View
include/osg/Viewport
@@ -275,6 +263,7 @@ include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
include/osgDB/Callbacks
+include/osgDB/ClassInterface
include/osgDB/ConvertUTF
include/osgDB/DataTypes
include/osgDB/DatabasePager
@@ -291,6 +280,7 @@ include/osgDB/ImagePager
include/osgDB/ImageProcessor
include/osgDB/Input
include/osgDB/InputStream
+include/osgDB/ObjectCache
include/osgDB/ObjectWrapper
include/osgDB/Options
include/osgDB/Output
@@ -325,6 +315,8 @@ include/osgGA/CameraManipulator
include/osgGA/CameraViewSwitchManipulator
include/osgGA/Device
include/osgGA/DriveManipulator
+include/osgGA/Event
+include/osgGA/EventHandler
include/osgGA/EventQueue
include/osgGA/EventVisitor
include/osgGA/Export
@@ -344,6 +336,7 @@ include/osgGA/TerrainManipulator
include/osgGA/TrackballManipulator
include/osgGA/UFOManipulator
include/osgGA/Version
+include/osgGA/Widget
include/osgManipulator/AntiSquish
include/osgManipulator/Command
include/osgManipulator/CommandManager
@@ -430,6 +423,7 @@ include/osgPresentation/Model
include/osgPresentation/Movie
include/osgPresentation/PickEventHandler
include/osgPresentation/Presentation
+include/osgPresentation/PresentationInterface
include/osgPresentation/PropertyManager
include/osgPresentation/Section
include/osgPresentation/Slide
@@ -444,7 +438,6 @@ include/osgPresentation/Volume
%%QT4%%include/osgQt/QGraphicsViewAdapter
%%QT4%%include/osgQt/QWebViewImage
%%QT4%%include/osgQt/QWidgetImage
-include/osgDB/PropertyInterface
include/osgShadow/ConvexPolyhedron
include/osgShadow/DebugShadowMap
include/osgShadow/Export
@@ -490,7 +483,9 @@ include/osgSim/ShapeAttribute
include/osgSim/SphereSegment
include/osgSim/Version
include/osgSim/VisibilityGroup
+include/osgTerrain/DisplacementMappingTechnique
include/osgTerrain/Export
+include/osgTerrain/GeometryPool
include/osgTerrain/GeometryTechnique
include/osgTerrain/Layer
include/osgTerrain/Locator
@@ -511,6 +506,22 @@ include/osgText/Text
include/osgText/Text3D
include/osgText/TextBase
include/osgText/Version
+include/osgUI/AlignmentSettings
+include/osgUI/Callbacks
+include/osgUI/ColorPalette
+include/osgUI/ComboBox
+include/osgUI/Dialog
+include/osgUI/Export
+include/osgUI/FrameSettings
+include/osgUI/Label
+include/osgUI/LineEdit
+include/osgUI/Popup
+include/osgUI/PushButton
+include/osgUI/Style
+include/osgUI/TabWidget
+include/osgUI/TextSettings
+include/osgUI/Validator
+include/osgUI/Widget
include/osgUtil/ConvertVec
include/osgUtil/CubeMapGenerator
include/osgUtil/CullVisitor
@@ -572,10 +583,13 @@ include/osgVolume/Export
include/osgVolume/FixedFunctionTechnique
include/osgVolume/Layer
include/osgVolume/Locator
+include/osgVolume/MultipassTechnique
include/osgVolume/Property
include/osgVolume/RayTracedTechnique
include/osgVolume/Version
include/osgVolume/Volume
+include/osgVolume/VolumeScene
+include/osgVolume/VolumeSettings
include/osgVolume/VolumeTechnique
include/osgVolume/VolumeTile
include/osgWidget/Box
@@ -685,6 +699,7 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_dxf.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gdal.so
%%GIF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gif.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_glsl.so
+%%GSTREAMER%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gstreamer.so
%%GTA%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gta.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_gz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_hdr.so
@@ -694,6 +709,7 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_jpeg.so
%%JASPER%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_jp2.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_ktx.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_logo.so
+%%LIBLAS%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_las.so
%%LUA%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_lua.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_lwo.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_lws.so
@@ -737,12 +753,14 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgterrain.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgui.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgutil.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgviewer.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgvolume.so
%%SDL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_sdl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_shp.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_stl.so
%%SVG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_svg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_tf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_tga.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_tgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_tiff.so