aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-31 07:10:01 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-31 07:10:01 +0000
commitd50e3bce22bde92f7311ec140a048caf68b1db69 (patch)
tree769c3d71a54bf732ced542855f7046ac41bcd63b /graphics
parentff4f979fc5ad7195031491a62a67b8cf66ea3598 (diff)
downloadports-d50e3bce22bde92f7311ec140a048caf68b1db69.tar.gz
ports-d50e3bce22bde92f7311ec140a048caf68b1db69.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_image/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 6b1af93208b2..a30ea26c655e 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -15,27 +15,23 @@ DISTNAME= SDL_image-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple library to load images of various formats as SDL surfaces
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ tiff.4:${PORTSDIR}/graphics/tiff
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
-USE_LIBTOOL= yes
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="-I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lm"
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
CONFIGURE_ARGS= --enable-tif --enable-xcf
-
-post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
+INSTALLS_SHLIB= yes
post-configure:
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+ @${REINPLACE_CMD} -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
.include <bsd.port.mk>