aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-02 18:45:27 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-02 18:45:27 +0000
commitd79ebc5a37e7678c7318ae25569cbe212c31afdb (patch)
tree23d1e52799486ab1253c0295db903b9ba4e87e8d /graphics
parentaa06a40c2c06fa1f9490975f4d4efeab0c0af3f5 (diff)
downloadports-d79ebc5a37e7678c7318ae25569cbe212c31afdb.tar.gz
ports-d79ebc5a37e7678c7318ae25569cbe212c31afdb.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fly/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/graphics/fly/Makefile b/graphics/fly/Makefile
index 8c700fe94ccf..79d298709ad9 100644
--- a/graphics/fly/Makefile
+++ b/graphics/fly/Makefile
@@ -11,26 +11,23 @@ MASTER_SITES= http://fossies.org/unix/www/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple drawing language to generate GIFs on the fly
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= bin/fly
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include fly.c -o fly \
-L${LOCALBASE}/lib -lgd
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/fly ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/fly ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>