aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-05-23 18:58:50 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-05-23 18:58:50 +0000
commitdac9b152b43f87bca069beec9d9fd1c0c939f252 (patch)
tree725e74b8d1bd9bea99651e1879066016f50ca161 /graphics
parent0a49430aea0ee55aa290412ba8b23c2d969ad004 (diff)
downloadports-dac9b152b43f87bca069beec9d9fd1c0c939f252.tar.gz
ports-dac9b152b43f87bca069beec9d9fd1c0c939f252.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/rawtherapee/Makefile8
-rw-r--r--graphics/rawtherapee/distinfo4
-rw-r--r--graphics/rawtherapee/files/patch-rtengine_CMakeLists.txt8
-rw-r--r--graphics/rawtherapee/files/patch-rtengine__EdgePreservingDecomposition.h10
-rw-r--r--graphics/rawtherapee/files/patch-rtengine_myfile.h11
-rw-r--r--graphics/rawtherapee/pkg-plist83
6 files changed, 72 insertions, 52 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index c57c1ba8dde5..487b04b13127 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rawtherapee
-PORTVERSION= 4.0.12
-PORTREVISION= 1
+PORTVERSION= 4.1
CATEGORIES= graphics
MASTER_SITES= http://rawtherapee.com/shared/source/
@@ -38,7 +37,8 @@ CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
-DDESKTOPDIR="${DESKTOPDIR}" \
-DDATADIR="${DATADIR}" \
-DCMAKE_C_FLAGS="${CFLAGS:C|-Wl,-rpath=${_GCC_RUNTIME}||:C|-L${_GCC_RUNTIME}||}" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS:C|-Wl,-rpath=${_GCC_RUNTIME}||:C|-L${_GCC_RUNTIME}||}"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS:C|-Wl,-rpath=${_GCC_RUNTIME}||:C|-L${_GCC_RUNTIME}||}" \
+ -DCACHE_NAME_SUFFIX="4.1"
SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
INSTALLS_ICONS= yes
@@ -50,8 +50,6 @@ OPTIONS_DEFAULT= OPTIMIZED_CFLAGS OPENMP
OPENMP_DESC= Enable multicore processing using OpenMP
OPTIMIZED_CFLAGS_DESC= Use extra compiler optimizations (requires SSE support)
-#.include <bsd.port.options.mk>
-
.include <bsd.port.pre.mk>
# -------------------------------------------------------------------
diff --git a/graphics/rawtherapee/distinfo b/graphics/rawtherapee/distinfo
index 5c10c6a74be2..f875c9f8757f 100644
--- a/graphics/rawtherapee/distinfo
+++ b/graphics/rawtherapee/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rawtherapee-4.0.12.tar.xz) = 6ef923f4a0e39ee487fd50b4e528db3f8ca7e27613284e309b0625cdb86a03d9
-SIZE (rawtherapee-4.0.12.tar.xz) = 15063860
+SHA256 (rawtherapee-4.1.tar.xz) = 0a36fe407daca95a06f2d3ee28ec91c9c0c95d62a91214bd67a97fd854938307
+SIZE (rawtherapee-4.1.tar.xz) = 7670916
diff --git a/graphics/rawtherapee/files/patch-rtengine_CMakeLists.txt b/graphics/rawtherapee/files/patch-rtengine_CMakeLists.txt
deleted file mode 100644
index d6e4e3244fae..000000000000
--- a/graphics/rawtherapee/files/patch-rtengine_CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
---- rtengine/CMakeLists.txt.orig 2014-01-28 22:15:25.000000000 +0100
-+++ rtengine/CMakeLists.txt 2014-01-28 22:17:21.000000000 +0100
-@@ -38,4 +38,4 @@
- ${GLIB2_LIBRARIES} ${GLIBMM_LIBRARIES} ${LCMS_LIBRARIES} ${EXPAT_LIBRARIES} ${FFTW3F_LIBRARIES} ${IPTCDATA_LIBRARIES}
- ${JPEG_LIBRARIES} ${PNG_LIBRARIES} ${TIFF_LIBRARIES} ${ZLIB_LIBRARIES})
-
--install (FILES ${CAMCONSTSFILE} DESTINATION "${BINDIR}" PERMISSIONS OWNER_WRITE OWNER_READ GROUP_READ WORLD_READ)
-+install (FILES ${CAMCONSTSFILE} DESTINATION "${DATADIR}" PERMISSIONS OWNER_WRITE OWNER_READ GROUP_READ WORLD_READ)
diff --git a/graphics/rawtherapee/files/patch-rtengine__EdgePreservingDecomposition.h b/graphics/rawtherapee/files/patch-rtengine__EdgePreservingDecomposition.h
deleted file mode 100644
index 6de9f3200627..000000000000
--- a/graphics/rawtherapee/files/patch-rtengine__EdgePreservingDecomposition.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./rtengine/EdgePreservingDecomposition.h.orig 2014-03-28 09:23:51.000000000 +0100
-+++ ./rtengine/EdgePreservingDecomposition.h 2014-03-28 10:27:06.000000000 +0100
-@@ -48,6 +48,7 @@
-
- #include <cmath>
- #include <cstdio>
-+#include <cstdlib>
- #include <cstring>
- #include "opthelper.h"
-
diff --git a/graphics/rawtherapee/files/patch-rtengine_myfile.h b/graphics/rawtherapee/files/patch-rtengine_myfile.h
deleted file mode 100644
index 8bca1d7a3152..000000000000
--- a/graphics/rawtherapee/files/patch-rtengine_myfile.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./rtengine/myfile.h.orig 2012-01-31 05:00:05.000000000 +0400
-+++ ./rtengine/myfile.h 2012-03-29 19:28:04.000000000 +0400
-@@ -22,6 +22,8 @@
- #include <glib/gstdio.h>
- #include <cstdio>
- #include <cstring>
-+#undef feof
-+#undef getc
- struct IMFILE {
- int fd;
- int pos;
diff --git a/graphics/rawtherapee/pkg-plist b/graphics/rawtherapee/pkg-plist
index 2fc26d3cadb7..12f5e71a8a94 100644
--- a/graphics/rawtherapee/pkg-plist
+++ b/graphics/rawtherapee/pkg-plist
@@ -141,6 +141,16 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/curveType-parametric.png
%%DATADIR%%/images/curveType-spline.png
%%DATADIR%%/images/curveType-unchanged.png
+%%DATADIR%%/images/Dark/actions/ajd-ca-blue1.png
+%%DATADIR%%/images/Dark/actions/ajd-ca-blue2.png
+%%DATADIR%%/images/Dark/actions/ajd-ca-red1.png
+%%DATADIR%%/images/Dark/actions/ajd-ca-red2.png
+%%DATADIR%%/images/Dark/actions/ajd-wb-bluered1.png
+%%DATADIR%%/images/Dark/actions/ajd-wb-bluered2.png
+%%DATADIR%%/images/Dark/actions/ajd-wb-green1.png
+%%DATADIR%%/images/Dark/actions/ajd-wb-green2.png
+%%DATADIR%%/images/Dark/actions/ajd-wb-temp1.png
+%%DATADIR%%/images/Dark/actions/ajd-wb-temp2.png
%%DATADIR%%/images/Dark/actions/beforeafter.png
%%DATADIR%%/images/Dark/actions/cglabel0.png
%%DATADIR%%/images/Dark/actions/cglabel1.png
@@ -172,6 +182,8 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Dark/actions/detail.png
%%DATADIR%%/images/Dark/actions/distorsion.png
%%DATADIR%%/images/Dark/actions/distortion-auto.png
+%%DATADIR%%/images/Dark/actions/distortion-barrel.png
+%%DATADIR%%/images/Dark/actions/distortion-pincushion.png
%%DATADIR%%/images/Dark/actions/document-open-recent.png
%%DATADIR%%/images/Dark/actions/document-open.png
%%DATADIR%%/images/Dark/actions/edit-copy.png
@@ -182,6 +194,7 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Dark/actions/editedg-small.png
%%DATADIR%%/images/Dark/actions/editednot-small.png
%%DATADIR%%/images/Dark/actions/editednotg-small.png
+%%DATADIR%%/images/Dark/actions/editmodehand.png
%%DATADIR%%/images/Dark/actions/exposure.png
%%DATADIR%%/images/Dark/actions/filter.png
%%DATADIR%%/images/Dark/actions/filterclear.png
@@ -213,9 +226,12 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Dark/actions/gtk-undo-rtl.png
%%DATADIR%%/images/Dark/actions/gtk-undoall-ltr.png
%%DATADIR%%/images/Dark/actions/gtk-undoall-rtl.png
+%%DATADIR%%/images/Dark/actions/gtk-zoom-100-small.png
%%DATADIR%%/images/Dark/actions/gtk-zoom-100.png
%%DATADIR%%/images/Dark/actions/gtk-zoom-fit.png
+%%DATADIR%%/images/Dark/actions/gtk-zoom-in-small.png
%%DATADIR%%/images/Dark/actions/gtk-zoom-in.png
+%%DATADIR%%/images/Dark/actions/gtk-zoom-out-small.png
%%DATADIR%%/images/Dark/actions/gtk-zoom-out.png
%%DATADIR%%/images/Dark/actions/histBar.png
%%DATADIR%%/images/Dark/actions/histBarg.png
@@ -253,6 +269,10 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Dark/actions/panel-to-right.png
%%DATADIR%%/images/Dark/actions/panel-to-top.png
%%DATADIR%%/images/Dark/actions/PanelEnding.png
+%%DATADIR%%/images/Dark/actions/perspective-h1.png
+%%DATADIR%%/images/Dark/actions/perspective-h2.png
+%%DATADIR%%/images/Dark/actions/perspective-v1.png
+%%DATADIR%%/images/Dark/actions/perspective-v2.png
%%DATADIR%%/images/Dark/actions/popuparrow.png
%%DATADIR%%/images/Dark/actions/previewmodeB-off.png
%%DATADIR%%/images/Dark/actions/previewmodeB-on.png
@@ -282,6 +302,14 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Dark/actions/raw.png
%%DATADIR%%/images/Dark/actions/refresh-red.png
%%DATADIR%%/images/Dark/actions/refresh-white.png
+%%DATADIR%%/images/Dark/actions/rotate-left-1.png
+%%DATADIR%%/images/Dark/actions/rotate-left-2.png
+%%DATADIR%%/images/Dark/actions/rotate-left-3.png
+%%DATADIR%%/images/Dark/actions/rotate-left.png
+%%DATADIR%%/images/Dark/actions/rotate-right-1.png
+%%DATADIR%%/images/Dark/actions/rotate-right-2.png
+%%DATADIR%%/images/Dark/actions/rotate-right-3.png
+%%DATADIR%%/images/Dark/actions/rotate-right.png
%%DATADIR%%/images/Dark/actions/rtwindow.png
%%DATADIR%%/images/Dark/actions/stock-flip-horizontal.png
%%DATADIR%%/images/Dark/actions/stock-flip-vertical.png
@@ -373,6 +401,16 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/histValue.png
%%DATADIR%%/images/image-editor.png
%%DATADIR%%/images/info.png
+%%DATADIR%%/images/Light/actions/ajd-ca-blue1.png
+%%DATADIR%%/images/Light/actions/ajd-ca-blue2.png
+%%DATADIR%%/images/Light/actions/ajd-ca-red1.png
+%%DATADIR%%/images/Light/actions/ajd-ca-red2.png
+%%DATADIR%%/images/Light/actions/ajd-wb-bluered1.png
+%%DATADIR%%/images/Light/actions/ajd-wb-bluered2.png
+%%DATADIR%%/images/Light/actions/ajd-wb-green1.png
+%%DATADIR%%/images/Light/actions/ajd-wb-green2.png
+%%DATADIR%%/images/Light/actions/ajd-wb-temp1.png
+%%DATADIR%%/images/Light/actions/ajd-wb-temp2.png
%%DATADIR%%/images/Light/actions/beforeafter.png
%%DATADIR%%/images/Light/actions/cglabel0.png
%%DATADIR%%/images/Light/actions/cglabel1.png
@@ -404,6 +442,8 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Light/actions/detail.png
%%DATADIR%%/images/Light/actions/distorsion.png
%%DATADIR%%/images/Light/actions/distortion-auto.png
+%%DATADIR%%/images/Light/actions/distortion-barrel.png
+%%DATADIR%%/images/Light/actions/distortion-pincushion.png
%%DATADIR%%/images/Light/actions/document-open-recent.png
%%DATADIR%%/images/Light/actions/document-open.png
%%DATADIR%%/images/Light/actions/edit-copy.png
@@ -414,6 +454,7 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Light/actions/editedg-small.png
%%DATADIR%%/images/Light/actions/editednot-small.png
%%DATADIR%%/images/Light/actions/editednotg-small.png
+%%DATADIR%%/images/Light/actions/editmodehand.png
%%DATADIR%%/images/Light/actions/exposure.png
%%DATADIR%%/images/Light/actions/filter.png
%%DATADIR%%/images/Light/actions/filterclear.png
@@ -445,9 +486,12 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Light/actions/gtk-undo-rtl.png
%%DATADIR%%/images/Light/actions/gtk-undoall-ltr.png
%%DATADIR%%/images/Light/actions/gtk-undoall-rtl.png
+%%DATADIR%%/images/Light/actions/gtk-zoom-100-small.png
%%DATADIR%%/images/Light/actions/gtk-zoom-100.png
%%DATADIR%%/images/Light/actions/gtk-zoom-fit.png
+%%DATADIR%%/images/Light/actions/gtk-zoom-in-small.png
%%DATADIR%%/images/Light/actions/gtk-zoom-in.png
+%%DATADIR%%/images/Light/actions/gtk-zoom-out-small.png
%%DATADIR%%/images/Light/actions/gtk-zoom-out.png
%%DATADIR%%/images/Light/actions/histBar.png
%%DATADIR%%/images/Light/actions/histBarg.png
@@ -485,6 +529,10 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Light/actions/panel-to-right.png
%%DATADIR%%/images/Light/actions/panel-to-top.png
%%DATADIR%%/images/Light/actions/PanelEnding.png
+%%DATADIR%%/images/Light/actions/perspective-h1.png
+%%DATADIR%%/images/Light/actions/perspective-h2.png
+%%DATADIR%%/images/Light/actions/perspective-v1.png
+%%DATADIR%%/images/Light/actions/perspective-v2.png
%%DATADIR%%/images/Light/actions/popuparrow.png
%%DATADIR%%/images/Light/actions/previewmodeB-off.png
%%DATADIR%%/images/Light/actions/previewmodeB-on.png
@@ -514,6 +562,14 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/Light/actions/raw.png
%%DATADIR%%/images/Light/actions/refresh-red.png
%%DATADIR%%/images/Light/actions/refresh-white.png
+%%DATADIR%%/images/Light/actions/rotate-left-1.png
+%%DATADIR%%/images/Light/actions/rotate-left-2.png
+%%DATADIR%%/images/Light/actions/rotate-left-3.png
+%%DATADIR%%/images/Light/actions/rotate-left.png
+%%DATADIR%%/images/Light/actions/rotate-right-1.png
+%%DATADIR%%/images/Light/actions/rotate-right-2.png
+%%DATADIR%%/images/Light/actions/rotate-right-3.png
+%%DATADIR%%/images/Light/actions/rotate-right.png
%%DATADIR%%/images/Light/actions/rtwindow.png
%%DATADIR%%/images/Light/actions/stock-flip-horizontal.png
%%DATADIR%%/images/Light/actions/stock-flip-vertical.png
@@ -571,6 +627,10 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/images/logoicon-wind.png
%%DATADIR%%/images/media-usb.png
%%DATADIR%%/images/meta.png
+%%DATADIR%%/images/move-1D-h.png
+%%DATADIR%%/images/move-1D-v.png
+%%DATADIR%%/images/move-2D.png
+%%DATADIR%%/images/move-rotate.png
%%DATADIR%%/images/network.png
%%DATADIR%%/images/nocolorlabel.png
%%DATADIR%%/images/notrated.png
@@ -721,6 +781,12 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/themes/17-Gray-Red.iconset
%%DATADIR%%/themes/21-Gray-Gray.gtkrc
%%DATADIR%%/themes/21-Gray-Gray.iconset
+%%DATADIR%%/themes/21-Gray-Orange.gtkrc
+%%DATADIR%%/themes/21-Gray-Orange.iconset
+%%DATADIR%%/themes/21-Gray-Purple.gtkrc
+%%DATADIR%%/themes/21-Gray-Purple.iconset
+%%DATADIR%%/themes/21-Gray-Red.gtkrc
+%%DATADIR%%/themes/21-Gray-Red.iconset
%%DATADIR%%/themes/25-Gray-Gray.gtkrc
%%DATADIR%%/themes/25-Gray-Gray.iconset
%%DATADIR%%/themes/25-Gray-Purple.gtkrc
@@ -734,8 +800,7 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/themes/63-Gray-Cyan.gtkrc
%%DATADIR%%/themes/63-Gray-Cyan.iconset
%%DATADIR%%/themes/92-Beige-DarkCyan.gtkrc
-%%DATADIR%%/themes/Default.gtkrc
-%%DATADIR%%/themes/Default.iconset
+%%DATADIR%%/themes/92-Beige-DarkCyan.iconset
%%DATADIR%%/themes/gray_textured/arrow-down-ins.png
%%DATADIR%%/themes/gray_textured/arrow-down-pre.png
%%DATADIR%%/themes/gray_textured/arrow-down.png
@@ -795,17 +860,3 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
@dirrm %%DATADIR%%/dcpprofiles
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/256x256/apps
-@dirrmtry share/icons/hicolor/256x256
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons