aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-04-19 10:42:36 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-04-19 10:42:36 +0000
commite1265622205c0a433caf60c8b410ad26b4676abf (patch)
tree906e372fc62046e4c9d00c5cad4e0540b4f02ae9 /graphics
parent846f70f92d00af7e1eab0a3209474a4a2d4faa8d (diff)
downloadports-e1265622205c0a433caf60c8b410ad26b4676abf.tar.gz
ports-e1265622205c0a433caf60c8b410ad26b4676abf.zip
graphics/py-ueberzug: add USE_CSTD=c99 to fix build on GCC-based systems:
Xshm/Xshm.c:209: error: 'for' loop initial declaration used outside C99 mode
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-ueberzug/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/py-ueberzug/Makefile b/graphics/py-ueberzug/Makefile
index 979f7fa5fb8f..997b89a652b1 100644
--- a/graphics/py-ueberzug/Makefile
+++ b/graphics/py-ueberzug/Makefile
@@ -16,6 +16,7 @@ RUN_DEPENDS= ${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}xlib>=0:x11-toolkits/py-xlib@${PY_FLAVOR}
USES= localbase python:3.6+ shebangfix xorg
+USE_CSTD= c99
USE_GITHUB= yes
GH_ACCOUNT= seebye
USE_PYTHON= autoplist concurrent distutils