aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-06 12:14:47 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-06 12:14:47 +0000
commitf5bbed8262a843799d1dbcbabac49282fec2d41e (patch)
tree357f04123e21f5c87c34b6dea20aeba1c7bd71c6 /graphics
parent9c489c4d483814810029c4d5eeedcd5ba787f060 (diff)
downloadports-f5bbed8262a843799d1dbcbabac49282fec2d41e.tar.gz
ports-f5bbed8262a843799d1dbcbabac49282fec2d41e.zip
graphics/blender: fix build on non-x86
Don't use SSE on non-x86. /wrkdirs/usr/ports/graphics/blender/work/blender-2.91.0/intern/cycles/util/../util/util_simd.h:60:14: error: unknown type name '__m128' extern const __m128 _mm_lookupmask_ps[16]; Additionally, libunwind works on more architectures.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index c7159dc67ad4..57acabb6e919 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -65,8 +65,8 @@ AVI_CMAKE_BOOL= WITH_CODEC_AVI
BULLET_CMAKE_BOOL= WITH_BULLET
CAMERATRACK_CMAKE_BOOL= WITH_LIBMV
CAMERATRACK_LIB_DEPENDS= libunwind.so:devel/libunwind
-CAMERATRACK_ONLY_FOR_ARCHS= i386 amd64
-CAMERATRACK_ONLY_FOR_ARCHS_REASON= libunwind only supports x86/amd64
+CAMERATRACK_ONLY_FOR_ARCHS= i386 amd64 aarch64 powerpc64 powerpc64le
+CAMERATRACK_ONLY_FOR_ARCHS_REASON= libunwind only supports x86/amd64/aarch64/powerpc64/powerpc64le
CINEON_CMAKE_BOOL= WITH_IMAGE_CINEON
COLLADA_CMAKE_BOOL= WITH_OPENCOLLADA
COLLADA_LIB_DEPENDS= libOpenCOLLADABaseUtils.so:graphics/opencollada \
@@ -171,6 +171,10 @@ CMAKE_ARGS+= -DWITH_GHOST_DEBUG:BOOL=ON
.include <bsd.port.options.mk>
+.if ${ARCH} != amd64 && ${ARCH} != i386
+CMAKE_ARGS+= -DWITH_CPU_SSE:BOOL=OFF
+.endif
+
.if ${LLVM_DEFAULT:M[678]0}
LLVM_VER= 90
.else