aboutsummaryrefslogtreecommitdiff
path: root/hungarian/hunspell/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-01 14:09:22 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-01 14:09:22 +0000
commit805c13c799ebd759eb9a1f4c91518ca8f919989c (patch)
treef40bc75efa466b21471ad4c02f1f749ec528f4e8 /hungarian/hunspell/Makefile
parent1ee5b15179a9cabdb33e94914b0b6c452b7c021c (diff)
downloadports-805c13c799ebd759eb9a1f4c91518ca8f919989c.tar.gz
ports-805c13c799ebd759eb9a1f4c91518ca8f919989c.zip
- Update to 1.1.9
- Fixing twice registration of documents - Fix extracting on older systems [1] PR: ports/115042 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu> (maintainer) Reported by: pointyhat (via pav, via kris) [1]
Notes
Notes: svn path=/head/; revision=196898
Diffstat (limited to 'hungarian/hunspell/Makefile')
-rw-r--r--hungarian/hunspell/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/hungarian/hunspell/Makefile b/hungarian/hunspell/Makefile
index 94fbb7eeba37..6f649804a566 100644
--- a/hungarian/hunspell/Makefile
+++ b/hungarian/hunspell/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hunspell
-PORTVERSION= 1.1.8
+PORTVERSION= 1.1.9
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
http://magyarispell.sourceforge.net/:data
@@ -15,7 +15,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code hu_HU.zip:data
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Improved Hungarian spelling checker
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_GMAKE= yes
USE_LDCONFIG= yes
@@ -29,6 +29,14 @@ PORTDOCS= README README.myspell
.include <bsd.port.pre.mk>
+# Ugly workaround for FreeBSD versions before the import of NetBSD gzip.
+do-extract:
+ @${RM} -rf ${WRKDIR}; \
+ ${MKDIR} ${WRKDIR}; \
+ cd ${WRKDIR} && ${TAR} -xzf ${_DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX};\
+ ${UNZIP_CMD} -qo ${_DISTDIR}/hu_HU.zip -d ${WRKDIR}
+
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/tools/hunspell.cxx