aboutsummaryrefslogtreecommitdiff
path: root/irc/anope
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2017-06-09 13:55:01 +0000
committerMark Felder <feld@FreeBSD.org>2017-06-09 13:55:01 +0000
commit40338eb3840d6fff638539876b6e42c99be9c890 (patch)
tree5a3abe9d62be2bf975aacf5768dded3b6cca27bc /irc/anope
parent507bd261601e89a95c3926b9cd211f4af9465cd8 (diff)
downloadports-40338eb3840d6fff638539876b6e42c99be9c890.tar.gz
ports-40338eb3840d6fff638539876b6e42c99be9c890.zip
irc/anope: Update to 2.0.5
Modernize port options Fix building with MySQL Add new REDIS option Changelog: https://github.com/anope/anope/blob/a9bf2518864a6919f7e1217016c9dec3a3b08323/docs/Changes MFH: 2017Q2
Notes
Notes: svn path=/head/; revision=442989
Diffstat (limited to 'irc/anope')
-rw-r--r--irc/anope/Makefile81
-rw-r--r--irc/anope/distinfo5
-rw-r--r--irc/anope/files/patch-CMakeLists.txt33
-rw-r--r--irc/anope/pkg-plist27
4 files changed, 48 insertions, 98 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index df16f81c2cba..032c84fc8bc9 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= anope
-PORTVERSION= 2.0.2
-PORTREVISION= 2
+PORTVERSION= 2.0.5
+PORTREVISION= 0
CATEGORIES= irc
MAINTAINER= feld@FreeBSD.org
@@ -13,7 +13,7 @@ LICENSE= GPLv2
USES= cmake:outsource shebangfix
CMAKE_ARGS+= -DINSTDIR:STRING="${LOCALBASE}/anope"
-CPPFLAGS+= "-I${LOCALBASE}/include"
+CXXFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
SHEBANG_FILES= ${WRKSRC}/src/tools/*.sh
@@ -23,83 +23,34 @@ USE_RC_SUBR= anope
SUB_FILES= pkg-message
-OPTIONS_DEFINE= GNUTLS LDAP MYSQL NLS OPENSSL PCRE POSIX SASL SQLITE STATS TRE
+OPTIONS_DEFINE= GNUTLS LDAP MYSQL NLS OPENSSL PCRE POSIX REDIS SASL SQLITE STATS TRE
OPTIONS_DEFAULT= MYSQL OPENSSL POSIX
+OPTIONS_SUB= yes
POSIX_DESC= POSIX Regex Module
STATS_DESC= Channel Statistics Module
TRE_DESC= Tre Regex Module
-NLS_USES= gettext
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
-.include <bsd.port.options.mk>
+LDAP_VARS_ON= USE_OPENLDAP=yes
-.if ${PORT_OPTIONS:MGNUTLS}
-PLIST_SUB+= GNUTLS=""
-LIB_DEPENDS+= libgnutls.so:security/gnutls
-.else
-PLIST_SUB+= GNUTLS="@comment "
-.endif
+MYSQL_USES= mysql
-.if ${PORT_OPTIONS:MLDAP}
-PLIST_SUB+= LDAP=""
-USE_OPENLDAP= yes
-.else
-PLIST_SUB+= LDAP="@comment "
-.endif
+NLS_USES= gettext
-.if ${PORT_OPTIONS:MMYSQL}
-PLIST_SUB+= MYSQL=""
-USE_MYSQL= yes
-.else
-PLIST_SUB+= MYSQL="@comment "
-.endif
+OPENSSL_USES= ssl
-.if ${PORT_OPTIONS:MOPENSSL}
-PLIST_SUB+= OPENSSL=""
-USES+= ssl
-.else
-PLIST_SUB+= OPENSSL="@comment "
-.endif
+REDIS_RUN_DEPENDS= redis:databases/redis
-.if ${PORT_OPTIONS:MPCRE}
-PLIST_SUB+= PCRE=""
-LIB_DEPENDS+= libpcre.so:devel/pcre
-.else
-PLIST_SUB+= PCRE="@comment "
-.endif
+PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
-.if ${PORT_OPTIONS:MPOSIX}
-PLIST_SUB+= POSIX=""
-.else
-PLIST_SUB+= POSIX="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSASL}
-PLIST_SUB+= SASL=""
-LIB_DEPENDS+= libsasl2.so:security/cyrus-sasl2
-.else
-PLIST_SUB+= SASL="@comment "
-.endif
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
-.if ${PORT_OPTIONS:MSQLITE}
-PLIST_SUB+= SQLITE=""
-USES+= sqlite
-.else
-PLIST_SUB+= SQLITE="@comment "
-.endif
+SQLITE_USES= sqlite
-.if ${PORT_OPTIONS:MSTATS}
-PLIST_SUB+= STATS=""
-.else
-PLIST_SUB+= STATS="@comment "
-.endif
+TRE_LIB_DEPENDS= libtre.so:textproc/libtre
-.if ${PORT_OPTIONS:MTRE}
-PLIST_SUB+= TRE=""
-LIB_DEPENDS+= libtre.so:textproc/libtre
-.else
-PLIST_SUB+= TRE="@comment "
-.endif
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
diff --git a/irc/anope/distinfo b/irc/anope/distinfo
index d37cf8a1aeda..7ab445d99ffc 100644
--- a/irc/anope/distinfo
+++ b/irc/anope/distinfo
@@ -1,2 +1,3 @@
-SHA256 (anope-anope-2.0.2_GH0.tar.gz) = 15e041bf3ebe0c86002e41162e98beb9276a910ef43628c46b58ae0a230401e2
-SIZE (anope-anope-2.0.2_GH0.tar.gz) = 1764564
+TIMESTAMP = 1497014744
+SHA256 (anope-anope-2.0.5_GH0.tar.gz) = acfaa189b05a08108838dcdd6dc6c445cc437861911a7c922599eb7b862f3109
+SIZE (anope-anope-2.0.5_GH0.tar.gz) = 1779920
diff --git a/irc/anope/files/patch-CMakeLists.txt b/irc/anope/files/patch-CMakeLists.txt
index 647edb0a99c3..59b0b8800067 100644
--- a/irc/anope/files/patch-CMakeLists.txt
+++ b/irc/anope/files/patch-CMakeLists.txt
@@ -1,27 +1,24 @@
---- CMakeLists.txt.orig 2015-03-22 19:34:50 UTC
+--- CMakeLists.txt.orig 2017-06-09 13:48:41 UTC
+++ CMakeLists.txt
-@@ -485,17 +485,17 @@ get_target_property(SERVICES_BINARY ${PR
+@@ -489,16 +489,16 @@ get_target_property(SERVICES_BINARY ${PR
get_filename_component(SERVICES_BINARY ${SERVICES_BINARY} NAME)
# At install time, create the following additional directories
--install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")")
--install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")")
-+#install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")")
-+#install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")")
+-install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")")
+-install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")")
++#install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")")
++#install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")")
if(WIN32)
- install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/runtime\")")
+ install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/runtime\")")
endif(WIN32)
# On non-Windows platforms, if RUNGROUP is set, change the permissions of the below directories, as well as the group of the data directory
--if(NOT WIN32 AND RUNGROUP)
-- install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")")
-- install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")")
-- install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\${CMAKE_INSTALL_PREFIX}\")")
--endif(NOT WIN32 AND RUNGROUP)
-+#if(NOT WIN32 AND RUNGROUP)
-+# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")")
-+# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")")
-+# install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\${CMAKE_INSTALL_PREFIX}\")")
-+#endif(NOT WIN32 AND RUNGROUP)
+ if(NOT WIN32 AND RUNGROUP)
+- install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")")
+- install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")")
+- install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}\")")
++# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")")
++# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")")
++# install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}\")")
+ endif(NOT WIN32 AND RUNGROUP)
# On Windows platforms, install extra files
if(WIN32)
- install(FILES ${Anope_SOURCE_DIR}/src/win32/anope.bat
diff --git a/irc/anope/pkg-plist b/irc/anope/pkg-plist
index f7e1fe5b174e..5a9938fcb0c8 100644
--- a/irc/anope/pkg-plist
+++ b/irc/anope/pkg-plist
@@ -202,21 +202,22 @@ anope/lib/modules/os_sxline.so
anope/lib/modules/os_update.so
anope/lib/modules/plexus.so
anope/lib/modules/ratbox.so
+anope/lib/modules/unreal4.so
anope/lib/modules/unreal.so
anope/lib/modules/webcpanel.so
-anope/locale/ca_ES/LC_MESSAGES/anope.mo
-anope/locale/de_DE/LC_MESSAGES/anope.mo
-anope/locale/el_GR/LC_MESSAGES/anope.mo
-anope/locale/en_US/LC_MESSAGES/anope.mo
-anope/locale/es_ES/LC_MESSAGES/anope.mo
-anope/locale/fr_FR/LC_MESSAGES/anope.mo
-anope/locale/hu_HU/LC_MESSAGES/anope.mo
-anope/locale/it_IT/LC_MESSAGES/anope.mo
-anope/locale/nl_NL/LC_MESSAGES/anope.mo
-anope/locale/pl_PL/LC_MESSAGES/anope.mo
-anope/locale/pt_PT/LC_MESSAGES/anope.mo
-anope/locale/ru_RU/LC_MESSAGES/anope.mo
-anope/locale/tr_TR/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/ca_ES/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/de_DE/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/el_GR/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/en_US/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/es_ES/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/fr_FR/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/hu_HU/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/it_IT/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/nl_NL/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/pl_PL/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/pt_PT/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/ru_RU/LC_MESSAGES/anope.mo
+%%NLS%%anope/locale/tr_TR/LC_MESSAGES/anope.mo
@dir(nobody,,) anope/data/backups
@dir(nobody,,) anope/data
@dir(nobody,,) anope/logs