aboutsummaryrefslogtreecommitdiff
path: root/irc/anope
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-06-19 13:03:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-06-19 13:03:29 +0000
commit4f623e0f1421197ab570dd0712fbd1722ac70d3f (patch)
treef94ecf746239fe88d1e422cdb4570e2a9ab0ff04 /irc/anope
parent34caa2cddb261cb9f7a2d4d25edcd8e9f27f3f8d (diff)
downloadports-4f623e0f1421197ab570dd0712fbd1722ac70d3f.tar.gz
ports-4f623e0f1421197ab570dd0712fbd1722ac70d3f.zip
- Update to 1.8.9
- Stage - Cleanup rc script - Take [1] Approved by: maintainer [1] Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=358404
Diffstat (limited to 'irc/anope')
-rw-r--r--irc/anope/Makefile33
-rw-r--r--irc/anope/distinfo4
-rw-r--r--irc/anope/files/anope.in16
-rw-r--r--irc/anope/pkg-plist16
4 files changed, 32 insertions, 37 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index f351317178f0..e9e16508c1cf 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= anope
-PORTVERSION= 1.8.8
+PORTVERSION= 1.8.9
CATEGORIES= irc
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/Anope%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-legacy/Anope%20${PORTVERSION}
-MAINTAINER= dhn@FreeBSD.org
+MAINTAINER= mat@FreeBSD.org
COMMENT= Set of IRC services for IRC networks
-USES= perl5 gmake
+USES= perl5 gmake desthack
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir="${LOCALBASE}/lib" \
--includedir="${LOCALBASE}/include" \
- --with-bindir=${PREFIX}/libexec/anope \
- --with-datadir=${DATADIR} \
- --with-rungroup=ircdru
+ --with-bindir=\$${${DESTDIRNAME}}${PREFIX}/libexec/anope \
+ --with-datadir=\$${${DESTDIRNAME}}${DATADIR}
PORTDOCS= BUGS COPYING DEFCON EVENTS \
FAQ INSTALL IRCD MODULES MYSQL \
@@ -27,7 +26,9 @@ USE_RC_SUBR= anope
OPTIONS_DEFINE= MYSQL
OPTIONS_DEFAULT= MYSQL
-NO_STAGE= yes
+MYSQL_USE= mysql=yes
+MYSQL_CONFIGURE_WITH= mysql
+
.include <bsd.port.pre.mk>
# XXX Add here other arch which needs -fPIC :-)
@@ -35,24 +36,16 @@ NO_STAGE= yes
CFLAGS+= -fPIC
.endif
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-.else
-CONFIGURE_ARGS+= --without-mysql
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|ja_utf8|ja|g' ${WRKSRC}/lang/Makefile
${MV} ${WRKSRC}/lang/ja_utf8.l ${WRKSRC}/lang/ja.l
pre-install:
- @${MKDIR} ${PREFIX}/libexec/anope
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/anope
+ @${MKDIR} ${STAGEDIR}${DATADIR}
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/docs/,} ${DOCSDIR}/
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/docs/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/irc/anope/distinfo b/irc/anope/distinfo
index d794ac18cbb1..5c8b0ac9a3e6 100644
--- a/irc/anope/distinfo
+++ b/irc/anope/distinfo
@@ -1,2 +1,2 @@
-SHA256 (anope-1.8.8.tar.gz) = 20bfc2db4be7475b6065d3eac0c904f69a6925d30ced22098341e5a2bbb62a77
-SIZE (anope-1.8.8.tar.gz) = 1665488
+SHA256 (anope-1.8.9.tar.gz) = 484ff70260ccd36fa153f121fb49adb8c74d77e0508e616b1a85440c2c8370cf
+SIZE (anope-1.8.9.tar.gz) = 1646505
diff --git a/irc/anope/files/anope.in b/irc/anope/files/anope.in
index 124e3947dd84..f4b6aa18ac9a 100644
--- a/irc/anope/files/anope.in
+++ b/irc/anope/files/anope.in
@@ -1,29 +1,31 @@
#!/bin/sh
#
+# $FreeBSD$
+#
# PROVIDE: anope
# REQUIRE: LOGIN mysql
+# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable anope:
-#anope_enable="YES"
+# anope_enable=YES
#
# Also, to prevent running anope as root You may use
# anope_user="nobody"
# and
-# anope_chroot="%%PREFIX%%/share/anope"
+# anope_chdir="%%PREFIX%%/share/anope"
#
. /etc/rc.subr
-name="anope"
+name=anope
rcvar=anope_enable
-command=%%PREFIX%%/libexec/anope/services
-
-# set defaults
load_rc_config $name
-: ${anope_enable="NO"}
+command=%%PREFIX%%/libexec/anope/services
+
+anope_enable=${anope_enable:-"NO"}
run_rc_command "$1"
diff --git a/irc/anope/pkg-plist b/irc/anope/pkg-plist
index 47bb6db31bf8..c803dd55210e 100644
--- a/irc/anope/pkg-plist
+++ b/irc/anope/pkg-plist
@@ -176,11 +176,11 @@ libexec/anope/tools/epona2anope
%%DATADIR%%/modules/viagra.so
%%DATADIR%%/mydbgen
%%DATADIR%%/tables.sql
-@dirrm %%DATADIR%%/modules/runtime
-@dirrm %%DATADIR%%/modules
-@dirrm %%DATADIR%%/logs
-@dirrm %%DATADIR%%/languages
-@dirrm %%DATADIR%%/backups
-@dirrm %%DATADIR%%
-@dirrm libexec/anope/tools
-@dirrm libexec/anope
+@dirrmtry libexec/anope/tools
+@dirrmtry libexec/anope
+@dirrmtry %%DATADIR%%/backups
+@dirrmtry %%DATADIR%%/languages
+@dirrmtry %%DATADIR%%/logs
+@dirrmtry %%DATADIR%%/modules/runtime
+@dirrmtry %%DATADIR%%/modules
+@dirrmtry %%DATADIR%%