aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-26 20:43:40 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-26 20:43:40 +0000
commit469f80fed3695ccc029f8da93d0f63cea05d94e8 (patch)
treee6cd035bafcc999d5f0fbbb337603781defc9532 /irc/bitchx/Makefile
parent3a4696995560025dafe4ba8bed9461f59f8cadee (diff)
downloadports-469f80fed3695ccc029f8da93d0f63cea05d94e8.tar.gz
ports-469f80fed3695ccc029f8da93d0f63cea05d94e8.zip
- Fix plugins option
- Remove aim, cavlink,identd and nap plugins (won't build with gcc-4.2) - Bump portrevision
Notes
Notes: svn path=/head/; revision=217629
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 6130adaf1fb0..15020f1584d4 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitchX
PORTVERSION= 1.1.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= irc
MASTER_SITES= SF
DISTNAME= ircii-pana-1.1-final
@@ -80,8 +80,9 @@ CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
.endif
.if defined(WITH_PLUGINS)
-PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,\
-fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
+PLUGINS=\
+abot,acro,arcfour,autocycle,blowfish,encrypt,fserv,hint,pkga,possum,qbx,qmail,scan,wavplay
+CONFIGURE_ARGS+= --with-plugins=${PLUGINS}
PLIST_SUB+= PLUGINS=""
.else
CONFIGURE_ARGS+=--without-plugins
@@ -95,8 +96,8 @@ PLIST_SUB+= XMMS=""
PLIST_SUB+= XMMS="@comment "
.endif
.if (defined(WITH_XMMS) && defined(WITH_PLUGINS))
-PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,\
-hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
+PLUGINS=\
+abot,acro,arcfour,autocycle,blowfish,encrypt,fserv,hint,pkga,possum,qbx,qmail,scan,wavplay,xmms
.endif
.if (defined(WITH_PLUGINS) || defined(WITH_XMMS))