aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-22 16:35:48 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-22 16:35:48 +0000
commit6b3ad76219426c08caa2703ffae5e42f136f1abf (patch)
treefe5b5750fb5f3dddb63761f621e423453debebbb /irc/bitchx/Makefile
parentc5dd43d4e10e695fb06c0aa880d2654ad4e2ddbb (diff)
downloadports-6b3ad76219426c08caa2703ffae5e42f136f1abf.tar.gz
ports-6b3ad76219426c08caa2703ffae5e42f136f1abf.zip
Notes
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 38b2c0ea844a..64db74b4ee14 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -13,13 +13,13 @@ MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/ \
ftp://ftp.cyberpunkz.org/pub/BitchX/source/ \
ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
-.if !defined(WITH_TCL)
-DISTNAME= ircii-pana-${PORTVERSION}
-.else
DISTFILES= ircii-pana-${PORTVERSION}${EXTRACT_SUFX} \
- freebsd4-tcl83-bx1.0c19-tcl.o:tcl
-EXTRACT_ONLY= ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
+ ircii-pana-${PORTVERSION}${EXTRACT_SUFX}.sig
+.if defined(WITH_TCL)
+DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl \
+ freebsd4-tcl83-bx1.0c19-tcl.o.sig:tcl
.endif
+EXTRACT_ONLY= ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= arved@FreeBSD.org
COMMENT?= "An alternative ircII color client with optional GTK/GNOME support"
@@ -104,6 +104,20 @@ CONFIGURE_ARGS+= --with-plugins=${PLUGINS}
.endif
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+.if exists(${PREFIX}/bin/gpg)
+pre-extract:
+ @${ECHO_CMD} "===> Verifying GnuPG Signatures."
+ -gpg --keyserver pgp.mit.edu --recv-key 42D1F77C
+ cd ${DISTDIR}; gpg --verify ircii-pana-${PORTVERSION}${EXTRACT_SUFX}.sig \
+ ircii-pana-${PORTVERSION}${EXTRACT_SUFX}
+.if defined(WITH_TCL)
+ cd ${DISTDIR}; gpg --verify freebsd4-tcl83-bx1.0c19-tcl.o.sig \
+ freebsd4-tcl83-bx1.0c19-tcl.o
+.endif
+.else
+ @${ECHO_CMD} "===> GnuPG not installed. Signatures can not be verified"
+.endif
+
pre-patch:
.if defined(WITH_LATIN)
${REINPLACE_CMD} -e 's|#undef LATIN1|#define LATIN1|g' ${WRKSRC}/include/config.h