aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-11-19 04:01:48 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-11-19 04:01:48 +0000
commit916e01dcd837b84f67b74a7ba29a95dfe918ced3 (patch)
treef6f527ed3ee9c159d9e01bf1b7395ffbf10cef9e /irc/bitchx/Makefile
parent39a5f36418c4c6689edbe92f23277c86ba76f51d (diff)
downloadports-916e01dcd837b84f67b74a7ba29a95dfe918ced3.tar.gz
ports-916e01dcd837b84f67b74a7ba29a95dfe918ced3.zip
Copy irc/bitchx to irc/bitchx-devel and attach to the build.
Revert irc/bitchx back to 1.1.0.1. Set LATEST_LINK for irc/bitchx-devel appropriately. PR: ports/172294, ports/172295 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=307552
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile39
1 files changed, 20 insertions, 19 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 11cc9d5aa7c9..c3e8db6d1d60 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -1,30 +1,33 @@
# Created by: Jimbo Bahooli <griffin@blackhole.iceworld.org>
# $FreeBSD$
+#
PORTNAME= BitchX
-PORTVERSION= 1.2
+PORTVERSION= 1.1.0.1
+PORTREVISION= 4
+PORTEPOCH= 1
CATEGORIES+= irc
-DISTNAME= ${PORTNAME}-${PORTNAME}${PORTVERSION}-${GH_COMMIT}
+MASTER_SITES= SF/bitchx/ircii-pana/ircii-pana-1.1
+DISTNAME= ircii-pana-1.1-final
MAINTAINER?= c.petrik.sosa@gmail.com
COMMENT?= Feature-rich scriptable IRC client
-USE_GITHUB= yes
-GH_ACCOUNT= ${PORTNAME}
-GH_PROJECT= ${PORTNAME}1.2
-GH_TAGNAME= master
-GH_COMMIT= a22b86f
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --libdir="${PREFIX}/share"
-USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/BitchX
USE_PERL5= yes
+GNU_CONFIGURE= yes
WANT_GNOME= yes
+USE_GMAKE= yes
DOCSDIR= ${PREFIX}/share/bx/help
PORTDOCS= *
+CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
+ --bindir="${PREFIX}/bin" \
+ --datadir="${PREFIX}/share" \
+ --libdir="${PREFIX}/share"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
-MAN1= ${PORTNAME}.1
+MAN1= BitchX.1
OPTIONS_DEFINE= ESOUND GNOME IPV6 LATIN PLUGINS SSL XMMS
@@ -64,9 +67,8 @@ PLIST_SUB+= GNOME="@comment " NOGNOME=""
.endif
.if ${PORT_OPTIONS:MPLUGINS}
-PLUGINS= abot acro aim arcfour autocycle blowfish cavlink cdrom \
- encrypt europa fserv hint nap nicklist pkga possum qbx \
- qmail wavplay
+PLUGINS= abot acro arcfour autocycle blowfish cdrom encrypt scan \
+ europa fserv hint nicklist pkga possum qbx qmail wavplay
PLIST_SUB+= PLUGINS=""
.else
PLIST_SUB+= PLUGINS="@comment "
@@ -95,9 +97,9 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MGNOME}
- ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX
+ ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX-1.1-final
.else
- ${STRIP_CMD} ${PREFIX}/bin/BitchX
+ ${STRIP_CMD} ${PREFIX}/bin/BitchX-1.1-final
${STRIP_CMD} ${PREFIX}/bin/scr-bx
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -105,7 +107,6 @@ post-install:
cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
-# Ensure that `@dirrm share/bx' will be appended last (after PORTDOCS stuff)
add-plist-post:
@${ECHO_CMD} "@dirrm share/bx" >> ${TMPPLIST}
.if (${PREFIX} != ${LOCALBASE} && ${PREFIX} != ${LINUXBASE} && ${PREFIX} != "/usr")