aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-09-07 18:38:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-09-07 18:38:25 +0000
commitdec5b2ef726c3e9cbdc9fe255930e89a403c6dd8 (patch)
tree763c4dc6d7acc17764a809b891584643b72d7a4b /irc/bitchx/Makefile
parentbd503ebb02ed0636a557308e726810e7b2984d20 (diff)
downloadports-dec5b2ef726c3e9cbdc9fe255930e89a403c6dd8.tar.gz
ports-dec5b2ef726c3e9cbdc9fe255930e89a403c6dd8.zip
Notes
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile32
1 files changed, 2 insertions, 30 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 12f5f24cc800..d725991432da 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -28,14 +28,12 @@ PORTDOCS= *
DATADIR= ${PREFIX}/share/bx
MAN1= BitchX.1
-OPTIONS_DEFINE= ESOUND GNOME IPV6 LATIN PLUGINS SSL XMMS
+OPTIONS_DEFINE= IPV6 LATIN PLUGINS SSL DOCS
-GNOME_DESC= Legacy GTK/GNOME frontend
LATIN_DESC= Recommended for ISO-8859-1 display
PLUGINS_DESC= Build a handful of BitchX plugins
-XMMS_DESC= Build XMMS plugin
-OPTIONS_DEFAULT= IPV6 PLUGINS SSL
+OPTIONS_DEFAULT=PLUGINS SSL
.include <bsd.port.options.mk>
@@ -47,20 +45,6 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --with-ssl
.endif
-.if ${PORT_OPTIONS:MGNOME} || ${PORT_OPTIONS:MESOUND}
-USE_GNOME= gnomelibs
-CONFIGURE_ARGS+= --with-gtk
-. if ${PORT_OPTIONS:MESOUND}
-USE_GNOME+= esound
-CONFIGURE_ARGS+= --enable-sound
-. endif
-CFLAGS+= -I${LOCALBASE}/include/gnome-1.0
-PLIST_SUB+= NOGNOME="@comment " GNOME=""
-.else
-CONFIGURE_ARGS+= --without-gtk
-PLIST_SUB+= GNOME="@comment " NOGNOME=""
-.endif
-
.if ${PORT_OPTIONS:MPLUGINS}
PLUGINS= abot acro aim arcfour autocycle blowfish cavlink cdrom encrypt \
europa fserv hint nap nicklist pkga possum qbx qmail wavplay
@@ -69,14 +53,6 @@ PLIST_SUB+= PLUGINS=""
PLIST_SUB+= PLUGINS="@comment "
.endif
-.if ${PORT_OPTIONS:MXMMS}
-LIB_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-PLUGINS+= xmms
-PLIST_SUB+= XMMS=""
-.else
-PLIST_SUB+= XMMS="@comment "
-.endif
-
.if !empty(PLUGINS)
CONFIGURE_ARGS+= --with-plugins="${PLUGINS:C/\$$/,/g}"
.else
@@ -91,12 +67,8 @@ post-patch:
${REINPLACE_CMD} -e 's|bzip2|true|g' ${WRKSRC}/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MGNOME}
- ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX
-.else
${STRIP_CMD} ${PREFIX}/bin/BitchX
${STRIP_CMD} ${PREFIX}/bin/scr-bx
-.endif
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${DOCSDIR}