aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-05-31 09:48:32 +0000
committerChris Rees <crees@FreeBSD.org>2013-05-31 09:48:32 +0000
commitf610ee2f9c164ed8bb2d8cb387ed7caf4c572086 (patch)
tree8f7b4931ff668dddbc0f4424167d288fb8e63782 /irc/bitchx/Makefile
parentad3f3827f79916eb9783bcfa84c7a67adbf63b92 (diff)
downloadports-f610ee2f9c164ed8bb2d8cb387ed7caf4c572086.tar.gz
ports-f610ee2f9c164ed8bb2d8cb387ed7caf4c572086.zip
Notes
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile39
1 files changed, 15 insertions, 24 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 1ae134bd60ce..419f021c2dfa 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -2,30 +2,29 @@
# $FreeBSD$
PORTNAME= BitchX
-PORTVERSION= 1.1.0.1
-PORTREVISION= 4
+DISTVERSION= 1.2-final
PORTEPOCH= 1
CATEGORIES+= irc
-MASTER_SITES= SF/bitchx/ircii-pana/ircii-pana-1.1
-DISTNAME= ircii-pana-1.1-final
+MASTER_SITES= http://bitchx.ca/
MAINTAINER?= dan.mashal@gmail.com
COMMENT?= Feature-rich scriptable IRC client
-WRKSRC= ${WRKDIR}/BitchX
+WRKSRC= ${WRKDIR}/${DISTNAME:C,-final$,,}
USE_PERL5= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
USE_GMAKE= yes
-DOCSDIR= ${PREFIX}/share/bx/help
-PORTDOCS= *
CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
--datadir="${PREFIX}/share" \
--libdir="${PREFIX}/share"
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+PLIST_SUB+= DISTVERSION=${DISTVERSION}
+DOCSDIR= ${PREFIX}/share/bx/help
+PORTDOCS= *
+DATADIR= ${PREFIX}/share/bx
MAN1= BitchX.1
OPTIONS_DEFINE= ESOUND GNOME IPV6 LATIN PLUGINS SSL XMMS
@@ -37,11 +36,7 @@ XMMS_DESC= Build XMMS plugin
OPTIONS_DEFAULT= IPV6 PLUGINS SSL
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
@@ -66,8 +61,8 @@ PLIST_SUB+= GNOME="@comment " NOGNOME=""
.endif
.if ${PORT_OPTIONS:MPLUGINS}
-PLUGINS= abot acro arcfour autocycle blowfish cdrom encrypt scan \
- europa fserv hint nicklist pkga possum qbx qmail wavplay
+PLUGINS= abot acro aim arcfour autocycle blowfish cavlink cdrom encrypt \
+ europa fserv hint nap nicklist pkga possum qbx qmail wavplay
PLIST_SUB+= PLUGINS=""
.else
PLIST_SUB+= PLUGINS="@comment "
@@ -96,9 +91,9 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MGNOME}
- ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX-1.1-final
+ ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX
.else
- ${STRIP_CMD} ${PREFIX}/bin/BitchX-1.1-final
+ ${STRIP_CMD} ${PREFIX}/bin/BitchX
${STRIP_CMD} ${PREFIX}/bin/scr-bx
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -106,12 +101,8 @@ post-install:
cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
+# Ensure that `@dirrm share/bx' will be appended last (after PORTDOCS stuff)
add-plist-post:
- @${ECHO_CMD} "@dirrm share/bx" >> ${TMPPLIST}
-.if (${PREFIX} != ${LOCALBASE} && ${PREFIX} != ${LINUXBASE} && ${PREFIX} != "/usr")
- @${ECHO_CMD} "@unexec rmdir %D 2> /dev/null || true" >> ${TMPPLIST}
-.else
- @${DO_NADA}
-.endif
+ @${ECHO_CMD} "@dirrm ${DATADIR_REL}" >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>