aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-04-04 20:52:06 +0000
committerRene Ladan <rene@FreeBSD.org>2014-04-04 20:52:06 +0000
commitf94798f73086061d790abf5a1baf478f49850a49 (patch)
treee12acb5025dd65439e96a266c9efbd50de63b07f /irc/bitchx/Makefile
parenta9eaceffbbe9fb629b001f654b3ba46b10bbaa40 (diff)
downloadports-f94798f73086061d790abf5a1baf478f49850a49.tar.gz
ports-f94798f73086061d790abf5a1baf478f49850a49.zip
Notes
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 950c8b075456..24a3b0e2d4be 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -25,7 +25,6 @@ PLIST_SUB+= DISTVERSION=${DISTVERSION}
DOCSDIR= ${PREFIX}/share/bx/help
PORTDOCS= *
DATADIR= ${PREFIX}/share/bx
-MAN1= BitchX.1
OPTIONS_DEFINE= IPV6 LATIN PLUGINS SSL DOCS
@@ -34,7 +33,6 @@ PLUGINS_DESC= Build a handful of BitchX plugins
OPTIONS_DEFAULT=PLUGINS SSL
-NO_STAGE= yes
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.options.mk>
@@ -68,11 +66,11 @@ post-patch:
${REINPLACE_CMD} -e 's|bzip2|true|g' ${WRKSRC}/Makefile.in
post-install:
- ${STRIP_CMD} ${PREFIX}/bin/BitchX
- ${STRIP_CMD} ${PREFIX}/bin/scr-bx
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/BitchX
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scr-bx
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
# Ensure that `@dirrm share/bx' will be appended last (after PORTDOCS stuff)