aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2015-01-29 13:13:59 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2015-01-29 13:13:59 +0000
commitfb5d6af4c411f902934cb55e8b71b7340cca076b (patch)
treeff190215e1658aa19ddf768f42f33c656fea6d6d /irc/bitchx
parent8caef19761f755e618e5cf885bccf7c0ed17714a (diff)
downloadports-fb5d6af4c411f902934cb55e8b71b7340cca076b.tar.gz
ports-fb5d6af4c411f902934cb55e8b71b7340cca076b.zip
irc/bitchx: update to 1.2.1
- update to 1.2.1 - use OPTIONS helpers - remove unnecessary Perl depencency - remove unnecessary GCC dependency - Add support for hebrew language (as option) - Add helpful toggles (as option - Kill files/ directory PR: 195526 Differential Revision: https://reviews.freebsd.org/D1710 Submitted by: Chris Petrik <chris@bsdjunk.com> Approved by: koobs (mentor)
Notes
Notes: svn path=/head/; revision=378116
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile73
-rw-r--r--irc/bitchx/distinfo4
-rw-r--r--irc/bitchx/files/patch-include-config.h33
-rw-r--r--irc/bitchx/files/patch-source-Makefile.in19
-rw-r--r--irc/bitchx/pkg-plist1
5 files changed, 35 insertions, 95 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index b41f77b4180a..15ab91e6bc41 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -1,21 +1,17 @@
# Created by: Jimbo Bahooli <griffin@blackhole.iceworld.org>
# $FreeBSD$
-PORTNAME= BitchX
-DISTVERSION= 1.2-final
-PORTREVISION?= 3
+PORTNAME= bitchx
+PORTVERSION= 1.2.1
PORTEPOCH= 1
CATEGORIES+= irc
-MASTER_SITES= http://bitchx.ca/
+MASTER_SITES= SF/${PORTNAME}/ircii-pana/${PORTNAME}-${DISTVERSION}
-MAINTAINER?= dan.mashal@gmail.com
-# Co-maintainer: Chris Petrik <c.petrik.sosa@gmail.com> (PR/181627)
-COMMENT?= Feature-rich scriptable IRC client
+MAINTAINER= dan.mashal@gmail.com
+# Co-maintainer: Chris Petrik <chris@bsdjunk.com> (PR/181627)
+COMMENT= Feature-rich scriptable IRC client
-WRKSRC= ${WRKDIR}/${DISTNAME:C,-final$,,}
-
-USES= gmake perl5
-USE_GCC= yes # PR: 186425
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
@@ -23,61 +19,56 @@ CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--libdir="${PREFIX}/share"
LIBS+= -L${LOCALBASE}/lib
+OPTIONS_SUB= yes
+
PLIST_SUB+= DISTVERSION=${DISTVERSION}
DOCSDIR= ${PREFIX}/share/bx/help
PORTDOCS= *
DATADIR= ${PREFIX}/share/bx
-OPTIONS_DEFINE= IPV6 LATIN PLUGINS SSL DOCS
+OPTIONS_DEFINE= DOCS HEBREW IPV6 LATIN PLUGINS SSL TOGGLES
LATIN_DESC= Recommended for ISO-8859-1 display
PLUGINS_DESC= Build a handful of BitchX plugins
-
-OPTIONS_DEFAULT=PLUGINS SSL
+HEBREW_DESC= Add support for hebrew language
+TOGGLES_DESC= Disable away,kick_ops,auto_rejoin
+OPTIONS_DEFAULT= PLUGINS SSL
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
+IPV6_CONFIGURE_ENABLE= ipv6
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= --with-ssl
-USE_OPENSSL= yes
-.endif
+SSL_CONFIGURE_WITH= ssl
+SSL_USE= openssl=yes
-.if ${PORT_OPTIONS:MPLUGINS}
-PLUGINS= abot acro aim arcfour autocycle blowfish cavlink cdrom encrypt \
- europa fserv hint nap nicklist pkga possum qbx qmail wavplay
-PLIST_SUB+= PLUGINS=""
-.else
-PLIST_SUB+= PLUGINS="@comment "
-.endif
+PLUGINS_CONFIGURE_WITH= plugins="${PLUGIN_LIST:C/\$$/,/g}"
-.if !empty(PLUGINS)
-CONFIGURE_ARGS+= --with-plugins="${PLUGINS:C/\$$/,/g}"
-.else
-CONFIGURE_ARGS+= --without-plugins
-.endif
+PLUGIN_LIST= abot acro aim arcfour autocycle blowfish cavlink cdrom encrypt \
+ europa fserv hint nap nicklist pkga possum qbx qmail wavplay
+.include <bsd.port.options.mk>
post-patch:
.if ${PORT_OPTIONS:MLATIN}
${REINPLACE_CMD} -e 's|#undef LATIN1|#define LATIN1|' \
${WRKSRC}/include/config.h
.endif
+.if ${PORT_OPTIONS:MHEBREW}
+ ${REINPLACE_CMD} -e 's|#undef WANT_HEBREW|#define WANT_HEBREW|' \
+ ${WRKSRC}/include/config.h
+.endif
+.if ${PORT_OPTIONS:MTOGGLES}
+ ${REINPLACE_CMD} -e 's|DEFAULT_AUTO_AWAY ON|DEFAULT_AUTO_AWAY OFF|' \
+ ${WRKSRC}/include/config.h
+ ${REINPLACE_CMD} -e 's|DEFAULT_KICK_OPS ON|DEFAULT_KICK_OPS OFF|' \
+ ${WRKSRC}/include/config.h
+ ${REINPLACE_CMD} -e 's|DEFAULT_AUTO_REJOIN ON|DEFAULT_AUTO_REJOIN OFF|' \
+ ${WRKSRC}/include/config.h
+.endif
${REINPLACE_CMD} -e 's|bzip2|true|g' ${WRKSRC}/Makefile.in
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/BitchX
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scr-bx
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
-# Ensure that `@dirrm share/bx' will be appended last (after PORTDOCS stuff)
-add-plist-post:
- @${ECHO_CMD} "@dirrm ${DATADIR_REL}" >> ${TMPPLIST}
-
.include <bsd.port.mk>
diff --git a/irc/bitchx/distinfo b/irc/bitchx/distinfo
index bad40ef64d9b..1534435b9e43 100644
--- a/irc/bitchx/distinfo
+++ b/irc/bitchx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (BitchX-1.2-final.tar.gz) = 7058d4be640c881fe91cbda6701b271c47846e0d3d7a13b52a3a36948094ec36
-SIZE (BitchX-1.2-final.tar.gz) = 2609717
+SHA256 (bitchx-1.2.1.tar.gz) = 2d270500dd42b5e2b191980d584f6587ca8a0dbda26b35ce7fadb519f53c83e2
+SIZE (bitchx-1.2.1.tar.gz) = 2549182
diff --git a/irc/bitchx/files/patch-include-config.h b/irc/bitchx/files/patch-include-config.h
deleted file mode 100644
index 7c46ba4760f5..000000000000
--- a/irc/bitchx/files/patch-include-config.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- include/config.h.old Wed Mar 14 11:20:48 2001
-+++ include/config.h Wed Mar 14 11:23:51 2001
-@@ -225,7 +225,7 @@
- * in the client. defining this variable to 1 allows that happen. It also
- * adds a HEBREW_TOGGLE variable which can turn this feature on/off
- */
--#undef WANT_HEBREW
-+#define WANT_HEBREW
-
- /* if you use cidentd the filename is called .authlie instead of .noident.
- * as well some modifications to the format of the file were made. So we
-@@ -480,9 +480,9 @@
- #define DEFAULT_AINV 0
- #define DEFAULT_ANNOY_KICK OFF
- #define DEFAULT_AOP_VAR OFF
--#define DEFAULT_AUTO_AWAY ON
--#define DEFAULT_KICK_OPS ON
--#define DEFAULT_AUTO_REJOIN ON
-+#define DEFAULT_AUTO_AWAY OFF
-+#define DEFAULT_KICK_OPS OFF
-+#define DEFAULT_AUTO_REJOIN OFF
- #define DEFAULT_DEOPFLOOD ON
- #if defined(__EMXPM__) || defined(WIN32)
- #define DEFAULT_CODEPAGE 437
-@@ -684,7 +684,7 @@
- #endif
-
- #undef PARANOID /* #define this if your paranoid about dcc hijacking */
--#undef WANT_CHAN_NICK_SERV /* do we want to include some chan/nick/oper server commands */
-+#define WANT_CHAN_NICK_SERV /* do we want to include some chan/nick/oper server commands */
-
- /* new epic stuff */
- #define OLD_STATUS_S_EXPANDO_BEHAVIOR
diff --git a/irc/bitchx/files/patch-source-Makefile.in b/irc/bitchx/files/patch-source-Makefile.in
deleted file mode 100644
index 1de368fa30af..000000000000
--- a/irc/bitchx/files/patch-source-Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- source/Makefile.in.orig Fri Apr 11 03:09:07 2003
-+++ source/Makefile.in Tue Mar 30 14:44:20 2004
-@@ -37,7 +37,7 @@
- IRCLIB = @IRCLIB@
-
- CC = @CC@
--DEFS = @INCLUDES@
-+DEFS = @INCLUDES@ @CPPFLAGS@
- LIBS = @LIBS@
-
- # Tcl library.
-@@ -51,6 +51,7 @@
- # Set this to -g if you want to be able to debug the client, otherwise
- # use -O to have the compiler do some optimization instead.
- CFLAGS = @CFLAGS@
-+CPPFLAGS= @CPPFLAGS@
-
- # Set this to -s if you want the binary to be stripped.
- LDFLAGS = @LDFLAGS@
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index 349ff66aae70..d504cee4a076 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -7,6 +7,7 @@ man/man1/BitchX.1.gz
%%DATADIR%%/BitchX.ircnames
%%DATADIR%%/BitchX.quit
%%DATADIR%%/BitchX.kick
+@dir %%DATADIR%%/plugins
%%PLUGINS%%%%DATADIR%%/plugins/BitchX.hints
%%PLUGINS%%%%DATADIR%%/plugins/acro.so
%%PLUGINS%%%%DATADIR%%/plugins/aim.so