aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee-facebook
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2017-03-30 07:41:50 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2017-03-30 07:41:50 +0000
commit4d0265e987165be9c92207d5c5f293956470b62c (patch)
tree29814c3473a5cc4c84079ce7dba69598a2d0da3f /irc/bitlbee-facebook
parentc46eed8def18aa0aabf360c5ca93e3c8284421d5 (diff)
downloadports-4d0265e987165be9c92207d5c5f293956470b62c.tar.gz
ports-4d0265e987165be9c92207d5c5f293956470b62c.zip
irc/bitlbee-facebook: update to 1.1.0 + patch for issue #139
Notes
Notes: svn path=/head/; revision=437274
Diffstat (limited to 'irc/bitlbee-facebook')
-rw-r--r--irc/bitlbee-facebook/Makefile6
-rw-r--r--irc/bitlbee-facebook/distinfo6
-rw-r--r--irc/bitlbee-facebook/files/patch-issue-13948
3 files changed, 53 insertions, 7 deletions
diff --git a/irc/bitlbee-facebook/Makefile b/irc/bitlbee-facebook/Makefile
index 1d756c3f977c..8335cbdc3956 100644
--- a/irc/bitlbee-facebook/Makefile
+++ b/irc/bitlbee-facebook/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= bitlbee-facebook
-PORTVERSION= 1.0.0
+PORTVERSION= 1.1.0
DISTVERSIONPREFIX=v
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= irc
@@ -22,8 +21,7 @@ USE_GNOME= glib20
GNU_CONFIGURE= yes
USE_GITHUB= yes
-GH_ACCOUNT= gahr
-GH_TAGNAME= 20170329
+GH_ACCOUNT= bitlbee
MAKE_JOBS_UNSAFE= yes
diff --git a/irc/bitlbee-facebook/distinfo b/irc/bitlbee-facebook/distinfo
index d6513971e0da..011161f235dc 100644
--- a/irc/bitlbee-facebook/distinfo
+++ b/irc/bitlbee-facebook/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490796410
-SHA256 (gahr-bitlbee-facebook-v1.0.0-20170329_GH0.tar.gz) = 0e7644f789b24570ce20cb96bd3fc21afee31c063bfc60d0586e5b8fc7ce37f4
-SIZE (gahr-bitlbee-facebook-v1.0.0-20170329_GH0.tar.gz) = 65531
+TIMESTAMP = 1490859018
+SHA256 (bitlbee-bitlbee-facebook-v1.1.0_GH0.tar.gz) = ac6d72b0f5b10971ff811fed5cdb9e4fdded43174fe8c16b1bfe7bbfa6c11088
+SIZE (bitlbee-bitlbee-facebook-v1.1.0_GH0.tar.gz) = 66317
diff --git a/irc/bitlbee-facebook/files/patch-issue-139 b/irc/bitlbee-facebook/files/patch-issue-139
new file mode 100644
index 000000000000..541b6a711c63
--- /dev/null
+++ b/irc/bitlbee-facebook/files/patch-issue-139
@@ -0,0 +1,48 @@
+--- facebook/facebook-api.h.orig
++++ facebook/facebook-api.h
+@@ -89,26 +89,36 @@
+ #define FB_API_SECRET "374e60f8b9bb6b8cbb30f78030438895"
+
+ /**
++ * FB_ORCA_AGENT
++ *
++ * The part of the user agent that looks like the official client, since the
++ * server started checking this.
++ *
++ * We announce ourselves as compatible with Orca-Android 38.0 since that's the
++ * closest version to the last major protocol update. Some parts use older
++ * features, some parts use newer ones.
++ *
++ * Fun fact: this version sends old-style MQIsdp CONNECT messages for the first
++ * connection, with JSON payloads instead of compressed thrift.
++ *
++ */
++
++#define FB_ORCA_AGENT "[FBAN/Orca-Android;FBAV/38.0.0.22.155;FBBV/14477681]"
++
++/**
+ * FB_API_AGENT:
+ *
+ * The HTTP User-Agent header.
+ */
+-#define FB_API_AGENT "Facebook plugin / BitlBee / " PACKAGE_VERSION
++#define FB_API_AGENT "Facebook plugin / BitlBee / " PACKAGE_VERSION " " FB_ORCA_AGENT
+
+ /**
+ * FB_API_MQTT_AGENT
+ *
+ * The client information string sent in the MQTT CONNECT message
+- *
+- * We announce ourselves as compatible with Orca-Android 38.0 since that's the
+- * closest version to the last major protocol update. Some parts use older
+- * features, some parts use newer ones.
+- *
+- * Fun fact: this version sends old-style MQIsdp CONNECT messages for the first
+- * connection, with JSON payloads instead of compressed thrift.
+ */
+
+-#define FB_API_MQTT_AGENT FB_API_AGENT " [FBAN/Orca-Android;FBAV/38.0.0.22.155;FBBV/14477681]"
++#define FB_API_MQTT_AGENT FB_API_AGENT
+
+
+ /**