aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2019-03-22 13:08:12 +0000
committerRenato Botelho <garga@FreeBSD.org>2019-03-22 13:08:12 +0000
commit38b4b761dec4290517a8b0f027ccd4b5356c8d3b (patch)
tree98ce33d39da2af3c0e22746887c61d8f041d1e00 /irc/bitlbee
parentb3e5c927ea9f4dfcbb4e78279ed9c90839452fc7 (diff)
downloadports-38b4b761dec4290517a8b0f027ccd4b5356c8d3b.tar.gz
ports-38b4b761dec4290517a8b0f027ccd4b5356c8d3b.zip
irc/bitlbee: Update to 3.6
While here, sort options descriptions and add missing OPTIONS for LDAP and PAM authentication
Notes
Notes: svn path=/head/; revision=496562
Diffstat (limited to 'irc/bitlbee')
-rw-r--r--irc/bitlbee/Makefile22
-rw-r--r--irc/bitlbee/distinfo6
-rw-r--r--irc/bitlbee/files/patch-configure18
-rw-r--r--irc/bitlbee/pkg-plist1
4 files changed, 18 insertions, 29 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index a27a90837ef0..e63711fd9537 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= bitlbee
-PORTVERSION= 3.5.1
-PORTREVISION= 3
+PORTVERSION= 3.6
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/ \
LOCAL/brix
@@ -16,17 +15,18 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= xmlto:textproc/xmlto \
xsltproc:textproc/libxslt
+USES= gettext-runtime gmake gnome pkgconfig
+
SUB_FILES= pkg-message
PORTDOCS= AUTHORS CHANGES CREDITS FAQ README
PORTEXAMPLES= bitlbee.conf motd.txt
HAS_CONFIGURE= yes
-USES= gettext-runtime gmake pkgconfig
USE_RC_SUBR= bitlbee
USE_GNOME= glib20
OPTIONS_SUB= yes
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES OTR
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LDAP OTR PAM
OPTIONS_SINGLE= EVENTS SSL
OPTIONS_SINGLE_EVENTS= GLIB LIBEVENT
@@ -38,15 +38,15 @@ OPTIONS_MULTI_PROTO= LIBPURPLE JABBER MSN OSCAR SKYPE TWITTER
LIBPURPLE_PREVENTS= JABBER MSN OSCAR SKYPE TWITTER
LIBPURPLE_PREVENTS_MSG= If libpurple is enabled, all native protocols must be disabled
-OTR_DESC= Off-the-Record Messaging support
+GLIB_DESC= Use glib as event handler
+LIBEVENT_BROKEN= bitlbee w/ libevent fails to start as daemon or fork
+LIBEVENT_DESC= Use libevent as event handler
LIBPURPLE_DESC= Use libpurple for protocol support
MSN_DESC= Microsoft Messenger support
OSCAR_DESC= OSCAR (ICQ) support
+OTR_DESC= Off-the-Record Messaging support
SKYPE_DESC= Skype support
TWITTER_DESC= Twitter support
-GLIB_DESC= Use glib as event handler
-LIBEVENT_DESC= Use libevent as event handler
-LIBEVENT_BROKEN= bitlbee w/ libevent fails to start as daemon or fork
OPTIONS_DEFAULT= GLIB GNUTLS JABBER OSCAR OTR TWITTER
@@ -58,12 +58,16 @@ CONFIGURE_ARGS= --config=/var/db/bitlbee \
--yahoo=0
DEBUG_CONFIGURE_ON= --debug=1
+DOCS_USES= python:build
+DOCS_CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
GLIB_CONFIGURE_ON= --events=glib
GNUTLS_CONFIGURE_ON= --ssl=gnutls
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
JABBER_CONFIGURE_OFF= --jabber=0
+LDAP_CONFIGURE_ON= --ldap=1
+LDAP_USE= OPENLDAP=yes
LIBEVENT_CONFIGURE_ON= --events=libevent --libevent=${LOCALBASE}
LIBEVENT_LIB_DEPENDS= libevent.so:devel/libevent
LIBPURPLE_CONFIGURE_ON= --purple=1
@@ -81,6 +85,7 @@ OTR_CONFIGURE_ON= --otr=1
OTR_LIB_DEPENDS= libotr.so.5:security/libotr \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
+PAM_CONFIGURE_ON= --pam=1
SKYPE_CONFIGURE_ON= --skype=1
SKYPE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Skype4Py>0:net-im/py-skype4py@${PY_FLAVOR}
SKYPE_USES= python:2.7
@@ -93,6 +98,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^install:/ s/$$/ install-dev/' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|^\(EFLAGS=.*\)|\1 ${LDFLAGS}|" \
+ -e "/include.*ldap.h/ s,-E,-I${LOCALBASE}/include -E," \
${WRKSRC}/configure
@${REINPLACE_CMD} -e "s:/etc/bitlbee/motd.txt:${ETCDIR}/motd.txt:" \
-e "s:/var/lib/bitlbee:/var/db/bitlbee:" \
diff --git a/irc/bitlbee/distinfo b/irc/bitlbee/distinfo
index 74b0d172d4f0..66c07dc912f0 100644
--- a/irc/bitlbee/distinfo
+++ b/irc/bitlbee/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487513940
-SHA256 (bitlbee-3.5.1.tar.gz) = 9636d7fd89ebb3756c13a9a3387736ca6d56ccf66ec0580d512f07b21db0fa69
-SIZE (bitlbee-3.5.1.tar.gz) = 680351
+TIMESTAMP = 1553255523
+SHA256 (bitlbee-3.6.tar.gz) = 9f15de46f29b46bf1e39fc50bdf4515e71b17f551f3955094c5da792d962107e
+SIZE (bitlbee-3.6.tar.gz) = 534961
diff --git a/irc/bitlbee/files/patch-configure b/irc/bitlbee/files/patch-configure
deleted file mode 100644
index adc8931b7321..000000000000
--- a/irc/bitlbee/files/patch-configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig 2017-01-30 20:45:59 UTC
-+++ configure
-@@ -743,15 +743,7 @@ if [ -z "$PYTHON" ]; then
- fi
-
- if [ "$doc" = "1" ]; then
-- # check this here just in case someone tries to install it in python2.4...
-- if ! $PYTHON -m xml.etree.ElementTree > /dev/null 2>&1; then
-- echo
-- echo 'ERROR: Python (>=2.5 or 3.x) is required to generate docs'
-- echo "(Use the PYTHON environment variable if it's in a weird location)"
-- exit 1
-- fi
- echo "DOC=1" >> Makefile.settings
-- echo "PYTHON=$PYTHON" >> Makefile.settings
- fi
-
- get_version
diff --git a/irc/bitlbee/pkg-plist b/irc/bitlbee/pkg-plist
index 28a0264b3000..f2e846a915b0 100644
--- a/irc/bitlbee/pkg-plist
+++ b/irc/bitlbee/pkg-plist
@@ -7,6 +7,7 @@ include/bitlbee/auth.h
include/bitlbee/base64.h
include/bitlbee/bee.h
include/bitlbee/bitlbee.h
+include/bitlbee/canohost.h
include/bitlbee/commands.h
include/bitlbee/conf.h
include/bitlbee/config.h