aboutsummaryrefslogtreecommitdiff
path: root/irc/ctrlproxy
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-23 09:54:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-23 09:54:02 +0000
commit3ab1b8443ec60e4983c4666f0e84cedab20e81d2 (patch)
treed13723a66084b6936010f3cea6404da7bbcf103b /irc/ctrlproxy
parent63d0ab27e8fc88df6e11d9fb8b37620420285dd1 (diff)
downloadports-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.tar.gz
ports-3ab1b8443ec60e4983c4666f0e84cedab20e81d2.zip
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and adjust all ports that depend on security/gnutls3 - Update mail/anubis to version 4.2 which supports gnutls 3.x - Update mail/libvmime to a development snapshot (recommended by upstream developers) PR: 191274 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=362645
Diffstat (limited to 'irc/ctrlproxy')
-rw-r--r--irc/ctrlproxy/Makefile2
-rw-r--r--irc/ctrlproxy/files/patch-src_gnutls.c18
2 files changed, 16 insertions, 4 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index b3a839c1dcb8..3ab23462b693 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ctrlproxy
PORTVERSION= 3.0.8
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= irc
MASTER_SITES= http://launchpadlibrarian.net/50016234/ \
LOCAL/ashish/
diff --git a/irc/ctrlproxy/files/patch-src_gnutls.c b/irc/ctrlproxy/files/patch-src_gnutls.c
index 78dc64b7977b..fb2c8fe15faa 100644
--- a/irc/ctrlproxy/files/patch-src_gnutls.c
+++ b/irc/ctrlproxy/files/patch-src_gnutls.c
@@ -1,6 +1,3 @@
-
-$FreeBSD$
-
--- src/gnutls.c.orig
+++ src/gnutls.c
@@ -18,7 +18,6 @@
@@ -11,6 +8,21 @@ $FreeBSD$
#include <gnutls/gnutls.h>
#include <gnutls/x509.h>
+@@ -47,11 +46,11 @@
+ static gboolean
+ verify_certificate (gnutls_session session, const char *hostname, GError **err)
+ {
+- int status;
++ int res, status;
+
+- status = gnutls_certificate_verify_peers (session);
++ res = gnutls_certificate_verify_peers2 (session, &status);
+
+- if (status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
++ if (res < 0 || status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
+ g_set_error (err, SSL_ERROR,
+ SSL_ERROR_CERTIFICATE,
+ "No SSL certificate was sent.");
@@ -452,9 +451,6 @@
static void
_gnutls_init (void)