aboutsummaryrefslogtreecommitdiff
path: root/irc/ctrlproxy
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 01:48:20 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 01:48:20 +0000
commit53b1b41eca79a65905572c4d9b1ddaaf15612672 (patch)
tree0455571708dee255a486148a32af655a05c5d163 /irc/ctrlproxy
parent123d6acb52402cb592abb042e077ebae4f6911b9 (diff)
downloadports-53b1b41eca79a65905572c4d9b1ddaaf15612672.tar.gz
ports-53b1b41eca79a65905572c4d9b1ddaaf15612672.zip
1: Stagify.
2: strip binary. Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=358063
Diffstat (limited to 'irc/ctrlproxy')
-rw-r--r--irc/ctrlproxy/Makefile24
-rw-r--r--irc/ctrlproxy/pkg-plist2
2 files changed, 14 insertions, 12 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 67088615cc0f..33600213c123 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -11,31 +11,31 @@ MASTER_SITES= http://launchpadlibrarian.net/50016234/ \
MAINTAINER= ashish@FreeBSD.org
COMMENT= Flexible IRC proxy
-LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USES= pkgconfig gmake
-MAN1= ctrlproxy.1
-MAN5= ctrlproxy_config.5
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/ctrlproxy.1 ${MANPREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/ctrlproxy_config.5 ${MANPREFIX}/man/man5
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/help.txt ${DATADIR}/help.txt
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ctrlproxy
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ctrlproxy-admin
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/linestack-cmd
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/ctrlproxyd
+ ${INSTALL_MAN} ${WRKSRC}/doc/ctrlproxy.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/ctrlproxy_config.5 ${STAGEDIR}${MANPREFIX}/man/man5
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/help.txt ${STAGEDIR}${DATADIR}/help.txt
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS HACKING NEWS README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/user-guide.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/user-guide.html ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/irc/ctrlproxy/pkg-plist b/irc/ctrlproxy/pkg-plist
index 8b1fc29b537f..1ce8b31780d5 100644
--- a/irc/ctrlproxy/pkg-plist
+++ b/irc/ctrlproxy/pkg-plist
@@ -5,6 +5,8 @@ sbin/ctrlproxyd
libdata/pkgconfig/ctrlproxy.pc
etc/ctrlproxy/motd
etc/ctrlproxy/config
+man/man1/ctrlproxy.1.gz
+man/man5/ctrlproxy_config.5.gz
%%DATADIR%%/help.txt
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/HACKING