aboutsummaryrefslogtreecommitdiff
path: root/irc/ctrlproxy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-21 15:21:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-21 15:21:13 +0000
commita0bcd2cf684ff6bc2faf242e6678282f20a3ee44 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /irc/ctrlproxy
parentb7fb6d6f05e67910c9ecd4b0e0e1e0a130f8f54f (diff)
downloadports-a0bcd2cf684ff6bc2faf242e6678282f20a3ee44.tar.gz
ports-a0bcd2cf684ff6bc2faf242e6678282f20a3ee44.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Notes
Notes: svn path=/head/; revision=424427
Diffstat (limited to 'irc/ctrlproxy')
-rw-r--r--irc/ctrlproxy/Makefile3
-rw-r--r--irc/ctrlproxy/files/patch-Makefile21
2 files changed, 7 insertions, 17 deletions
diff --git a/irc/ctrlproxy/Makefile b/irc/ctrlproxy/Makefile
index 75a9af4be237..edc8e4c28523 100644
--- a/irc/ctrlproxy/Makefile
+++ b/irc/ctrlproxy/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libgnutls.so:security/gnutls
USE_GNOME= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USES= pkgconfig gmake
+USES= gmake pathfix pkgconfig
+PATHFIX_MAKEFILEIN= Makefile
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/irc/ctrlproxy/files/patch-Makefile b/irc/ctrlproxy/files/patch-Makefile
index ea05159aad67..1ad875305999 100644
--- a/irc/ctrlproxy/files/patch-Makefile
+++ b/irc/ctrlproxy/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig Sun Apr 15 14:17:58 2007
-+++ Makefile Sat Jun 16 12:00:33 2007
-@@ -108,7 +108,7 @@
- ctrlproxy.pc Makefile.settings: configure Makefile.settings.in ctrlproxy.pc.in
+--- Makefile.orig 2008-12-06 17:36:33 UTC
++++ Makefile
+@@ -145,7 +145,7 @@ endif
+ ctrlproxy.pc Makefile.settings config.h: configure Makefile.settings.in ctrlproxy.pc.in
./$<
-install: all install-dirs install-bin install-header install-data install-pkgconfig $(EXTRA_INSTALL_TARGETS)
@@ -9,7 +9,7 @@
install-dirs:
$(INSTALL) -d $(DESTDIR)$(modulesdir)
-@@ -133,7 +133,6 @@
+@@ -177,7 +177,6 @@ doc::
install-doc:: doc
$(INSTALL) -d $(DESTDIR)$(docdir)
@@ -17,14 +17,3 @@
uninstall-doc:
$(MAKE) -C doc uninstall
-@@ -156,8 +154,8 @@
- $(INSTALL) -m 0644 config.admin $(DESTDIR)$(DEFAULT_CONFIG_DIR)/networks/admin
-
- install-pkgconfig:
-- $(INSTALL) -d $(DESTDIR)$(libdir)/pkgconfig
-- $(INSTALL) -m 0644 ctrlproxy.pc $(DESTDIR)$(libdir)/pkgconfig
-+ $(INSTALL) -d $(DESTDIR)$(prefix)/libdata/pkgconfig
-+ $(INSTALL) -m 0644 ctrlproxy.pc $(DESTDIR)$(prefix)/libdata/pkgconfig
-
- uninstall-pkgconfig:
- -rm -f $(DESTDIR)$(libdir)/pkgconfig/ctrlproxy.pc