aboutsummaryrefslogtreecommitdiff
path: root/irc/cwirc/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-04-11 21:47:53 +0000
committerDiane Bruce <db@FreeBSD.org>2008-04-11 21:47:53 +0000
commit4c56261c42781cfbef7a63ff29d6cf52d926a7f4 (patch)
tree1ca59aa3373c1e11bc7fb4216cc528170e063657 /irc/cwirc/Makefile
parentf28c034e6716bfd5160b06818efd1c6ab1c69e27 (diff)
downloadports-4c56261c42781cfbef7a63ff29d6cf52d926a7f4.tar.gz
ports-4c56261c42781cfbef7a63ff29d6cf52d926a7f4.zip
Notes
Diffstat (limited to 'irc/cwirc/Makefile')
-rw-r--r--irc/cwirc/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/irc/cwirc/Makefile b/irc/cwirc/Makefile
new file mode 100644
index 000000000000..9eab08d4dcbf
--- /dev/null
+++ b/irc/cwirc/Makefile
@@ -0,0 +1,41 @@
+# ports collection makefile for: cwirc
+# Date created: 9 April 2008
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= cwirc
+PORTVERSION= 2.0.0
+CATEGORIES= irc comms hamradio
+MASTER_SITES= http://users.skynet.be/ppc/cwirc/download/ \
+ http://www.db.net/downloads/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= X-Chat morse plugin
+
+BUILD_DEPENDS= xchat:${PORTSDIR}/irc/xchat
+
+post-patch:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in COPYING LISEZMOI README RELEASE_NOTES
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+ ${MKDIR} ${DOCSDIR}/schematics
+.for f in cw_oscillator.jpg rs232_key_connection.jpg
+ @${INSTALL_DATA} ${WRKSRC}/schematics/$f ${DOCSDIR}/schematics
+.endfor
+ @${ECHO} ""
+ @${ECHO} "cwirc docs installed in ${DOCSDIR}"
+ @${ECHO} ""
+.endif
+
+.include <bsd.port.mk>