aboutsummaryrefslogtreecommitdiff
path: root/irc/dancer
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-10-17 06:53:44 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-10-17 06:53:44 +0000
commitae730cb9497b0a3e06ddbfa14f683e6d20af3106 (patch)
tree82f185dba20e577d7f282c5cda798eb5bc02d19d /irc/dancer
parent367cb1bae4bf2e1225a3ee235cb36ceae6f7046a (diff)
downloadports-ae730cb9497b0a3e06ddbfa14f683e6d20af3106.tar.gz
ports-ae730cb9497b0a3e06ddbfa14f683e6d20af3106.zip
Fix build on -current
PR: 58143 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Notes
Notes: svn path=/head/; revision=91479
Diffstat (limited to 'irc/dancer')
-rw-r--r--irc/dancer/Makefile3
-rw-r--r--irc/dancer/files/patch-src::list.h15
2 files changed, 17 insertions, 1 deletions
diff --git a/irc/dancer/Makefile b/irc/dancer/Makefile
index f0804cc0cc56..6dd9933c391a 100644
--- a/irc/dancer/Makefile
+++ b/irc/dancer/Makefile
@@ -27,7 +27,8 @@ do-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
-BROKEN= Does not compile
+LDFLAGS+= -lm
+MAKE_ARGS+= LDFLAGS="${LDFLAGS}"
.endif
.include <bsd.port.post.mk>
diff --git a/irc/dancer/files/patch-src::list.h b/irc/dancer/files/patch-src::list.h
new file mode 100644
index 000000000000..59e8dd3fb7af
--- /dev/null
+++ b/irc/dancer/files/patch-src::list.h
@@ -0,0 +1,15 @@
+--- src/list.h.orig Mon Nov 13 03:42:45 2000
++++ src/list.h Thu Oct 16 22:36:07 2003
+@@ -52,10 +52,10 @@
+ ((NULL == (list)) || (NULL == ((header *)(list))->next))
+
+ /* NewList creates a header for a list of the specified type */
+-#define NewList(type) ( ##type## *)calloc(1, sizeof( ##type## ))
++#define NewList(type) (type *)calloc(1, sizeof(type))
+
+ /* NewEntry allocates a new entry of the specified type */
+-#define NewEntry(type) ( ##type## *)calloc(1, sizeof( ##type## ))
++#define NewEntry(type) (type *)calloc(1, sizeof(type))
+
+ #define RemoveFirst(list) RemoveEntry((list), (list).h->next)
+ #define RemoveLast(list) RemoveEntry((list), (list).h->prev)