aboutsummaryrefslogtreecommitdiff
path: root/irc/darkbot
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-05-04 22:48:03 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-05-04 22:48:03 +0000
commit5ac18767d1594a7c77ba505b9672eb4e3b5284bc (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /irc/darkbot
parentb3db8883de118166da92dad3b8b07b17378c911c (diff)
downloadports-5ac18767d1594a7c77ba505b9672eb4e3b5284bc.tar.gz
ports-5ac18767d1594a7c77ba505b9672eb4e3b5284bc.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=317389
Diffstat (limited to 'irc/darkbot')
-rw-r--r--irc/darkbot/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
index 38b7253d7549..a253489c6620 100644
--- a/irc/darkbot/Makefile
+++ b/irc/darkbot/Makefile
@@ -35,12 +35,12 @@ post-install:
cd ${WRKSRC}/dat; \
for file in *; do \
${INSTALL_DATA} $$file ${ETCDIR}/dat/$${file}.dist; \
- ${CP} -np ${ETCDIR}/dat/$${file}.dist ${ETCDIR}/dat/$$file; \
+ ${CP} -np ${ETCDIR}/dat/$${file}.dist ${ETCDIR}/dat/$$file || ${TRUE} ; \
${ECHO_CMD} "@unexec cmp -s ${ETCDIR}/dat/$$file \
${ETCDIR}/dat/$${file}.dist && \
rm -f ${ETCDIR}/dat/$$file || true" >> ${TMPPLIST}; \
${ECHO_CMD} "${ETCDIR_REL}/dat/$${file}.dist" >> ${TMPPLIST}; \
- ${ECHO_CMD} "@exec cp -np %D/%F %B/$$file" >> ${TMPPLIST}; \
+ ${ECHO_CMD} "@exec cp -np %D/%F %B/$$file || true" >> ${TMPPLIST}; \
done
${ECHO_CMD} "@unexec rmdir ${ETCDIR}/logs 2>/dev/null || true" >> ${TMPPLIST}
${ECHO_CMD} "@unexec rmdir ${ETCDIR}/dat 2>/dev/null || true" >> ${TMPPLIST}