aboutsummaryrefslogtreecommitdiff
path: root/irc/dxirc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /irc/dxirc
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'irc/dxirc')
-rw-r--r--irc/dxirc/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/irc/dxirc/Makefile b/irc/dxirc/Makefile
index 414b7956dc32..c59e3f16f67a 100644
--- a/irc/dxirc/Makefile
+++ b/irc/dxirc/Makefile
@@ -40,12 +40,14 @@ NLS_CMAKE_BOOL= WITH_NLS
NOTIFY_RUN_DEPENDS= notify-send:devel/libnotify
-QT4_USE= QT4=corelib,gui,network \
- QT4=moc_build,rcc_build,uic_build,qmake_build
+QT4_USES= qt:4
+QT4_USE= QT=corelib,gui,network \
+ QT=moc_build,rcc_build,uic_build,qmake_build
QT4_CMAKE_ON= -DQT5:BOOL=OFF
-QT5_USE= QT5=core,gui,multimedia,network,widgets \
- QT5=buildtools_build,qmake_build
+QT5_USES= qt:5
+QT5_USE= QT=core,gui,multimedia,network,widgets \
+ QT=buildtools_build,qmake_build
QT5_CMAKE_ON= -DQT5:BOOL=ON
.include <bsd.port.mk>