aboutsummaryrefslogtreecommitdiff
path: root/irc/epic4/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-04-02 06:00:30 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-04-02 06:00:30 +0000
commit7e0cd75c07c4c1c1e867929bc93ccd2192c694b1 (patch)
tree73d85a3c152d239c97cd5867cc17feb16b6fa515 /irc/epic4/Makefile
parent351a3ad2a665e8e8ac7f000df1f28f62d587bcd1 (diff)
Notes
Diffstat (limited to 'irc/epic4/Makefile')
-rw-r--r--irc/epic4/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index 97c53f9ba122..b70f0379b1c3 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= epic4
-PORTVERSION= 2.8
+PORTVERSION= 2.10
CATEGORIES= irc ipv6
MASTER_SITES= http://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/ \
http://tehran.lain.pl/epic-mirror/EPIC4-PRODUCTION/ \
@@ -15,7 +15,7 @@ MASTER_SITES= http://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/ \
http://ftp.freenet.de/pub/ftp.prbh.org/pub/epic/EPIC4-PRODUCTION/ \
ftp://ftp.eu.uu.net/pub/unix/irc/epic/EPIC4-PRODUCTION/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-help-20050315.tar.gz
+ ${PORTNAME}-help-20050315.tar.bz2
MAINTAINER= josh@tcbug.org
COMMENT= The (E)nhanced (P)rogrammable (I)RC-II (C)lient
@@ -26,12 +26,14 @@ GNU_CONFIGURE= yes
MAN1= epic.1
USE_OPENSSL= yes
SUB_FILES= pkg-message
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+USE_BZIP2= yes
OPTIONS= IPV6 "IPv6 support" on \
TCL "TCL support" on \
- PERL "Perl scripting support" off \
+ PERL "Perl scripting support" on \
SOCKS5 "Enable SOCKS5 proxy support" off \
- SSL "Enable SSL support" off \
+ SSL "Enable SSL support" on \
TERMCAP "Refuse to use terminfo/ncurses" off
.include <bsd.port.pre.mk>
@@ -47,6 +49,8 @@ CONFIGURE_ARGS+= --without-ipv6
.if !defined(WITHOUT_TCL)
LIB_DEPENDS+= tcl84:${PORTSDIR}/lang/tcl84
CONFIGURE_ARGS+= --with-tcl
+.else
+CONFIGURE_ARGS+= --without-tcl
.endif
## WITH_PERL: enable perl5 support (requires perl 5.6.1 or newer)
@@ -59,6 +63,8 @@ CONFIGURE_ARGS+= --with-tcl
.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE
+.else
+CONFIGURE_ARGS+= --without-perl
.endif
## WITH_SOCKS5: enable SOCKS5 support
@@ -75,6 +81,8 @@ CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}/include
#
.if defined(WITH_SSL)
CONFIGURE_ARGS+= --with-ssl
+.else
+CONFIGURE_ARGS+= --without-ssl
.endif
## WITH_TERMCAP forceably refuse to use terminfo/ncurses