aboutsummaryrefslogtreecommitdiff
path: root/irc/epic4
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2019-03-22 15:01:22 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2019-03-22 15:01:22 +0000
commita71ec4f5d0fa5f309952f988febf4d94bdde8993 (patch)
treee436207b0f227e4077867cc35a10a2c65d95d4a2 /irc/epic4
parent8b6ae3497c2cdca3b4ad4fc85fed8ad80c6d2c92 (diff)
downloadports-a71ec4f5d0fa5f309952f988febf4d94bdde8993.tar.gz
ports-a71ec4f5d0fa5f309952f988febf4d94bdde8993.zip
Version update and several cleanups
- Update to port version 2.10.6 - Clean up mirror sites - switch to OPTION_USES framework - Fix PERL build option by replacing ${PERL_VERSION} with ${PERL_VER} in the path that is passed to --with-perl - Minor changes to satisfy portlint PR: 236709 Submitted by: caf@bitchx.org
Notes
Notes: svn path=/head/; revision=496573
Diffstat (limited to 'irc/epic4')
-rw-r--r--irc/epic4/Makefile43
-rw-r--r--irc/epic4/distinfo5
-rw-r--r--irc/epic4/pkg-message2
3 files changed, 18 insertions, 32 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index cb15e049cee2..c32a55dede4b 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -2,44 +2,36 @@
# $FreeBSD$
PORTNAME= epic4
-PORTVERSION= 2.10.5
-PORTREVISION= 3
+PORTVERSION= 2.10.6
CATEGORIES= irc ipv6
MASTER_SITES= http://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/ \
- http://tehran.lain.pl/epic-mirror/EPIC4-PRODUCTION/ \
- ftp://ftp.irc.org/irc/clients/unix/epic/EPIC4-PRODUCTION/ \
- http://ftp.freenet.de/pub/ftp.prbh.org/pub/epic/EPIC4-PRODUCTION/ \
- ftp://ftp.eu.uu.net/pub/unix/irc/epic/EPIC4-PRODUCTION/
+ http://ftp.cc.uoc.gr/mirrors/irc/epic/EPIC4-PRODUCTION/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-help-20050315.tar.bz2
MAINTAINER= jpaetzel@FreeBSD.org
-COMMENT= The (E)nhanced (P)rogrammable (I)RC-II (C)lient
+COMMENT= (E)nhanced (P)rogrammable (I)RC-II (C)lient
LICENSE= BSD3CLAUSE
+USES= ncurses tar:xz
+
CONFLICTS= epic5-0.[0-2]*
GNU_CONFIGURE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-USES= ncurses tar:bzip2 ssl
CFLAGS:= ${CFLAGS:C/-O2/-g -O/g}
OPTIONS_DEFINE= IPV6 TCL PERL SSL DOCS
OPTIONS_DEFAULT= TCL PERL SSL
-.include <bsd.port.options.mk>
+IPV6_CONFIGURE_WITH= ipv6
-.if ! ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --without-ipv6
-.endif
+SSL_CONFIGURE_WITH= ssl="${OPENSSLBASE}"
+SSL_USES= ssl
-.if ${PORT_OPTIONS:MTCL}
-USES+= tcl
-CONFIGURE_ARGS+= --with-tcl
-.else
-CONFIGURE_ARGS+= --without-tcl
-.endif
+TCL_CONFIGURE_WITH= tcl
+TCL_USES= tcl
# enable perl5 support (requires perl 5.6.1 or newer)
#
@@ -48,18 +40,11 @@ CONFIGURE_ARGS+= --without-tcl
# patch to configure would be a better idea, but we need to rely on
# SITE_PERL and PERL_VERSION to create the path.
#
-.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
-CONFIGURE_ARGS+= --with-perl=${LOCALBASE}/lib/perl5/${PERL_VERSION}/${PERL_ARCH}/CORE
-.else
-CONFIGURE_ARGS+= --without-perl
-.endif
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= --with-ssl
-.else
-CONFIGURE_ARGS+= --without-ssl
-.endif
+PERL_CONFIGURE_WITH= perl="${LOCALBASE}/lib/perl5/${PERL_VER}/${PERL_ARCH}/CORE"
+PERL_USES= perl5
+
+.include <bsd.port.options.mk>
post-extract:
@${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -r
diff --git a/irc/epic4/distinfo b/irc/epic4/distinfo
index de85a6576f07..edf5031c4851 100644
--- a/irc/epic4/distinfo
+++ b/irc/epic4/distinfo
@@ -1,4 +1,5 @@
-SHA256 (epic4-2.10.5.tar.bz2) = fca7b1788bde52687fd01c33c5e74d0e16fcc656a76b387de18504eda764ff80
-SIZE (epic4-2.10.5.tar.bz2) = 636364
+TIMESTAMP = 1553042057
+SHA256 (epic4-2.10.6.tar.xz) = eaa79efe6393525de9632cc796e6a6fb15b476baec71d270fdeb7e28186953c1
+SIZE (epic4-2.10.6.tar.xz) = 585300
SHA256 (epic4-help-20050315.tar.bz2) = a7b7026ecfc00ab7040ef5e435d72fd347d48fab128722d4e213dba194cd5bbe
SIZE (epic4-help-20050315.tar.bz2) = 238390
diff --git a/irc/epic4/pkg-message b/irc/epic4/pkg-message
index 9a3e0c0ff661..48c6daacb768 100644
--- a/irc/epic4/pkg-message
+++ b/irc/epic4/pkg-message
@@ -3,4 +3,4 @@ build a client the way you want it. You will not find EPIC usable without
a script of some sort.
Some of the more popular scripts can be found at:
-http://epicsol.org/doku.php/scripts
+http://epicsol.org/doku.php?id=scripts