aboutsummaryrefslogtreecommitdiff
path: root/irc/icbirc
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2004-02-14 22:19:22 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2004-02-14 22:19:22 +0000
commit0c26df2d2518fed5f3090d3f4403185c3b122725 (patch)
tree5a7e51adbcd8da385f7414729bc6e8541245e05c /irc/icbirc
parentf135498d0a2d8324b6f8f74e87826864c84ab53e (diff)
downloadports-0c26df2d2518fed5f3090d3f4403185c3b122725.tar.gz
ports-0c26df2d2518fed5f3090d3f4403185c3b122725.zip
Import icbirc 1.6.
icbirc is a proxy that allows to connect an IRC client to an ICB server. PR: 62506 Submitted by: hrs
Notes
Notes: svn path=/head/; revision=100944
Diffstat (limited to 'irc/icbirc')
-rw-r--r--irc/icbirc/Makefile22
-rw-r--r--irc/icbirc/distinfo2
-rw-r--r--irc/icbirc/files/patch-icbirc.c22
-rw-r--r--irc/icbirc/pkg-descr9
4 files changed, 55 insertions, 0 deletions
diff --git a/irc/icbirc/Makefile b/irc/icbirc/Makefile
new file mode 100644
index 000000000000..1839eab99886
--- /dev/null
+++ b/irc/icbirc/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: icbirc
+# Date created: 8 Feb 2004
+# Whom: hrs
+#
+# $FreeBSD$
+
+PORTNAME= icbirc
+PORTVERSION= 1.6
+CATEGORIES= irc
+MASTER_SITES= http://www.benzedrine.cx/
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Proxy IRC client and ICB server
+
+MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/man/man"
+
+MAN8= icbirc.8
+MANCOMPRESSED= maybe
+
+PLIST_FILES= bin/icbirc
+
+.include <bsd.port.mk>
diff --git a/irc/icbirc/distinfo b/irc/icbirc/distinfo
new file mode 100644
index 000000000000..9438214121ec
--- /dev/null
+++ b/irc/icbirc/distinfo
@@ -0,0 +1,2 @@
+MD5 (icbirc-1.6.tar.gz) = bf70111c22f13862b75457c7f076a911
+SIZE (icbirc-1.6.tar.gz) = 10936
diff --git a/irc/icbirc/files/patch-icbirc.c b/irc/icbirc/files/patch-icbirc.c
new file mode 100644
index 000000000000..2e4a9d19882c
--- /dev/null
+++ b/irc/icbirc/files/patch-icbirc.c
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- icbirc.c.orig Wed Aug 20 23:55:59 2003
++++ icbirc.c Sat Feb 14 23:09:01 2004
+@@ -318,12 +318,12 @@
+ done:
+ if (server_fd >= 0)
+ close(server_fd);
+- printf("(%u seconds, %lu:%lu bytes)\n",
+- time(NULL) - t, bytes_out, bytes_in);
++ printf("(%lu seconds, %lu:%lu bytes)\n",
++ (long)time(NULL) - t, bytes_out, bytes_in);
+ if (terminate_client)
+ irc_send_notice(client_fd, "Closing connection "
+- "(%u seconds, %lu:%lu bytes)",
+- time(NULL) - t, bytes_out, bytes_in);
++ "(%lu seconds, %lu:%lu bytes)",
++ (long)time(NULL) - t, bytes_out, bytes_in);
+ }
+
+ int
diff --git a/irc/icbirc/pkg-descr b/irc/icbirc/pkg-descr
new file mode 100644
index 000000000000..d045360db4f1
--- /dev/null
+++ b/irc/icbirc/pkg-descr
@@ -0,0 +1,9 @@
+icbirc is a proxy that allows to connect an IRC client to an ICB server.
+The proxy accepts client connections, connects to the server, and for-
+wards data between those two connections.
+
+Commands from the IRC client are translated to ICB commands and forwarded
+to the ICB server. Messages from the ICB server are translated to IRC
+messages and forwarded to the IRC client.
+
+WWW: http://www.benzedrine.cx/icbirc.html