aboutsummaryrefslogtreecommitdiff
path: root/irc/icbirc
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-05-17 03:13:56 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-05-17 03:13:56 +0000
commitd69e5bd22aab1b13c726dfe5e41b288921236794 (patch)
treecd541a8293544ade5345ad1b609ca0fcad4c0fa7 /irc/icbirc
parent1504bf2f9fe1f918aaee4233b4c439cf966896b9 (diff)
downloadports-d69e5bd22aab1b13c726dfe5e41b288921236794.tar.gz
ports-d69e5bd22aab1b13c726dfe5e41b288921236794.zip
- Fix build on 10.x and later.
- Add LICENSE.
Notes
Notes: svn path=/head/; revision=354277
Diffstat (limited to 'irc/icbirc')
-rw-r--r--irc/icbirc/Makefile5
-rw-r--r--irc/icbirc/files/COPYING28
-rw-r--r--irc/icbirc/files/patch-icb.c34
-rw-r--r--irc/icbirc/files/patch-icbirc.c16
-rw-r--r--irc/icbirc/files/patch-irc.c12
5 files changed, 80 insertions, 15 deletions
diff --git a/irc/icbirc/Makefile b/irc/icbirc/Makefile
index b8d442abd1b2..46572935d5bc 100644
--- a/irc/icbirc/Makefile
+++ b/irc/icbirc/Makefile
@@ -3,13 +3,18 @@
PORTNAME= icbirc
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.benzedrine.cx/
MAINTAINER= hrs@FreeBSD.org
COMMENT= Proxy IRC client and ICB server
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${FILESDIR}/COPYING
+
MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/man/man"
+MAKE_ARGS+= -DWITH_INSTALL_AS_USER
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/icbirc \
diff --git a/irc/icbirc/files/COPYING b/irc/icbirc/files/COPYING
new file mode 100644
index 000000000000..47aff33fec0d
--- /dev/null
+++ b/irc/icbirc/files/COPYING
@@ -0,0 +1,28 @@
+$FreeBSD$
+
+Copyright (c) 2003-2004 Daniel Hartmeier
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ - Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ - Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/irc/icbirc/files/patch-icb.c b/irc/icbirc/files/patch-icb.c
index 5b0a7b341462..c94427595f2c 100644
--- a/irc/icbirc/files/patch-icb.c
+++ b/irc/icbirc/files/patch-icb.c
@@ -1,6 +1,16 @@
---- icb.c.orig Fri Nov 19 06:14:28 2004
-+++ icb.c Tue Aug 28 05:09:38 2007
-@@ -40,8 +40,8 @@
+--- icb.c.orig 2004-11-19 06:14:28.000000000 +0900
++++ icb.c 2014-05-17 02:34:25.000000000 +0900
+@@ -30,7 +30,9 @@
+ *
+ */
+
++#if 0
+ static const char rcsid[] = "$Id: icb.c,v 1.15 2004/11/18 21:14:28 dhartmei Exp $";
++#endif
+
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -40,8 +42,8 @@
extern int sync_write(int, const char *, int);
@@ -11,7 +21,7 @@
static void icb_ico(int, const char *);
static void icb_iwl(int, const char *, const char *, long,
long, const char *, const char *);
-@@ -108,7 +108,7 @@
+@@ -108,7 +110,7 @@
*/
void
@@ -20,7 +30,7 @@
{
while (**s && strchr(skip, **s) != NULL)
(*s)++;
-@@ -149,7 +149,7 @@
+@@ -149,7 +151,7 @@
}
static unsigned char
@@ -29,7 +39,7 @@
{
unsigned char i = 0, j = 0, k = 0;
-@@ -175,10 +175,10 @@
+@@ -175,10 +177,10 @@
}
static void
@@ -42,7 +52,7 @@
unsigned char i, j;
char s[8192];
-@@ -254,7 +254,7 @@
+@@ -254,7 +256,7 @@
char old_nick[256], new_nick[256];
scan(&a, old_nick, sizeof(old_nick), " ", " ");
@@ -51,7 +61,7 @@
return;
a += 21;
scan(&a, new_nick, sizeof(new_nick), " ", " ");
-@@ -268,7 +268,7 @@
+@@ -268,7 +270,7 @@
char nick[256], topic[256];
scan(&a, nick, sizeof(nick), " ", " ");
@@ -60,7 +70,7 @@
return;
a += 23;
scan(&a, topic, sizeof(topic), "", "\"");
-@@ -279,13 +279,13 @@
+@@ -279,13 +281,13 @@
char old_mod[256], new_mod[256];
scan(&a, old_mod, sizeof(old_mod), " ", " ");
@@ -76,7 +86,7 @@
snprintf(s, sizeof(s),
":%s MODE %s +o %s\r\n",
icb_hostid, irc_channel, old_mod);
-@@ -297,7 +297,7 @@
+@@ -297,7 +299,7 @@
char nick[256];
scan(&a, nick, sizeof(nick), " ", " ");
@@ -85,7 +95,7 @@
return;
snprintf(s, sizeof(s), ":%s KICK %s %s :booted\r\n",
icb_moderator, irc_channel, nick);
-@@ -508,7 +508,7 @@
+@@ -508,7 +510,7 @@
cmd[off++] = 0;
cmd[0] = off - 1;
/* cmd[0] <= MAX_MSG_SIZE */
@@ -94,7 +104,7 @@
}
}
-@@ -533,7 +533,7 @@
+@@ -533,7 +535,7 @@
cmd[off++] = 0;
cmd[0] = off - 1;
/* cmd[0] <= MAX_MSG_SIZE */
diff --git a/irc/icbirc/files/patch-icbirc.c b/irc/icbirc/files/patch-icbirc.c
index 72dac2faf679..1bdff116b421 100644
--- a/irc/icbirc/files/patch-icbirc.c
+++ b/irc/icbirc/files/patch-icbirc.c
@@ -1,6 +1,16 @@
---- icbirc.c.orig Fri Nov 19 06:14:28 2004
-+++ icbirc.c Tue Aug 28 05:12:05 2007
-@@ -322,8 +322,8 @@
+--- icbirc.c.orig 2004-11-19 06:14:28.000000000 +0900
++++ icbirc.c 2014-05-17 02:17:15.000000000 +0900
+@@ -30,7 +30,9 @@
+ *
+ */
+
++#if 0
+ static const char rcsid[] = "$Id: icbirc.c,v 1.13 2004/11/18 21:14:28 dhartmei Exp $";
++#endif
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
+@@ -322,8 +324,8 @@
(unsigned long)(time(NULL) - t), bytes_out, bytes_in);
if (terminate_client)
irc_send_notice(client_fd, "Closing connection "
diff --git a/irc/icbirc/files/patch-irc.c b/irc/icbirc/files/patch-irc.c
new file mode 100644
index 000000000000..1b673afda1e4
--- /dev/null
+++ b/irc/icbirc/files/patch-irc.c
@@ -0,0 +1,12 @@
+--- irc.c.orig 2014-05-17 02:34:33.000000000 +0900
++++ irc.c 2014-05-17 02:34:43.000000000 +0900
+@@ -30,7 +30,9 @@
+ *
+ */
+
++#if 0
+ static const char rcsid[] = "$Id: irc.c,v 1.13 2004/11/18 21:14:28 dhartmei Exp $";
++#endif
+
+ #include <stdarg.h>
+ #include <stdio.h>