aboutsummaryrefslogtreecommitdiff
path: root/irc/infobot/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-05-19 22:14:22 +0000
committerWill Andrews <will@FreeBSD.org>2000-05-19 22:14:22 +0000
commitb35f084b918549662ee19fe0e4c907ebb8dd84d1 (patch)
tree59a0fedcbb10a254408f97c3f0c72cc54be277d3 /irc/infobot/Makefile
parent3d3e80a22e77ca5939ad8bbfb9edcfed05d0f3fb (diff)
downloadports-b35f084b918549662ee19fe0e4c907ebb8dd84d1.tar.gz
ports-b35f084b918549662ee19fe0e4c907ebb8dd84d1.zip
Notes
Diffstat (limited to 'irc/infobot/Makefile')
-rw-r--r--irc/infobot/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/irc/infobot/Makefile b/irc/infobot/Makefile
new file mode 100644
index 000000000000..dc64502d572e
--- /dev/null
+++ b/irc/infobot/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: infobot
+# Date created: 17 November 1999
+# Whom: perlguy@perlguy.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= infobot
+PORTVERSION= 0.44.3
+CATEGORIES= irc
+MASTER_SITES= http://www.infobot.org/src/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= perlguy@perlguy.com
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_PERL5= yes
+NO_BUILD= yes
+PLIST_SUB+= VERSION="${PORTVERSION}"
+
+do-install:
+ @if [ ! -d ${PREFIX}/share/${DISTNAME} ]; then \
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}-${PORTVERSION}; \
+ fi
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/share/${PORTNAME}-${PORTVERSION}/
+
+.include <bsd.port.mk>