aboutsummaryrefslogtreecommitdiff
path: root/irc/inspircd
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2020-06-08 20:55:00 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2020-06-08 20:55:00 +0000
commit15bff038d54412cbf84a7686e94572b92437edcd (patch)
tree60ed4b1c154abd5cb863b8aca03fea294a1ec6ef /irc/inspircd
parentfa2128241b324469c0f4ceb2495934f54cd4c62c (diff)
downloadports-15bff038d54412cbf84a7686e94572b92437edcd.tar.gz
ports-15bff038d54412cbf84a7686e94572b92437edcd.zip
irc/inspircd: Update to 3.6.0
Changes: https://docs.inspircd.org/3/change-log/#inspircd-360 Reported by: Tyler Saylor <me@tylersaylor.com>
Notes
Notes: svn path=/head/; revision=538260
Diffstat (limited to 'irc/inspircd')
-rw-r--r--irc/inspircd/Makefile8
-rw-r--r--irc/inspircd/distinfo6
-rw-r--r--irc/inspircd/files/patch-configure64
-rw-r--r--irc/inspircd/pkg-plist1
4 files changed, 10 insertions, 69 deletions
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index 3bb846eac08a..d07e20aa5d61 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inspircd
DISTVERSIONPREFIX= v
-DISTVERSION= 3.5.0
+DISTVERSION= 3.6.0
CATEGORIES= irc
MAINTAINER= dmgk@FreeBSD.org
@@ -29,6 +29,7 @@ CONFIGURE_ARGS= --binary-dir=${PREFIX}/bin \
--module-dir=${PREFIX}/libexec/${PORTNAME}/modules \
--prefix=${PREFIX}/libexec/${PORTNAME} \
--distribution-label=${OPSYS}-${PORTVERSION} \
+ --uid=0 --gid=0 \
--disable-auto-extras
USE_RC_SUBR= ${PORTNAME}
@@ -56,7 +57,7 @@ PLIST_SUB= INSPIRCD_DBDIR=${INSPIRCD_DBDIR} \
INSPIRCD_RUNDIR=${INSPIRCD_RUNDIR} \
INSPIRCD_USER=${USERS}
-OPTIONS_DEFINE= GNUTLS IPV6 LDAP MBEDTLS MYSQL OPENSSL PCRE PGSQL POSIX SQLITE
+OPTIONS_DEFINE= GNUTLS IPV6 LDAP MBEDTLS MYSQL OPENSSL PCRE PGSQL POSIX SQLITE SSLREHASH
OPTIONS_DEFAULT= OPENSSL POSIX
OPTIONS_SUB= yes
@@ -69,6 +70,7 @@ PCRE_DESC= Build m_regex_pcre module
PGSQL_DESC= Build m_pgsql module
POSIX_DESC= Build m_regex_posix module
SQLITE_DESC= Build m_sqlite3 module
+SSLREHASH_DESC= Build m_sslrehashsignal module
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_USES= pkgconfig
@@ -97,6 +99,8 @@ POSIX_VARS= EXTRAS+=m_regex_posix.cpp
SQLITE_USES= pkgconfig sqlite
SQLITE_VARS= EXTRAS+=m_sqlite3.cpp
+SSLREHASH_VARS+= EXTRAS+=m_sslrehashsignal.cpp
+
pre-configure:
@(cd ${WRKSRC}/src/modules && for m in ${EXTRAS}; do ${RLN} extra/$$m $$m; done)
diff --git a/irc/inspircd/distinfo b/irc/inspircd/distinfo
index 1e3def2db9f3..210c0ac87070 100644
--- a/irc/inspircd/distinfo
+++ b/irc/inspircd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580731499
-SHA256 (inspircd-inspircd-v3.5.0_GH0.tar.gz) = c7e61d02bf6bde873bdf4696bf1b695e09d2d396fcaa05ff37942290d1b75c63
-SIZE (inspircd-inspircd-v3.5.0_GH0.tar.gz) = 835283
+TIMESTAMP = 1591531437
+SHA256 (inspircd-inspircd-v3.6.0_GH0.tar.gz) = f9a80ddfd8354163e0935ec65ea2c596c93152560ebb56dbeb5f8b3e1b53eb1e
+SIZE (inspircd-inspircd-v3.6.0_GH0.tar.gz) = 851768
diff --git a/irc/inspircd/files/patch-configure b/irc/inspircd/files/patch-configure
deleted file mode 100644
index 183315520d2a..000000000000
--- a/irc/inspircd/files/patch-configure
+++ /dev/null
@@ -1,64 +0,0 @@
---- configure.orig 2020-01-31 12:49:58 UTC
-+++ configure
-@@ -208,57 +208,10 @@ if (defined $opt_system) {
- $config{SCRIPT_DIR} = $opt_script_dir // $config{SCRIPT_DIR} // $config{BASE_DIR};
- }
-
--# Parse --gid=123 or --gid=foo and extract the group id.
--my @group;
--if (defined $opt_gid) {
-- @group = $opt_gid =~ /^\d+$/ ? getgrgid($opt_gid) : getgrnam($opt_gid);
-- print_error "there is no '$opt_gid' group on this system!" unless @group;
--} else {
-- @group = $opt_system ? getgrnam('irc') : getgrgid($config{GID} // getgid());
-- print_error "you need to specify a group to run as using '--gid [id|name]'!" unless @group;
-- unless ($group[2]) {
-- print_warning <<"EOW";
--You are building as the privileged $group[0] group and have not specified
--an unprivileged group to run InspIRCd as.
--
--This is almost never what you should do. You should probably either create a new
--unprivileged user/group to build and run as or pass the '--gid [id|name]' flag
--to specify an unprivileged group to run as.
--EOW
-- if (!prompt_bool $interactive, "Are you sure you want to build as the $group[0] group?", 0) {
-- say STDERR "If you are sure you want to build as the $group[0] group pass the --gid $group[2] flag." unless $interactive;
-- exit 1;
-- }
-- }
--}
--$config{GROUP} = $group[0];
--$config{GID} = $group[2];
--
--# Parse --uid=123 or --uid=foo and extract the user id.
--my @user;
--if (defined $opt_uid) {
-- @user = $opt_uid =~ /^\d+$/ ? getpwuid($opt_uid) : getpwnam($opt_uid);
-- print_error "there is no '$opt_uid' user on this system!" unless @user;
--} else {
-- @user = $opt_system ? getpwnam('irc') : getpwuid($config{UID} // getuid());
-- print_error "you need to specify a user to run as using '--uid [id|name]'!" unless @user;
-- unless ($user[2]) {
-- print_warning <<"EOW";
--You are building as the privileged $user[0] user and have not specified
--an unprivileged user to run InspIRCd as.
--
--This is almost never what you should do. You should probably either create a new
--unprivileged user/group to build and run as or pass the '--uid [id|name]' flag
--to specify an unprivileged user to run as.
--EOW
-- if (!prompt_bool $interactive, "Are you sure you want to build as the $user[0] user?", 0) {
-- say STDERR "If you are sure you want to build as the $user[0] user pass the --uid $user[2] flag." unless $interactive;
-- exit 1;
-- }
-- }
--}
--$config{USER} = $user[0];
--$config{UID} = $user[2];
-+$config{GROUP} = "%%INSPIRCD_GROUP%%";
-+$config{GID} = %%INSPIRCD_GID%%;
-+$config{USER} = "%%INSPIRCD_USER%%";
-+$config{UID} = %%INSPIRCD_UID%%;
-
- # Warn the user about clock drifting when running on OpenVZ.
- if (-e '/proc/user_beancounters' || -e '/proc/vz/vzaquota') {
diff --git a/irc/inspircd/pkg-plist b/irc/inspircd/pkg-plist
index ef45440623df..e00ddf2f0edd 100644
--- a/irc/inspircd/pkg-plist
+++ b/irc/inspircd/pkg-plist
@@ -222,6 +222,7 @@ libexec/inspircd/modules/m_xline_db.so
%%PGSQL%%libexec/inspircd/modules/m_pgsql.so
%%POSIX%%libexec/inspircd/modules/m_regex_posix.so
%%SQLITE%%libexec/inspircd/modules/m_sqlite3.so
+%%SSLREHASH%%libexec/inspircd/modules/m_sslrehashsignal.so
man/man1/inspircd-genssl.1.gz
man/man1/inspircd.1.gz
@dir(%%INSPIRCD_USER%%,%%INSPIRCD_GROUP%%,750) %%INSPIRCD_DBDIR%%