aboutsummaryrefslogtreecommitdiff
path: root/irc/inspircd
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-01-11 17:23:09 +0000
committerMark Felder <feld@FreeBSD.org>2014-01-11 17:23:09 +0000
commit57a58bd00a3f02833958a097d48ac62f07cdfcd5 (patch)
tree5fc671e47160e4661cd8dd08dc23c00b0e0de7a8 /irc/inspircd
parent43b8bf18c65f273e5beb28b4e13727cc1ea1c18f (diff)
downloadports-57a58bd00a3f02833958a097d48ac62f07cdfcd5.tar.gz
ports-57a58bd00a3f02833958a097d48ac62f07cdfcd5.zip
Fix SQLITE and GNUTLS build options which were missing pkgconfig
PR: ports/185610 Approved by: swills (mentor)
Notes
Notes: svn path=/head/; revision=339439
Diffstat (limited to 'irc/inspircd')
-rw-r--r--irc/inspircd/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index 5622ed27ce23..d21e093d472c 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -93,6 +93,7 @@ PLIST_SUB+= PGSQL="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
+USES+= pkgconfig
USE_SQLITE= 3
EXTRAS:=${EXTRAS},m_sqlite3.cpp
PLIST_SUB+= SQLITE=""
@@ -101,8 +102,9 @@ PLIST_SUB+= SQLITE="@comment "
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt
+USES+= pkgconfig
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+= --enable-gnutls
EXTRAS:=${EXTRAS},m_ssl_gnutls.cpp
PLIST_SUB+= GNUTLS=""
@@ -120,7 +122,7 @@ PLIST_SUB+= OPENSSL="@comment "
.endif
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
EXTRAS:=${EXTRAS},m_regex_pcre.cpp
PLIST_SUB+= PCRE=""
.else