aboutsummaryrefslogtreecommitdiff
path: root/irc/insub/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2012-08-19 02:23:56 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2012-08-19 02:23:56 +0000
commite5dd0a9bcd3f17fc330c888645261beabe575058 (patch)
treea008aa6156f5b065bbaf7eaef92c7dc3686e39b8 /irc/insub/Makefile
parente5ddbf7110cfeda151118669bf828c16e34e107a (diff)
downloadports-e5dd0a9bcd3f17fc330c888645261beabe575058.tar.gz
ports-e5dd0a9bcd3f17fc330c888645261beabe575058.zip
Notes
Diffstat (limited to 'irc/insub/Makefile')
-rw-r--r--irc/insub/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index a8e0dd3622b3..fc1e74a62ae1 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -7,6 +7,7 @@
PORTNAME= insub
PORTVERSION= 15.0
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://cloud.github.com/downloads/cjones/insub/
@@ -23,13 +24,25 @@ USE_PERL5= 5.6+
SCRIPT= ${PORTNAME}.pl
+COWLIST= 2bear ahnold apple ass baa bendover bendover2 bigcow blam \
+ cack cake canada chick1 chocobo clippy clover cockasaur copter \
+ dance dick doggies duck erect ferret fish flag flagasaur goatse \
+ gobble heart invdragon ipedo jesus limp lobster missle nascar \
+ nuke nuke2 pedo peek peepees penii penis penisbird pez pig pman \
+ point poland pr8 psyduck puffy pumpkin puppy retard santa santa2 \
+ saq satan shark shlong smpez spam spider standtall stud1 stud2 \
+ tampon turkey-penis urinal usa wang weed wtc wtf-pony wtf wtf2 zig
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${PREFIX}/bin/${SCRIPT:R}
${MKDIR} ${PREFIX}/share/irssi/scripts/
${INSTALL_DATA} ${WRKSRC}/${SCRIPT} \
${PREFIX}/share/irssi/scripts/${SCRIPT}
${MKDIR} ${PREFIX}/share/cows/
- cd ${WRKSRC} && \
- ${FIND} cows | ${CPIO} -pdmu ${PREFIX}/share/
+.for c in ${COWLIST}
+ @${INSTALL_DATA} ${WRKSRC}/cows/${c}.cow ${PREFIX}/share/cows
+.endfor
+# cd ${WRKSRC} && \
+# ${FIND} cows | ${CPIO} -pdmu ${PREFIX}/share/
.include <bsd.port.mk>