aboutsummaryrefslogtreecommitdiff
path: root/irc/irc
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
commit546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8 (patch)
tree7b9cd553a62be7a9bd52800d334be8b703eb93a1 /irc/irc
parent01ab6da99c55af36e516b7f8016373124c4039cf (diff)
downloadports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.tar.gz
ports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.zip
As threatened on freebsd-ports: all startup scripts know about the two
options `start' and `stop' now (unless I have forgotten any). This allows us to call the scripts from /etc/rc.shutdown with the correct option. The (42 or so) ports that already DTRT before are unchanged.
Notes
Notes: svn path=/head/; revision=30229
Diffstat (limited to 'irc/irc')
-rw-r--r--irc/irc/Makefile5
-rw-r--r--irc/irc/files/ircd.sh15
2 files changed, 16 insertions, 4 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index f4f663b8f1d5..d202064175fd 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -50,10 +50,7 @@ do-install:
post-install:
@if [ ! -f ${STARTUP_SCRIPT} ]; then \
${ECHO} "Installing ${STARTUP_SCRIPT} startup file."; \
- ${ECHO} '#!/bin/sh' > ${STARTUP_SCRIPT}; \
- ${ECHO} "[ -f ${PREFIX}/etc/ircd/ircd.conf ] && ${PREFIX}/sbin/ircd && ${ECHO} -n ' ircd'" >> ${STARTUP_SCRIPT} ; \
- ${CHMOD} 755 ${STARTUP_SCRIPT} ; \
- ${CHOWN} bin.bin ${STARTUP_SCRIPT}; \
+ ${INSTALL_SCRIPT} ${FILESDIR}/ircd.sh ${STARTUP_SCRIPT};\
fi
.include <bsd.port.post.mk>
diff --git a/irc/irc/files/ircd.sh b/irc/irc/files/ircd.sh
new file mode 100644
index 000000000000..530cc0e52280
--- /dev/null
+++ b/irc/irc/files/ircd.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ [ -f %%PREFIX%%/etc/ircd/ircd.conf ] && %%PREFIX%%/sbin/ircd && echo -n ' ircd'
+ ;;
+stop)
+ killall ircd && echo -n ' ircd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0