aboutsummaryrefslogtreecommitdiff
path: root/irc/ircII
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-12-18 00:50:06 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-12-18 00:50:06 +0000
commitf1a65313c486c39f1b589338f9ec3b29f50a2e53 (patch)
treed34dafe9c3ff740bc2ac67d5db94cb4d3ceba441 /irc/ircII
parent25b84c5efeb4c45b450558164bbf19b7d4efee80 (diff)
downloadports-f1a65313c486c39f1b589338f9ec3b29f50a2e53.tar.gz
ports-f1a65313c486c39f1b589338f9ec3b29f50a2e53.zip
r428809 was, of course, not the right way to fix libssl linkage. marino
had the right solution, which is to use the appropriate OPTIONS helper, which puts -L${OPENSSLLIB} in early enough that linkage works correctly.
Notes
Notes: svn path=/head/; revision=428813
Diffstat (limited to 'irc/ircII')
-rw-r--r--irc/ircII/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/irc/ircII/Makefile b/irc/ircII/Makefile
index 3d87cc6b2763..d51e1cf444da 100644
--- a/irc/ircII/Makefile
+++ b/irc/ircII/Makefile
@@ -27,19 +27,15 @@ SCRIPTS_DESC= Install ircII script collection
EMACS_KEYS_CONFIGURE_WITH= emacs-meta-keys
OPENSSL_USES= ssl
+OPENSSL_CONFIGURE_WITH= openssl=${OPENSSLBASE}
+OPENSSL_LDFLAGS= -L${OPENSSLLIB}
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.else
-CONFIGURE_ARGS+= --without-openssl
-.endif
-
-.if ${ICONV_PREFIX} != /usr
+# The ordering is very specific. This must come after pre.mk or
+# ircII won't link against libssl from ports
CPPFLAGS+= -I${ICONV_PREFIX}/include
LDFLAGS+= -L${ICONV_PREFIX}/lib
-.endif
post-patch:
@${REINPLACE_CMD} -e '/^mandir =/s/@mandir@/$${DESTDIR}&/' \