aboutsummaryrefslogtreecommitdiff
path: root/irc/ircd-hybrid/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-10 14:12:16 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-10 14:12:16 +0000
commited7970d591644f61a0e9dd73a248c2124a2ba865 (patch)
tree730055aee6100056e9b49d3f09bd39cc27e33f75 /irc/ircd-hybrid/Makefile
parent960d1b34ed6decd579e4c1f45a9cbb28e01a1e31 (diff)
downloadports-ed7970d591644f61a0e9dd73a248c2124a2ba865.tar.gz
ports-ed7970d591644f61a0e9dd73a248c2124a2ba865.zip
irc/ircd-hybrid: update to 8.1.3
- Update to 8.1.3 [1] - Convert to options ng [1] - USES gmake - Remove leading article from COMMENT - Use options helpers - Allow staging PR: ports/180201 [1] Submitted by: Nick Hilliard <nick foobar.org> Approved by: db (maintainer timeout, 4 months)
Notes
Notes: svn path=/head/; revision=333398
Diffstat (limited to 'irc/ircd-hybrid/Makefile')
-rw-r--r--irc/ircd-hybrid/Makefile59
1 files changed, 20 insertions, 39 deletions
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index e8532b8654c5..88a5740f4b48 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -2,18 +2,17 @@
# $FreeBSD$
PORTNAME= ircd-hybrid
-PORTVERSION= 8.0.4
+PORTVERSION= 8.1.3
CATEGORIES= irc ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= db@FreeBSD.org
-COMMENT= A fast irc daemon with a number of new features
+COMMENT= Fast irc daemon with a number of new features
-MAN8= ircd.8
INSTALL_IGNORES= ircu-* ircd-rat* charby*
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
USERS= ircd
@@ -21,33 +20,28 @@ GROUPS= ${USERS}
USE_RC_SUBR= ircd-hybrid
SUB_FILES= pkg-message
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+PLIST_SUB= PORTVERSION=${PORTVERSION}
-#
-# User Configurable Variables
-#
-# PREFIX - Where to install ircd-hybrid. Default is /usr/local
-# WITH_OPENSSL - Enable openssl. Allows use of CHALLENGE and encrypted links.
-# WITHOUT_ASSERT - Disable parts of the debugging code.
-# WITH_HALFOPS - Enable halfops on the server.
-# NICKLEN - Nick length. Default is 9. Must be consistant across the network.
+OPTIONS_DEFINE= OPENSSL HALFOPS ASSERT
+OPTIONS_DEFAULT=OPENSSL
-.if defined(PREFIX)
-CONFIGURE_ARGS+= --prefix=${PREFIX}
-.endif
+ASSERT_CONFIGURE_ENABLE= assert
+ASSERT_DESC= Enable halfops on the server
+
+HALFOPS_CONFIGURE_ENABLE= halfops
+HALFOPS_DESC= Enable parts of the debugging code
+
+OPENSSL_DESC= Enable openssl - allows use of CHALLENGE and encrypted links
+
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+= --enable-openssl=${OPENSSLBASE}
.endif
-.if defined(WITH_HALFOPS)
-CONFIGURE_ARGS+= --enable-halfops
-.endif
-
-.if defined(WITHOUT_ASSERT)
-CONFIGURE_ARGS+= --disable-assert
-.endif
+# User Configurable Variables
+# NICKLEN - Nick length. Default is 9. Must be consistant across the network.
.if defined(NICKLEN)
CONFIGURE_ARGS+= --with-nicklen=${NICKLEN}
@@ -55,20 +49,7 @@ CONFIGURE_ARGS+= --with-nicklen=${NICKLEN}
CONFIGURE_ARGS+= \
--sysconfdir=${PREFIX}/etc/ircd-hybrid \
- --prefix=${LOCAL} \
- --datarootdir=${PREFIX}/share/${PORTNAME}-${PORTVERSION}
-
-NO_STAGE= yes
-pre-su-install:
- ${MKDIR} ${PREFIX}/etc/ircd-hybrid ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
- ${MKDIR} ${PREFIX}/share/${PORTNAME}-${PORTVERSION}/help/
-
-post-install:
- ${MKDIR} /var/run/ircd
- ${CHOWN} ircd:ircd /var/run/ircd
- ${INSTALL_SCRIPT} ${WRKSRC}/doc/example.quick.conf ${PREFIX}/etc/ircd-hybrid
- ${INSTALL_SCRIPT} ${WRKSRC}/doc/example.efnet.conf ${PREFIX}/etc/ircd-hybrid
- ${INSTALL_SCRIPT} ${WRKSRC}/doc/example.conf ${PREFIX}/etc/ircd-hybrid
- @${CAT} ${PKGMESSAGE}
+ --datarootdir=${PREFIX}/share/${PORTNAME}-${PORTVERSION} \
+ --localstatedir=/var
.include <bsd.port.mk>