aboutsummaryrefslogtreecommitdiff
path: root/irc/ircd-hybrid
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2020-04-04 21:49:29 +0000
committerSanthosh Raju <fox@FreeBSD.org>2020-04-04 21:49:29 +0000
commit829f497bc043645d9b80feda169540addadd99d1 (patch)
treee290e8d25d685f4f76c4abd1136be2592ed7e0e1 /irc/ircd-hybrid
parent4a2b38d48df61793c10082c2d89933688b94d66a (diff)
downloadports-829f497bc043645d9b80feda169540addadd99d1.tar.gz
ports-829f497bc043645d9b80feda169540addadd99d1.zip
irc/ircd-hybrid: Fixes permissions for localstatedir.
Instead of pointing directly to /var, now localstatedir now points to /var/ircd-hybrid with proper permissions so that the databases are correctly created during start up. Also minor formatting fixes. PR: 228582 Reported by: Bunny Evans <bunny.evans@gmail.com>
Notes
Notes: svn path=/head/; revision=530722
Diffstat (limited to 'irc/ircd-hybrid')
-rw-r--r--irc/ircd-hybrid/Makefile8
-rw-r--r--irc/ircd-hybrid/pkg-plist7
2 files changed, 10 insertions, 5 deletions
diff --git a/irc/ircd-hybrid/Makefile b/irc/ircd-hybrid/Makefile
index 5ee298a3fb1d..7d298b3f1e9f 100644
--- a/irc/ircd-hybrid/Makefile
+++ b/irc/ircd-hybrid/Makefile
@@ -64,11 +64,11 @@ CONFIGURE_ARGS+= --with-tls=none
RUN_DEPENDS+= ${CERTSFILE}:security/ca_root_nss
.endif
-CONFIGURE_ARGS+= --datarootdir=${PREFIX}/share/${PORTNAME}-${PORTVERSION} \
- --localstatedir=/var \
- --sysconfdir=${PREFIX}/etc/ircd-hybrid
+CONFIGURE_ARGS+= --datadir=${PREFIX}/share/${PORTNAME}-${PORTVERSION} \
+ --localstatedir=/var/${PORTNAME} \
+ --sysconfdir=${PREFIX}/etc/${PORTNAME}
post-install:
- @${MV} ${STAGEDIR}${PREFIX}/bin/mkpasswd ${STAGEDIR}${PREFIX}/bin/ircd-hybrid-mkpasswd
+ @${MV} ${STAGEDIR}${PREFIX}/bin/mkpasswd ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-mkpasswd
.include <bsd.port.mk>
diff --git a/irc/ircd-hybrid/pkg-plist b/irc/ircd-hybrid/pkg-plist
index f14c0360c000..b228cb149ef8 100644
--- a/irc/ircd-hybrid/pkg-plist
+++ b/irc/ircd-hybrid/pkg-plist
@@ -1,6 +1,7 @@
bin/ircd
bin/ircd-hybrid-mkpasswd
%%ETCDIR%%/reference.conf
+etc/rc.d/ircd-hybrid
lib/ircd-hybrid/modules/autoload/m_accept.la
lib/ircd-hybrid/modules/autoload/m_accept.so
lib/ircd-hybrid/modules/autoload/m_admin.la
@@ -171,6 +172,7 @@ man/man8/ircd.8.gz
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/die
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/dline
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/etrace
+%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/extban
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/hash
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/help
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/index
@@ -222,4 +224,7 @@ man/man8/ircd.8.gz
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/whois
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/whowas
%%DATADIR%%-%%PORTVERSION%%/ircd-hybrid/help/xline
-@dir /var/lib
+@dir(ircd,ircd) /var/ircd-hybrid/lib
+@dir(ircd,ircd) /var/ircd-hybrid/log
+@dir(ircd,ircd) /var/ircd-hybrid/run
+@dir(ircd,ircd) /var/ircd-hybrid