aboutsummaryrefslogtreecommitdiff
path: root/irc/ircd-ratbox-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 13:38:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 13:38:25 +0000
commit16f8160c5f6f354730ebc5a3163df45384aad1c3 (patch)
tree4290f20d55e95e13eaafca5f0113f588866930ec /irc/ircd-ratbox-devel
parent10a5536525312072c344b6caeff9c3e77471abb2 (diff)
downloadports-16f8160c5f6f354730ebc5a3163df45384aad1c3.tar.gz
ports-16f8160c5f6f354730ebc5a3163df45384aad1c3.zip
- Update to ratbox-3.0.0 release
Port changes: o Adjusted WITHOUT_IPV6 port option to compensate for ratbox enabling IPv6 by default. o Updated patches for diff index changes and added new patch on 'rsdb_sqlite3.c' to fix ban.db path code. Software changes included in this release: o Fix a crash with the the global CIDR code. o Fix a core dump in bantool if bantool cannot open the database. o Report failure to open logfiles in a more useful way. o Check to see if we have both read and write access to the ban database. o Fix a build error on OS X Leopard. PR: 128890 Submitted by: Lewis <moggie@elasticmind.net> (maintainer)
Notes
Notes: svn path=/head/; revision=223243
Diffstat (limited to 'irc/ircd-ratbox-devel')
-rw-r--r--irc/ircd-ratbox-devel/Makefile11
-rw-r--r--irc/ircd-ratbox-devel/distinfo6
-rw-r--r--irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c24
-rw-r--r--irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl4
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_Makefile.in2
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_example.conf8
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf6
-rw-r--r--irc/ircd-ratbox-devel/files/patch-include_config.h6
-rw-r--r--irc/ircd-ratbox-devel/files/pkg-message.in8
9 files changed, 48 insertions, 27 deletions
diff --git a/irc/ircd-ratbox-devel/Makefile b/irc/ircd-ratbox-devel/Makefile
index 3ffe9c2b6095..b027d290a170 100644
--- a/irc/ircd-ratbox-devel/Makefile
+++ b/irc/ircd-ratbox-devel/Makefile
@@ -7,8 +7,7 @@
# ex: ts=8
PORTNAME= ircd-ratbox
-#PORTVERSION= 3.0.0
-DISTVERSION= 3.0.0rc3
+PORTVERSION= 3.0.0
CATEGORIES= irc ipv6
MASTER_SITES= ftp://ftp.ircd-ratbox.org/pub/ircd-ratbox/testing/ \
ftp://ftp.demon.co.uk/pub/mirrors/ircd-ratbox/testing/ \
@@ -68,8 +67,8 @@ CONFIGURE_ARGS+= --enable-openssl
CONFIGURE_ARGS+= --disable-openssl
.endif
-.if !defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
+.if defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --disable-ipv6
.endif
.if defined(WITHOUT_ZIPLINKS)
@@ -122,8 +121,8 @@ pre-configure:
pre-build:
@${REINPLACE_CMD} -e "s#-O2##" ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#g" \
- ${WRKSRC}/doc/example.conf \
+ @${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#g" \
+ ${WRKSRC}/doc/example.conf \
${WRKSRC}/doc/example.efnet.conf
@${REINPLACE_CMD} -e "s#%%LOGDIR%%#${LOGDIR}#g" \
${WRKSRC}/doc/example.conf \
diff --git a/irc/ircd-ratbox-devel/distinfo b/irc/ircd-ratbox-devel/distinfo
index 0c25103b2134..f406d5559230 100644
--- a/irc/ircd-ratbox-devel/distinfo
+++ b/irc/ircd-ratbox-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (ircd-ratbox-3.0.0rc3.tar.bz2) = 9d430b0e66ee55435c1d76772d712fb0
-SHA256 (ircd-ratbox-3.0.0rc3.tar.bz2) = 625479614d3bdfbf5c20125e82efdc3172ff8cdb34b345dbb36ec84111803f91
-SIZE (ircd-ratbox-3.0.0rc3.tar.bz2) = 1950606
+MD5 (ircd-ratbox-3.0.0.tar.bz2) = 3bab4271c6b6dd197202b6ac52f805a4
+SHA256 (ircd-ratbox-3.0.0.tar.bz2) = 1f754c71fc7a519d70a664096ec5e8b5dd991d714a7ff8476b1b5a3c104a0f9e
+SIZE (ircd-ratbox-3.0.0.tar.bz2) = 1956342
diff --git a/irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c b/irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c
new file mode 100644
index 000000000000..2823c2bdeee2
--- /dev/null
+++ b/irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c
@@ -0,0 +1,24 @@
+--- ./bandb/rsdb_sqlite3.c.orig 2008-11-15 02:59:20.000000000 +0000
++++ ./bandb/rsdb_sqlite3.c 2008-11-15 02:59:59.000000000 +0000
+@@ -58,18 +58,13 @@
+ int
+ rsdb_init(rsdb_error_cb * ecb)
+ {
+- const char *bandb_dpath;
+ char dbpath[PATH_MAX];
+ char errbuf[128];
+ error_cb = ecb;
+
+- /* try a path from the environment first, useful for basedir overrides */
+- bandb_dpath = getenv("BANDB_DPATH");
+-
+- if(bandb_dpath != NULL)
+- rb_snprintf(dbpath, sizeof(dbpath), "%s/etc/ban.db", bandb_dpath);
+- else
+- rb_strlcpy(dbpath, DBPATH, sizeof(dbpath));
++ /* remove the getenv checks and just use the DBPATH value so bandb
++ gets the right value for fbsd ban.db locateion. */
++ rb_strlcpy(dbpath, DBPATH, sizeof(dbpath));
+
+ if(sqlite3_open(dbpath, &rb_bandb) != SQLITE_OK)
+ {
diff --git a/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl b/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl
index 47307ad94a9a..8e2b4532bf84 100644
--- a/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl
+++ b/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl
@@ -1,5 +1,5 @@
---- ./contrib/ircd-shortcut.pl.orig 2008-06-29 14:05:58.000000000 +0100
-+++ ./contrib/ircd-shortcut.pl 2008-06-29 14:07:11.000000000 +0100
+--- ./contrib/ircd-shortcut.pl.orig 2008-04-24 16:43:42.000000000 +0100
++++ ./contrib/ircd-shortcut.pl 2008-11-15 02:55:35.000000000 +0000
@@ -36,7 +36,7 @@
######################################
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in b/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in
index 347f3f5080c0..fd1595236f2d 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in
+++ b/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in
@@ -1,5 +1,5 @@
--- ./doc/Makefile.in.orig 2008-04-23 20:59:46.000000000 +0100
-+++ ./doc/Makefile.in 2008-06-29 14:29:39.000000000 +0100
++++ ./doc/Makefile.in 2008-11-15 02:55:35.000000000 +0000
@@ -43,24 +43,6 @@
fi
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_example.conf b/irc/ircd-ratbox-devel/files/patch-doc_example.conf
index 8743017ecc58..4265b212a97a 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_example.conf
+++ b/irc/ircd-ratbox-devel/files/patch-doc_example.conf
@@ -1,5 +1,5 @@
---- ./doc/example.conf.orig 2008-08-17 14:16:36.000000000 +0100
-+++ ./doc/example.conf 2008-08-21 00:15:05.000000000 +0100
+--- ./doc/example.conf.orig 2008-11-14 16:37:10.000000000 +0000
++++ ./doc/example.conf 2008-11-15 02:55:35.000000000 +0000
@@ -98,13 +98,13 @@
default_max_clients = 10000;
@@ -44,7 +44,7 @@
};
/* class {}: contain information about classes for users (OLD Y:) */
-@@ -347,7 +347,7 @@
+@@ -349,7 +349,7 @@
* A password should not be defined when this is used, see
* doc/challenge.txt for more information.
*/
@@ -53,7 +53,7 @@
/* umodes: the specific umodes this oper gets when they oper.
* If this is specified an oper will not be given oper_umodes
-@@ -1003,8 +1003,9 @@
+@@ -1013,8 +1013,9 @@
/* module path: paths to search for modules specified below and
* in /modload.
*/
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf b/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
index f0d60a6ba6bb..6caab31da254 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
+++ b/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
@@ -1,5 +1,5 @@
---- ./doc/example.efnet.conf.orig 2008-08-23 23:05:37.000000000 +0100
-+++ ./doc/example.efnet.conf 2008-09-05 21:00:26.000000000 +0100
+--- ./doc/example.efnet.conf.orig 2008-09-22 19:38:10.000000000 +0100
++++ ./doc/example.efnet.conf 2008-11-15 02:55:35.000000000 +0000
@@ -60,7 +60,7 @@
/* description: the description of our server. '[' and ']' may not
* be used here for compatibility with older servers.
@@ -62,7 +62,7 @@
/* umodes: the specific umodes this oper gets when they oper.
* If this is specified an oper will not be given oper_umodes
-@@ -1022,8 +1022,9 @@
+@@ -1027,8 +1027,9 @@
/* module path: paths to search for modules specified below and
* in /modload.
*/
diff --git a/irc/ircd-ratbox-devel/files/patch-include_config.h b/irc/ircd-ratbox-devel/files/patch-include_config.h
index c24bd715abd1..c905966a1591 100644
--- a/irc/ircd-ratbox-devel/files/patch-include_config.h
+++ b/irc/ircd-ratbox-devel/files/patch-include_config.h
@@ -1,8 +1,8 @@
---- ./include/config.h.orig 2008-08-17 14:16:36.000000000 +0100
-+++ ./include/config.h 2008-08-21 00:30:16.000000000 +0100
+--- ./include/config.h.orig 2008-09-19 16:33:46.000000000 +0100
++++ ./include/config.h 2008-11-15 02:55:35.000000000 +0000
@@ -52,16 +52,18 @@
#define AUTOMODPATH MODULE_DIR "/autoload/"
- #define ETCPATH ETC_DIR
+ #define ETCPATH ETC_DIR
#define LOGPATH LOG_DIR
-#define UHPATH HELP_DIR "/users"
-#define HPATH HELP_DIR "/opers"
diff --git a/irc/ircd-ratbox-devel/files/pkg-message.in b/irc/ircd-ratbox-devel/files/pkg-message.in
index 18f7a09551fc..b96bfd7b5c5c 100644
--- a/irc/ircd-ratbox-devel/files/pkg-message.in
+++ b/irc/ircd-ratbox-devel/files/pkg-message.in
@@ -17,11 +17,9 @@ using the following rc.d script command:
%%PREFIX%%/etc/rc.d/ircd-ratbox conftest
-An update of the ban.db database will be necessary if upgrading from a
-pre-beta5 release. Those upgrading from 3.0.0-beta5 or later, to this
-version, should be able to omit this step. Though it doesn't do any harm to
-check anyway. Database updates must be performed using 'bantool -u' while
-no ircd is running and before starting the newer version.
+The ban.db database can be checked and updated using 'bantool -u'.
+For safety, updates should be done while no ircd is running and before
+starting the new version.
%%PREFIX%%/bin/bantool -u