aboutsummaryrefslogtreecommitdiff
path: root/irc/ircd-ratbox-devel
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-12-19 06:29:56 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-12-19 06:29:56 +0000
commit197722c13c25ce690bbfe33742664c69cfb9cb59 (patch)
tree1146fe2511e36be6c5cc063d4f7bc30380b2a7af /irc/ircd-ratbox-devel
parent76307b9fa69e6d43572080d0b6c9e0d0b112dc74 (diff)
downloadports-197722c13c25ce690bbfe33742664c69cfb9cb59.tar.gz
ports-197722c13c25ce690bbfe33742664c69cfb9cb59.zip
- Update to 3.0.1
Port changes: o Removed patch on 'rsdb_sqlite3.c' that fixed ban.db path code in previous release. Software changes included in this release: o Call rb_helper_close on bandb errors to kill off old bandb processes. o Report correct files/line numbers for spoof warnings. o SID in the serverinfo struct should be 4 bytes, not 3. o Rebuild the included ircd_lexer.c. o Fix ports and /dev/poll for solaris. o Report libratbox version on -version and /info. o libratbox version info includes SSL info. o Fix installing when using install-sh. o Re-enable ziplinks + SSL server connections. o Fix a gnutls related core dump. o Add support for a serverinfo::bandb setting in ircd.conf for the ban database. o Report adding throttles when an oper is set umode +r. o Report throttle stats in /stats T. PR: ports/129725 Submitted by: Lewis <moggie@elasticmind.net> (maintainer)
Notes
Notes: svn path=/head/; revision=224406
Diffstat (limited to 'irc/ircd-ratbox-devel')
-rw-r--r--irc/ircd-ratbox-devel/Makefile5
-rw-r--r--irc/ircd-ratbox-devel/distinfo6
-rw-r--r--irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c24
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_example.conf19
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf19
-rw-r--r--irc/ircd-ratbox-devel/files/pkg-message.in6
6 files changed, 38 insertions, 41 deletions
diff --git a/irc/ircd-ratbox-devel/Makefile b/irc/ircd-ratbox-devel/Makefile
index b027d290a170..f30d195b3f44 100644
--- a/irc/ircd-ratbox-devel/Makefile
+++ b/irc/ircd-ratbox-devel/Makefile
@@ -7,7 +7,7 @@
# ex: ts=8
PORTNAME= ircd-ratbox
-PORTVERSION= 3.0.0
+PORTVERSION= 3.0.1
CATEGORIES= irc ipv6
MASTER_SITES= ftp://ftp.ircd-ratbox.org/pub/ircd-ratbox/testing/ \
ftp://ftp.demon.co.uk/pub/mirrors/ircd-ratbox/testing/ \
@@ -127,6 +127,9 @@ pre-build:
@${REINPLACE_CMD} -e "s#%%LOGDIR%%#${LOGDIR}#g" \
${WRKSRC}/doc/example.conf \
${WRKSRC}/doc/example.efnet.conf
+ @${REINPLACE_CMD} -e "s#%%DBDIR%%#${DBDIR}#g" \
+ ${WRKSRC}/doc/example.conf \
+ ${WRKSRC}/doc/example.efnet.conf
@${REINPLACE_CMD} -e "s#%%RUNDIR%%#${RUNDIR}#g" ${WRKSRC}/include/config.h
@${REINPLACE_CMD} -e "s#%%DBDIR%%#${DBDIR}#g" ${WRKSRC}/include/config.h
@${REINPLACE_CMD} -e "s#%%WRKSRC%%#${WRKSRC}#g" ${WRKSRC}/contrib/ircd-shortcut.pl
diff --git a/irc/ircd-ratbox-devel/distinfo b/irc/ircd-ratbox-devel/distinfo
index f406d5559230..eb16a409fc83 100644
--- a/irc/ircd-ratbox-devel/distinfo
+++ b/irc/ircd-ratbox-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (ircd-ratbox-3.0.0.tar.bz2) = 3bab4271c6b6dd197202b6ac52f805a4
-SHA256 (ircd-ratbox-3.0.0.tar.bz2) = 1f754c71fc7a519d70a664096ec5e8b5dd991d714a7ff8476b1b5a3c104a0f9e
-SIZE (ircd-ratbox-3.0.0.tar.bz2) = 1956342
+MD5 (ircd-ratbox-3.0.1.tar.bz2) = e866c51270f77ef7906b7437eb234a34
+SHA256 (ircd-ratbox-3.0.1.tar.bz2) = 6e7102d6e1b4a6363bb28feb0cf25784cfe722de089a3f8ac1047a4c0e9e4c95
+SIZE (ircd-ratbox-3.0.1.tar.bz2) = 1958864
diff --git a/irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c b/irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c
deleted file mode 100644
index 2823c2bdeee2..000000000000
--- a/irc/ircd-ratbox-devel/files/patch-bandb_rsdb_sqlite3.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./bandb/rsdb_sqlite3.c.orig 2008-11-15 02:59:20.000000000 +0000
-+++ ./bandb/rsdb_sqlite3.c 2008-11-15 02:59:59.000000000 +0000
-@@ -58,18 +58,13 @@
- int
- rsdb_init(rsdb_error_cb * ecb)
- {
-- const char *bandb_dpath;
- char dbpath[PATH_MAX];
- char errbuf[128];
- error_cb = ecb;
-
-- /* try a path from the environment first, useful for basedir overrides */
-- bandb_dpath = getenv("BANDB_DPATH");
--
-- if(bandb_dpath != NULL)
-- rb_snprintf(dbpath, sizeof(dbpath), "%s/etc/ban.db", bandb_dpath);
-- else
-- rb_strlcpy(dbpath, DBPATH, sizeof(dbpath));
-+ /* remove the getenv checks and just use the DBPATH value so bandb
-+ gets the right value for fbsd ban.db locateion. */
-+ rb_strlcpy(dbpath, DBPATH, sizeof(dbpath));
-
- if(sqlite3_open(dbpath, &rb_bandb) != SQLITE_OK)
- {
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_example.conf b/irc/ircd-ratbox-devel/files/patch-doc_example.conf
index 4265b212a97a..0cbd033c3b1c 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_example.conf
+++ b/irc/ircd-ratbox-devel/files/patch-doc_example.conf
@@ -1,5 +1,5 @@
---- ./doc/example.conf.orig 2008-11-14 16:37:10.000000000 +0000
-+++ ./doc/example.conf 2008-11-15 02:55:35.000000000 +0000
+--- ./doc/example.conf.orig 2008-12-16 03:08:43.000000000 +0000
++++ ./doc/example.conf 2008-12-17 12:52:47.000000000 +0000
@@ -98,13 +98,13 @@
default_max_clients = 10000;
@@ -17,7 +17,16 @@
/* ssld_count: number of ssld processes you want to start, if you have a really busy
* server, using N-1 where N is the number of cpu/cpu cores you have might be useful
-@@ -137,16 +137,16 @@
+@@ -112,7 +112,7 @@
+ ssld_count = 1;
+
+ /* bandb: path to the ban database - default is PREFIX/etc/ban.db */
+- bandb = "etc/ban.db";
++ bandb = "%%DBDIR%%/ban.db";
+ };
+
+ /* admin {}: contains admin information about the server. (OLD A:) */
+@@ -139,16 +139,16 @@
* - operspylog: operspy usage
* - ioerrorlog: IO errors
*/
@@ -44,7 +53,7 @@
};
/* class {}: contain information about classes for users (OLD Y:) */
-@@ -349,7 +349,7 @@
+@@ -351,7 +351,7 @@
* A password should not be defined when this is used, see
* doc/challenge.txt for more information.
*/
@@ -53,7 +62,7 @@
/* umodes: the specific umodes this oper gets when they oper.
* If this is specified an oper will not be given oper_umodes
-@@ -1013,8 +1013,9 @@
+@@ -1015,8 +1015,9 @@
/* module path: paths to search for modules specified below and
* in /modload.
*/
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf b/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
index 6caab31da254..8aa695f146c2 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
+++ b/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
@@ -1,5 +1,5 @@
---- ./doc/example.efnet.conf.orig 2008-09-22 19:38:10.000000000 +0100
-+++ ./doc/example.efnet.conf 2008-11-15 02:55:35.000000000 +0000
+--- ./doc/example.efnet.conf.orig 2008-12-16 03:08:43.000000000 +0000
++++ ./doc/example.efnet.conf 2008-12-17 12:53:08.000000000 +0000
@@ -60,7 +60,7 @@
/* description: the description of our server. '[' and ']' may not
* be used here for compatibility with older servers.
@@ -26,7 +26,16 @@
/* ssld_count: number of ssld processes you want to start, if you have a really busy
* server, using N-1 where N is the number of cpu/cpu cores you have might be useful
-@@ -140,16 +140,16 @@
+@@ -115,7 +115,7 @@
+ ssld_count = 1;
+
+ /* bandb: path to the ban database - default is PREFIX/etc/ban.db */
+- bandb = "etc/ban.db";
++ bandb = "%%DBDIR%%/ban.db";
+ };
+
+ /* admin {}: contains admin information about the server. (OLD A:) */
+@@ -142,16 +142,16 @@
* - operspylog: operspy usage
* - ioerrorlog: IO errors
*/
@@ -53,7 +62,7 @@
};
/* class {}: contain information about classes for users (OLD Y:) */
-@@ -353,7 +353,7 @@
+@@ -355,7 +355,7 @@
* A password should not be defined when this is used, see
* doc/challenge.txt for more information.
*/
@@ -62,7 +71,7 @@
/* umodes: the specific umodes this oper gets when they oper.
* If this is specified an oper will not be given oper_umodes
-@@ -1027,8 +1027,9 @@
+@@ -1029,8 +1029,9 @@
/* module path: paths to search for modules specified below and
* in /modload.
*/
diff --git a/irc/ircd-ratbox-devel/files/pkg-message.in b/irc/ircd-ratbox-devel/files/pkg-message.in
index b96bfd7b5c5c..134193235611 100644
--- a/irc/ircd-ratbox-devel/files/pkg-message.in
+++ b/irc/ircd-ratbox-devel/files/pkg-message.in
@@ -23,9 +23,9 @@ starting the new version.
%%PREFIX%%/bin/bantool -u
-Note that the ssl_only_channel configure option has been removed and is
-now available as a setting in the channel section of the ircd
-configuration file.
+Note that the ssl_only_channel compile option has been removed, and
+should be added as a configuration setting (use_sslonly) in the
+ircd.conf file in order to activate the +S channel mode.
Be sure to check out 'ratbox-services' if you need a services package.
------------------------------------------------------------------------