aboutsummaryrefslogtreecommitdiff
path: root/irc/ircd-ratbox-devel
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-02 23:36:37 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-02 23:36:37 +0000
commit9706c706c493e68d42ee0eda3ab08b13dbf7b681 (patch)
tree3a81063ce6c0d4357eb08e18376c883d8ebb1b41 /irc/ircd-ratbox-devel
parentb64e38a747e78fbc95bbf6d4d8e10306e14ddd2c (diff)
downloadports-9706c706c493e68d42ee0eda3ab08b13dbf7b681.tar.gz
ports-9706c706c493e68d42ee0eda3ab08b13dbf7b681.zip
- Update to 3.0.0.b7
Changes: o sqlite3 dependency restored. o Added support for services' ircd-shortcut commands make options. o Added dependency on PERL for generation of ircd-shortcut modules. o The example EFNet configuration file is not helpful because it has not been updated for ratbox-3. It therefore is not installed as standard by this port version, but should be back in the next update. Software changes include: o Change -lock klines and friends to now use the ADMINKLINE etc commands. o Change to only support TS6. o Fix remote kline reasons. o Have sqlite3 checking use pkg-config when possible. o Move identd checking back into the ircd, this seems to have been more problematic than what it was worth. o Add experimental gnutls support - note that CHALLENGE does not work when using just gnutls. o Some helpfile cleanups and additions. o Fix compile error when zlib is not found. o Remove some restrictions on k/d/x/resv reasons that are no longer needed. PR: ports/125106 Submitted by: Lewis <moggie@elasticmind.net> (maintainer)
Notes
Notes: svn path=/head/; revision=216187
Diffstat (limited to 'irc/ircd-ratbox-devel')
-rw-r--r--irc/ircd-ratbox-devel/Makefile73
-rw-r--r--irc/ircd-ratbox-devel/distinfo6
-rw-r--r--irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl11
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_Makefile.in2
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_example.conf20
-rw-r--r--irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf59
-rw-r--r--irc/ircd-ratbox-devel/files/patch-include_config.h10
-rw-r--r--irc/ircd-ratbox-devel/files/pkg-message.in8
-rw-r--r--irc/ircd-ratbox-devel/pkg-plist9
9 files changed, 110 insertions, 88 deletions
diff --git a/irc/ircd-ratbox-devel/Makefile b/irc/ircd-ratbox-devel/Makefile
index ee4a0f7b79b6..97f9ebbe987a 100644
--- a/irc/ircd-ratbox-devel/Makefile
+++ b/irc/ircd-ratbox-devel/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ircd-ratbox
#PORTVERSION= 3.0.0
-DISTVERSION= 3.0.0beta5
+DISTVERSION= 3.0.0beta7
CATEGORIES= irc ipv6
MASTER_SITES= ftp://ftp.ircd-ratbox.org/pub/ircd-ratbox/testing/ \
ftp://ftp.demon.co.uk/pub/mirrors/ircd-ratbox/testing/ \
@@ -25,7 +25,8 @@ CONFLICTS= ircd-ratbox-[0-9]*
USE_BZIP2= yes
#MAN8= ircd.8
USE_RC_SUBR= ircd-ratbox.sh
-#USE_SQLITE= 3
+USE_SQLITE= 3
+USE_PERL5_BUILD= yes
USE_LDCONFIG= ${PREFIX}/lib/ircd-ratbox
LOGDIR?= /var/log/${PORTNAME}
@@ -111,10 +112,20 @@ pre-configure:
@${ECHO_MSG} "This port has additional options:"
@${ECHO_MSG} " NICKLEN [default 9, max 50] - Max nick length on server"
@${ECHO_MSG} ""
+ @${ECHO_MSG} " SERVER_NAME [default 'services.ircd-ratbox.org'] - Name of services"
+ @${ECHO_MSG} " USER_SERV [default 'USERSERV'] - Name of user registration service"
+ @${ECHO_MSG} " CHAN_SERV [default 'CHANSERV'] - Name of channel registration serv'"
+ @${ECHO_MSG} " NICK_SERV [default 'NICKSERV'] - Name of nickname registration serv'"
+ @${ECHO_MSG} " ALIS_SERV [default 'ALIS'] - Name of channel list service"
+ @${ECHO_MSG} " OPER_BOT [default 'OPERBOT'] - Name of operbot service"
+ @${ECHO_MSG} " OPER_SERV [default 'OPERSERV'] - Name of oper command service"
+ @${ECHO_MSG} " JUPE_SERV [default 'JUPESERV'] - Name of jupe service"
+ @${ECHO_MSG} " GLOBAL_SERV [default 'GLOBAL'] - Name of global announce service"
+ @${ECHO_MSG} ""
@${ECHO_MSG} "Press CTRL+C now if you wish to set them."
@${ECHO_MSG} ""
-post-patch:
+pre-build:
@${REINPLACE_CMD} -e "s#-O2##" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#g" \
${WRKSRC}/doc/example.conf \
@@ -124,11 +135,60 @@ post-patch:
${WRKSRC}/doc/example.efnet.conf
@${REINPLACE_CMD} -e "s#%%RUNDIR%%#${RUNDIR}#g" ${WRKSRC}/include/config.h
@${REINPLACE_CMD} -e "s#%%DBDIR%%#${DBDIR}#g" ${WRKSRC}/include/config.h
+ @${REINPLACE_CMD} -e "s#%%WRKSRC%%#${WRKSRC}#g" ${WRKSRC}/contrib/ircd-shortcut.pl
+
+#-- ircd-shortcut.pl ratbox-services commands --------------------------------------
+
+.if defined(SERVER_NAME)
+ @${REINPLACE_CMD} -e "s#services.ircd-ratbox.org#${SERVER_NAME}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(USER_SERV)
+ @${REINPLACE_CMD} -e "s#USERSERV#${USER_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(CHAN_SERV)
+ @${REINPLACE_CMD} -e "s#CHANSERV#${CHAN_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(NICK_SERV)
+ @${REINPLACE_CMD} -e "s#NICKSERV#${NICK_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(ALIS_SERV)
+ @${REINPLACE_CMD} -e "s#ALIS#${ALIS_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(OPER_BOT)
+ @${REINPLACE_CMD} -e "s#OPERBOT#${OPER_BOT}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(OPER_SERV)
+ @${REINPLACE_CMD} -e "s#OPERSERV#${OPER_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(JUPE_SERV)
+ @${REINPLACE_CMD} -e "s#JUPESERV#${JUPE_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+.if defined(GLOBAL_SERV)
+ @${REINPLACE_CMD} -e "s#GLOBAL#${GLOBAL_SERV}#" \
+ ${WRKSRC}/contrib/ircd-shortcut.pl
+.endif
+
+#------ Execute ircd-shortcut perl script to generate the .c file. -----
+ @${ECHO_MSG} "Executing ircd-shortcut.pl for ircd-shortcuts generation."
+ ${PERL} ${WRKSRC}/contrib/ircd-shortcut.pl
post-build:
@cd ${INSTALL_WRKSRC}/contrib && ${SETENV} ${MAKE_ENV} ${MAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
+# ----- Need to build the m_rsshortcut.so module for ircd-shortcut.pl ----
+ @${ECHO_MSG} "Building m_rsshortcut.la for ircd-shortcuts."
+ @cd ${INSTALL_WRKSRC}/contrib && ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} m_rsshortcut.la
+
pre-su-install:
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${MKDIR} ${PREFIX}/etc/${PORTNAME}
@@ -144,9 +204,14 @@ post-install:
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install
${INSTALL_DATA} ${WRKSRC}/doc/ircd.motd ${PREFIX}/etc/${PORTNAME}/ircd.motd.sample
${INSTALL_DATA} ${WRKSRC}/doc/example.conf ${PREFIX}/etc/${PORTNAME}/ircd.conf.sample
- ${INSTALL_DATA} ${WRKSRC}/doc/example.efnet.conf ${PREFIX}/etc/${PORTNAME}/ircd-efnet.conf.sample
+# ${INSTALL_DATA} ${WRKSRC}/doc/example.efnet.conf ${PREFIX}/etc/${PORTNAME}/ircd-efnet.conf.sample
${INSTALL_DATA} ${WRKSRC}/doc/genssl.sh ${PREFIX}/etc/${PORTNAME}/genssl.sh
+# ----- We need to install the shortcut.pl module ----
+ @${ECHO_MSG} "Executing install-mod.sh for ircd-shortcuts module installation."
+ ${SH} ${WRKSRC}/install-mod.sh ${WRKSRC}/contrib/m_rsshortcut.la \
+ ${PREFIX}/lib/${PORTNAME}/modules/contrib
+
@if [ ! -f ${PREFIX}/etc/${PORTNAME}/ircd.conf ]; then \
${ECHO} "Installing default configuration file."; \
${CP} -p ${PREFIX}/etc/${PORTNAME}/ircd.conf.sample ${PREFIX}/etc/${PORTNAME}/ircd.conf ; \
diff --git a/irc/ircd-ratbox-devel/distinfo b/irc/ircd-ratbox-devel/distinfo
index 7ec2dab2d7ca..b848d3afbd29 100644
--- a/irc/ircd-ratbox-devel/distinfo
+++ b/irc/ircd-ratbox-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (ircd-ratbox-3.0.0beta5.tar.bz2) = edb1aad622ad6312144818311ad8d2c8
-SHA256 (ircd-ratbox-3.0.0beta5.tar.bz2) = c5270090e5d034ac8c5a874e52c6ec586e93393dcd9456eb35d3e9fa95517ea2
-SIZE (ircd-ratbox-3.0.0beta5.tar.bz2) = 1966643
+MD5 (ircd-ratbox-3.0.0beta7.tar.bz2) = 7fd345c89c17c078dcbc2258a3a78710
+SHA256 (ircd-ratbox-3.0.0beta7.tar.bz2) = 5791ea30da68c4401f1427888e112679b5a96ac21654e9f1649f4ba79f19c455
+SIZE (ircd-ratbox-3.0.0beta7.tar.bz2) = 1982786
diff --git a/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl b/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl
new file mode 100644
index 000000000000..47307ad94a9a
--- /dev/null
+++ b/irc/ircd-ratbox-devel/files/patch-contrib_ircd-shortcut.pl
@@ -0,0 +1,11 @@
+--- ./contrib/ircd-shortcut.pl.orig 2008-06-29 14:05:58.000000000 +0100
++++ ./contrib/ircd-shortcut.pl 2008-06-29 14:07:11.000000000 +0100
+@@ -36,7 +36,7 @@
+ ######################################
+
+
+-open(FILE, '>', 'm_rsshortcut.c');
++open(FILE, '>', '%%WRKSRC%%/contrib/m_rsshortcut.c');
+
+ print FILE <<".EOF.";
+ /* m_rsshortcut.c
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in b/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in
index 87fe9606da4e..347f3f5080c0 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in
+++ b/irc/ircd-ratbox-devel/files/patch-doc_Makefile.in
@@ -1,5 +1,5 @@
--- ./doc/Makefile.in.orig 2008-04-23 20:59:46.000000000 +0100
-+++ ./doc/Makefile.in 2008-06-18 14:31:34.000000000 +0100
++++ ./doc/Makefile.in 2008-06-29 14:29:39.000000000 +0100
@@ -43,24 +43,6 @@
fi
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_example.conf b/irc/ircd-ratbox-devel/files/patch-doc_example.conf
index 6af27dffa786..fab418c68bed 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_example.conf
+++ b/irc/ircd-ratbox-devel/files/patch-doc_example.conf
@@ -1,23 +1,23 @@
---- ./doc/example.conf.orig Mon Mar 10 20:28:36 2008
-+++ ./doc/example.conf Tue Apr 22 02:23:42 2008
-@@ -93,13 +93,13 @@
+--- ./doc/example.conf.orig 2008-06-18 18:49:53.000000000 +0100
++++ ./doc/example.conf 2008-06-29 14:39:37.000000000 +0100
+@@ -88,13 +88,13 @@
default_max_clients = 10000;
/* ssl_private_key: our ssl private key */
- ssl_private_key = "etc/test.key";
-+ ssl_private_key = "/usr/local/etc/ssl/test.key";
++ ssl_private_key = "%%PREFIX%%/etc/ssl/test.key";
/* ssl_cert: certificate for our ssl server */
- ssl_cert = "etc/test.cert";
-+ ssl_cert = "/usr/local/etc/ssl/test.cert";
++ ssl_cert = "%%PREFIX%%/etc/ssl/test.cert";
/* ssl_dh_params: DH parameters, generate with openssl dhparam -out dh.pem 1024 */
- ssl_dh_params = "etc/dh.pem";
-+ ssl_dh_params = "/usr/local/etc/ssl/dh.pem";
++ ssl_dh_params = "%%PREFIX%%/etc/ssl/dh.pem";
/* ssld_count: number of ssld processes you want to start, if you have a really busy
* server, using N-1 where N is the number of cpu/cpu cores you have might be useful
-@@ -132,16 +132,16 @@
+@@ -127,16 +127,16 @@
* - operspylog: operspy usage
* - ioerrorlog: IO errors
*/
@@ -44,7 +44,7 @@
};
/* class {}: contain information about classes for users (OLD Y:) */
-@@ -337,7 +337,7 @@
+@@ -332,7 +332,7 @@
* A password should not be defined when this is used, see
* doc/challenge.txt for more information.
*/
@@ -53,7 +53,7 @@
/* umodes: the specific umodes this oper gets when they oper.
* If this is specified an oper will not be given oper_umodes
-@@ -946,7 +946,7 @@
+@@ -942,7 +942,7 @@
*
* only define if servlink is not in same directory as ircd itself.
*/
@@ -62,7 +62,7 @@
/* use egd: if your system does not have *random devices yet you
* want to use OpenSSL and encrypted links, enable this. Beware -
-@@ -999,8 +999,9 @@
+@@ -995,8 +995,9 @@
/* module path: paths to search for modules specified below and
* in /modload.
*/
diff --git a/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf b/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
index 3d3e7699046c..e69de29bb2d1 100644
--- a/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
+++ b/irc/ircd-ratbox-devel/files/patch-doc_example.efnet.conf
@@ -1,59 +0,0 @@
---- ./doc/example.efnet.conf.orig Wed Sep 5 20:00:42 2007
-+++ ./doc/example.efnet.conf Tue Apr 22 02:26:59 2008
-@@ -119,16 +119,16 @@
- * - operspylog: operspy usage
- * - ioerrorlog: IO errors
- */
-- fname_userlog = "logs/userlog";
-- #fname_fuserlog = "logs/fuserlog";
-- fname_operlog = "logs/operlog";
-- #fname_foperlog = "logs/foperlog";
-- fname_serverlog = "logs/serverlog";
-- fname_glinelog = "logs/glinelog";
-- #fname_klinelog = "logs/klinelog";
-- fname_killlog = "logs/killlog";
-- fname_operspylog = "logs/operspylog";
-- #fname_ioerrorlog = "logs/ioerror";
-+ fname_userlog = "%%LOGDIR%%/userlog";
-+ #fname_fuserlog = "%%LOGDIR%%/fuserlog";
-+ fname_operlog = "%%LOGDIR%%/operlog";
-+ #fname_foperlog = "%%LOGDIR%%/foperlog";
-+ fname_serverlog = "%%LOGDIR%%/serverlog";
-+ fname_glinelog = "%%LOGDIR%%/glinelog";
-+ #fname_klinelog = "%%LOGDIR%%/klinelog";
-+ fname_killlog = "%%LOGDIR%%/killlog";
-+ fname_operspylog = "%%LOGDIR%%/operspylog";
-+ #fname_ioerrorlog = "%%LOGDIR%%/ioerror";
- };
-
- /* class {}: contain information about classes for users (OLD Y:) */
-@@ -316,7 +316,7 @@
- * A password should not be defined when this is used, see
- * doc/challenge.txt for more information.
- */
-- #rsa_public_key_file = "/usr/local/ircd/etc/oper.pub";
-+ #rsa_public_key_file = "%%PREFIX%%/etc/oper.pub";
-
- /* umodes: the specific umodes this oper gets when they oper.
- * If this is specified an oper will not be given oper_umodes
-@@ -906,7 +906,7 @@
- *
- * only define if servlink is not in same directory as ircd itself.
- */
-- #servlink_path = "/usr/local/ircd/bin/servlink";
-+ #servlink_path = "%%PREFIX%%/bin/servlink";
-
- /* use egd: if your system does not have *random devices yet you
- * want to use OpenSSL and encrypted links, enable this. Beware -
-@@ -956,8 +956,9 @@
- /* module path: paths to search for modules specified below and
- * in /modload.
- */
-- path = "/usr/local/ircd/modules";
-- path = "/usr/local/ircd/modules/autoload";
-+ path = "%%PREFIX%%/lib/ircd-ratbox/modules/";
-+ path = "%%PREFIX%%/lib/ircd-ratbox/autoload/";
-+ path = "%%PREFIX%%/lib/ircd-ratbox/modules/contrib/";
-
- /* module: the name of a module to load on startup/rehash */
- #module = "some_module.so";
diff --git a/irc/ircd-ratbox-devel/files/patch-include_config.h b/irc/ircd-ratbox-devel/files/patch-include_config.h
index cdafb97b7cee..229f415d50c2 100644
--- a/irc/ircd-ratbox-devel/files/patch-include_config.h
+++ b/irc/ircd-ratbox-devel/files/patch-include_config.h
@@ -1,11 +1,11 @@
---- ./include/config.h.orig Wed Sep 5 20:08:21 2007
-+++ ./include/config.h Tue Apr 22 02:20:19 2008
+--- ./include/config.h.orig 2008-06-09 19:32:50.000000000 +0100
++++ ./include/config.h 2008-06-29 14:51:42.000000000 +0100
@@ -54,15 +54,17 @@
#define LOGPATH LOG_DIR
#define UHPATH HELP_DIR "/users"
#define HPATH HELP_DIR "/opers"
-+#define RUNPATH "/var/run/ircd-ratbox"
-+#define DBPTH "/var/db/ircd-ratbox"
++#define RUNPATH "%%RUNDIR%%"
++#define DBPTH "%%DBDIR%%"
/* files */
#define SPATH BINPATH "/ircd" /* ircd executable */
@@ -19,4 +19,4 @@
+#define PPATH RUNPATH "/ircd.pid" /* pid file */
#define OPATH ETCPATH "/opers.motd" /* oper MOTD file */
- /* TS6_ONLY
+ /* HANGONGOODLINK and HANGONGOODLINK
diff --git a/irc/ircd-ratbox-devel/files/pkg-message.in b/irc/ircd-ratbox-devel/files/pkg-message.in
index c7d71c304897..312c3b1f817d 100644
--- a/irc/ircd-ratbox-devel/files/pkg-message.in
+++ b/irc/ircd-ratbox-devel/files/pkg-message.in
@@ -17,9 +17,11 @@ using the following rc.d script command:
%%PREFIX%%/etc/rc.d/ircd-ratbox conftest
-An update of the ban.db database may be necessary when upgrading between
-ircd versions. You must perform this update manually using 'bantool -u'
-while no ircd is running and before starting the newer version.
+An update of the ban.db database will be necessary if upgrading from a
+pre-beta5 release. Those upgrading from 3.0.0-beta5 to this version
+should be able to omit this step. Though it doesn't do any harm to check
+anyway. Database updates must be performed using 'bantool -u' while no
+ircd is running and before starting the newer version.
%%PREFIX%%/bin/bantool -u
diff --git a/irc/ircd-ratbox-devel/pkg-plist b/irc/ircd-ratbox-devel/pkg-plist
index d5e9aa9f9f5e..d744618445f5 100644
--- a/irc/ircd-ratbox-devel/pkg-plist
+++ b/irc/ircd-ratbox-devel/pkg-plist
@@ -1,9 +1,7 @@
bin/ircd
bin/ratbox-mkpasswd
bin/bantool
-bin/ratbox-sqlite3
libexec/ircd-ratbox/bandb
-libexec/ircd-ratbox/ident
libexec/ircd-ratbox/resolver
libexec/ircd-ratbox/ssld
%%DATADIR%%/help/opers/accept
@@ -51,6 +49,7 @@ libexec/ircd-ratbox/ssld
%%DATADIR%%/help/opers/oper
%%DATADIR%%/help/opers/operspy
%%DATADIR%%/help/opers/operwall
+%%DATADIR%%/help/opers/adminwall
%%DATADIR%%/help/opers/part
%%DATADIR%%/help/opers/pass
%%DATADIR%%/help/opers/ping
@@ -85,6 +84,10 @@ libexec/ircd-ratbox/ssld
%%DATADIR%%/help/opers/userhost
%%DATADIR%%/help/opers/users
%%DATADIR%%/help/opers/version
+%%DATADIR%%/help/opers/admindline
+%%DATADIR%%/help/opers/adminkline
+%%DATADIR%%/help/opers/adminresv
+%%DATADIR%%/help/opers/adminxline
%%DATADIR%%/help/opers/wallops
%%DATADIR%%/help/opers/who
%%DATADIR%%/help/opers/whois
@@ -211,6 +214,7 @@ lib/ircd-ratbox/modules/contrib/spy_stats_notice.so
lib/ircd-ratbox/modules/contrib/spy_stats_p_notice.so
lib/ircd-ratbox/modules/contrib/spy_whois_notice.so
lib/ircd-ratbox/modules/contrib/spy_whois_notice_global.so
+lib/ircd-ratbox/modules/contrib/m_rsshortcut.so
lib/ircd-ratbox/modules/m_die.so
lib/ircd-ratbox/modules/m_error.so
lib/ircd-ratbox/modules/m_join.so
@@ -233,7 +237,6 @@ lib/ircd-ratbox/modules/m_squit.so
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%
etc/ircd-ratbox/genssl.sh
-etc/ircd-ratbox/ircd-efnet.conf.sample
@unexec if cmp -s %D/etc/ircd-ratbox/ircd.conf.sample %D/etc/ircd-ratbox/ircd.conf; then rm -f %D/etc/ircd-ratbox/ircd.conf; fi
etc/ircd-ratbox/ircd.conf.sample
@exec if [ ! -f %D/etc/ircd-ratbox/ircd.conf ] ; then cp -p %D/%F %B/ircd.conf; fi