aboutsummaryrefslogtreecommitdiff
path: root/irc/ircproxy/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-12-18 08:22:10 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-12-18 08:22:10 +0000
commitcd8375131c0f6fd41a4c904f5f1662fa311e98e2 (patch)
treee3b45bbbb4d4c3e9af53367f7964a15a92323589 /irc/ircproxy/Makefile
parentd9669b026a56c53811cf9dc3952e1f4049648d64 (diff)
- Update to 1.3.1b
Submitted by: Jonas Kvinge <jonas@emptyglass.night-light.net> (maintainer) Approved by: linimon (mentor)
Notes
Notes: svn path=/head/; revision=203975
Diffstat (limited to 'irc/ircproxy/Makefile')
-rw-r--r--irc/ircproxy/Makefile57
1 files changed, 36 insertions, 21 deletions
diff --git a/irc/ircproxy/Makefile b/irc/ircproxy/Makefile
index 96ac05b176a8..122f367911e7 100644
--- a/irc/ircproxy/Makefile
+++ b/irc/ircproxy/Makefile
@@ -6,30 +6,45 @@
#
PORTNAME= ircproxy
-DISTVERSION= 1.2.42d.pre3
+PORTVERSION= 1.3.1b
CATEGORIES= irc
-MASTER_SITES= http://www.ircproxy.night-light.net/files/
+MASTER_SITES= http://filearchive.night-light.net/packages/sources/ircproxy/
MAINTAINER= jonas@night-light.net
COMMENT= An IRC proxy/bouncer daemon
-GNU_CONFIGURE= yes
-CONFIGURE_WRKSRC= ${WRKSRC}/config
+LIB_DEPENDS= cares.1:${PORTSDIR}/dns/c-ares
-#
-# Copy the freebsd port setup file to automatically generate setup.h
-# So we dont need to do make config, I think this might be the best
-# solution.
-#
-pre-build:
- @if [ ! -f ${WRKSRC}/config/setup-file ]; then ( \
- if [ ! -f ${WRKSRC}/setup/setup-freebsd ]; then ( ${ECHO} "Missing the setup-freebsd file!"; exit 1; ) fi; \
- ${CP} ${WRKSRC}/setup/setup-freebsd ${WRKSRC}/setup/setup-file || exit 1; \
- cd ${WRKSRC}/setup; SETUP_BATCH=y SETUP_QUIET=y ${SH} ./setup || exit 1; \
- cd ${WRKSRC}/setup; ${SH} ./setup-makefile || exit 1; \
- ) \
- fi;
- ${CHMOD} u+x ${WRKSRC}/pkg-install || exit 1
- ${CHMOD} u+x ${WRKSRC}/pkg-deinstall || exit 1
-
-.include <bsd.port.mk>
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${LOCALBASE}
+
+OPTIONS= SSL "Enable SSL support" on \
+ IPV6 "Enable IPv6 support" on \
+ MEMDEBUG "Enable memory debugging" on \
+ FDDEBUG "Enable file descriptor debugging" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SSL)
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.else
+CONFIGURE_ARGS+= --disable-ssl
+.endif
+
+.if !defined(WITH_IPV6)
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.if defined(WITH_MEMDEBUG)
+CONFIGURE_ARGS+= --enable-memdebug
+.else
+CONFIGURE_ARGS+= --disable-memdebug
+.endif
+
+.if defined(WITH_FDDEBUG)
+CONFIGURE_ARGS+= --enable-fddebug
+.else
+CONFIGURE_ARGS+= --disable-fddebug
+.endif
+
+.include <bsd.port.post.mk>