aboutsummaryrefslogtreecommitdiff
path: root/irc/iroffer-dinoex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-04-16 14:49:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-04-16 14:49:59 +0000
commitae5215e025daae99b3ebfe22cd65310eebbdfc70 (patch)
tree95bc399a7e716d1a06cd630891cabc9b67eedc7b /irc/iroffer-dinoex
parentbc119880610cc9f9b32a3d34644e515755fd6575 (diff)
downloadports-ae5215e025daae99b3ebfe22cd65310eebbdfc70.tar.gz
ports-ae5215e025daae99b3ebfe22cd65310eebbdfc70.zip
- cleanup rc.d script
Notes
Notes: svn path=/head/; revision=531850
Diffstat (limited to 'irc/iroffer-dinoex')
-rw-r--r--irc/iroffer-dinoex/Makefile5
-rw-r--r--irc/iroffer-dinoex/files/iroffer.in (renamed from irc/iroffer-dinoex/files/iroffer-dinoex.in)35
2 files changed, 19 insertions, 21 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index 7b113c73c924..9781f60e3f4c 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= iroffer
PORTVERSION= 3.32
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= irc
MASTER_SITES= https://iroffer.net/
PKGNAMESUFFIX= -dinoex${PKGNAMESUFFIX2}
@@ -20,8 +20,9 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= CC="${CC}" LDFLAGS="${LDFLAGS}" LOCALBASE="${LOCALBASE}"
CONFIGURE_ENV= LANG=en_EN.UTF-8
+MAKE_ENV= LANG=en_EN.UTF-8
ALL_TARGET= all-lang doc
-USE_RC_SUBR= iroffer-dinoex
+USE_RC_SUBR= iroffer
IROFFER_DOCS= README README.modDinoex LIESMICH.modDinoex \
LICENSE THANKS TODO \
diff --git a/irc/iroffer-dinoex/files/iroffer-dinoex.in b/irc/iroffer-dinoex/files/iroffer.in
index 08ef365273e9..b9aa05d0b833 100644
--- a/irc/iroffer-dinoex/files/iroffer-dinoex.in
+++ b/irc/iroffer-dinoex/files/iroffer.in
@@ -2,11 +2,9 @@
#
# $FreeBSD$
#
-
# PROVIDE: iroffer
# REQUIRE: LOGIN
# KEYWORD: shutdown
-
#
# iroffer_enable="YES"
# iroffer_flags="<set as needed>"
@@ -21,18 +19,27 @@
. /etc/rc.subr
name="iroffer"
-rcvar=iroffer_enable
+desc="Iroffer IRC Bot"
+rcvar="iroffer_enable"
-# read configuration and set defaults
load_rc_config "$name"
-: ${iroffer_enable="NO"}
-: ${iroffer_user="bot"}
-: ${iroffer_bin="iroffer"}
-: ${iroffer_dir="/home/bot/iroffer/"}
-: ${iroffer_config="${iroffer_dir}mybot.config"}
+
+: ${iroffer_enable:="NO"}
+: ${iroffer_user:="bot"}
+: ${iroffer_bin:="iroffer"}
+: ${iroffer_dir:="/home/bot/iroffer/"}
+: ${iroffer_config:="${iroffer_dir}mybot.config"}
start_precmd="iroffer_checkdisk"
restart_precmd="iroffer_checkdisk"
+required_files="${iroffer_config}"
+command="${iroffer_dir}/${iroffer_bin}"
+if [ -n "${iroffer_dir}" ]; then
+ command_args="${command_args} -w ${iroffer_dir}"
+fi
+command_args="${command_args} -u ${iroffer_user}"
+command_args="${command_args} -b ${iroffer_config}"
+pidfile="${iroffer_dir}/mybot.pid"
iroffer_checkdisk()
{
@@ -46,14 +53,4 @@ iroffer_checkdisk()
fi
}
-required_files="${iroffer_config}"
-command="${iroffer_dir}/${iroffer_bin}"
-if [ -n "${iroffer_dir}" ]; then
- command_args="${command_args} -w ${iroffer_dir}"
-fi
-command_args="${command_args} -u ${iroffer_user}"
-command_args="${command_args} -b ${iroffer_config}"
-pidfile="${iroffer_dir}/mybot.pid"
run_rc_command "$1"
-
-# eof