aboutsummaryrefslogtreecommitdiff
path: root/irc/iroffer-dinoex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-15 16:54:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-15 16:54:14 +0000
commitc9647d0d7e94b2806d2bac25e37b1abacd094b60 (patch)
tree74ea99a81fcc243800275afa7b8591dd6da19b80 /irc/iroffer-dinoex
parent8cf57617d17e04fc71e1eef13a92aa294abf0611 (diff)
downloadports-c9647d0d7e94b2806d2bac25e37b1abacd094b60.tar.gz
ports-c9647d0d7e94b2806d2bac25e37b1abacd094b60.zip
- use OPTIONS_DEFINE
Notes
Notes: svn path=/head/; revision=299366
Diffstat (limited to 'irc/iroffer-dinoex')
-rw-r--r--irc/iroffer-dinoex/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index dbf09c164fcc..253826d1a15d 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -44,26 +44,24 @@ IROFFER_EXAMPLES= iroffer.cron \
IROFFER_HTDOCS= iroffer-state.css robots.txt \
info.txt.rb md5.txt.rb sfv.txt.rb
-OPTIONS= CURL "build ftp/http support" on \
- RUBY "build RUBY script support" on \
- UPNP "build UPNP support" on \
- GEOIP "build GEOIP support" on \
+OPTIONS_DEFINE= CURL RUBY UPNP GEOIP
+OPTIONS_DEFAULT=CURL RUBY UPNP GEOIP
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_CURL)
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= -curl
.endif
-.if !defined(WITHOUT_GEOIP)
+.if ${PORT_OPTIONS:MGEOIP}
LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= -geoip
.endif
-.if !defined(WITHOUT_UPNP)
+.if ${PORT_OPTIONS:MUPNP}
LIB_DEPENDS+= miniupnpc:${PORTSDIR}/net/miniupnpc
CONFIGURE_ARGS+= -upnp
.endif
-.if !defined(WITHOUT_RUBY)
+.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
CONFIGURE_ARGS+= -ruby
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
@@ -92,4 +90,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/iroffer.1 ${PREFIX}/man/man1/
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>