aboutsummaryrefslogtreecommitdiff
path: root/irc/irssi-xmpp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-12 23:56:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-12 23:56:31 +0000
commitb7197b79cf00159d2ba139c5fd3f16d8d0aeb7e7 (patch)
tree2f3001e285a591ea4237a80d702a393cd84b9ba5 /irc/irssi-xmpp
parent999cc14c58970aa321d43b4fe798293bbc88833a (diff)
downloadports-b7197b79cf00159d2ba139c5fd3f16d8d0aeb7e7.tar.gz
ports-b7197b79cf00159d2ba139c5fd3f16d8d0aeb7e7.zip
irssi-xmpp's aim is to provide a good integration in this text-based
irc client and a good support of XMPP (the Jabber protocol). Current main features are: * Sending and receiving messages in irssi's query windows * A roster with contact's ressources tracking (contact list) * Contact management (add, remove, manage subscriptions...) * Contact's JIDs, ressources and commands completion (TAB key) * Multiple accounts support (in different connection) * Unicode support (UTF-8) * SSL support * ... WWW: http://cybione.org/src/irssi-xmpp/ PR: ports/116304 Submitted by: Philippe Audeoud <jadawin at tuxaco.net>
Notes
Notes: svn path=/head/; revision=199389
Diffstat (limited to 'irc/irssi-xmpp')
-rw-r--r--irc/irssi-xmpp/Makefile37
-rw-r--r--irc/irssi-xmpp/distinfo3
-rw-r--r--irc/irssi-xmpp/pkg-descr15
3 files changed, 55 insertions, 0 deletions
diff --git a/irc/irssi-xmpp/Makefile b/irc/irssi-xmpp/Makefile
new file mode 100644
index 000000000000..06629f811371
--- /dev/null
+++ b/irc/irssi-xmpp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: irssi-xmpp
+# Date created: 11 September 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+# $FreeBSD$
+
+PORTNAME= irssi-xmpp
+PORTVERSION= 0.13
+CATEGORIES= irc
+MASTER_SITES= http://cybione.org/src/irssi-xmpp/
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= Irssi-xmpp is an irssi plugin to connect to the Jabber network
+
+BUILD_DEPENDS= irssi:${PORTSDIR}/irc/irssi
+RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
+LIB_DEPENDS= loudmouth:${PORTSDIR}/net-im/loudmouth
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+MAKE_ENV= IRSSI_INCLUDE="${LOCALBASE}/include/irssi/"
+
+PLIST_FILES= lib/irssi/modules/libfe_xmpp.so \
+ lib/irssi/modules/libxmpp_core.so
+PORTDOCS= README
+
+do-install:
+.for data in core fe-common
+ ${MKDIR} ${PREFIX}/lib/irssi/modules
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${data}/*.so \
+ ${PREFIX}/lib/irssi/modules
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/irssi-xmpp/distinfo b/irc/irssi-xmpp/distinfo
new file mode 100644
index 000000000000..0613353f19bc
--- /dev/null
+++ b/irc/irssi-xmpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (irssi-xmpp-0.13.tar.gz) = be2dab63a3ef5d86c3be9d5ff02f26fe
+SHA256 (irssi-xmpp-0.13.tar.gz) = 0f6741c702222390d337c03b17ff65ed61a932fcd98780b5ffafbfdabf6eefa7
+SIZE (irssi-xmpp-0.13.tar.gz) = 25074
diff --git a/irc/irssi-xmpp/pkg-descr b/irc/irssi-xmpp/pkg-descr
new file mode 100644
index 000000000000..f18b5041ad82
--- /dev/null
+++ b/irc/irssi-xmpp/pkg-descr
@@ -0,0 +1,15 @@
+irssi-xmpp's aim is to provide a good integration in this text-based
+irc client and a good support of XMPP (the Jabber protocol).
+
+Current main features are:
+
+ * Sending and receiving messages in irssi's query windows
+ * A roster with contact's ressources tracking (contact list)
+ * Contact management (add, remove, manage subscriptions...)
+ * Contact's JIDs, ressources and commands completion (TAB key)
+ * Multiple accounts support (in different connection)
+ * Unicode support (UTF-8)
+ * SSL support
+ * ...
+
+WWW: http://cybione.org/src/irssi-xmpp/