aboutsummaryrefslogtreecommitdiff
path: root/irc/irssi-xmpp
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-02-12 17:59:34 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-02-12 17:59:34 +0000
commitdac2b543261a80bd52ea61ef1427720d10cfc104 (patch)
tree6ff22dcf9031b84c56d5be9393ee8b2888ce4483 /irc/irssi-xmpp
parent381170da5ab33b209316067ba1797834e5412c19 (diff)
downloadports-dac2b543261a80bd52ea61ef1427720d10cfc104.tar.gz
ports-dac2b543261a80bd52ea61ef1427720d10cfc104.zip
irc/irssi-xmpp: Fix build with irssi < 1.0
- Remove patch for irssi >= 1.0 - irc/irssi is currently at 0.8 PR: 215829 Approved by: just-fix-it blanket
Notes
Notes: svn path=/head/; revision=433956
Diffstat (limited to 'irc/irssi-xmpp')
-rw-r--r--irc/irssi-xmpp/Makefile2
-rw-r--r--irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a41
2 files changed, 0 insertions, 43 deletions
diff --git a/irc/irssi-xmpp/Makefile b/irc/irssi-xmpp/Makefile
index a9d04f973920..23a749613041 100644
--- a/irc/irssi-xmpp/Makefile
+++ b/irc/irssi-xmpp/Makefile
@@ -16,8 +16,6 @@ BUILD_DEPENDS= irssi:irc/irssi
LIB_DEPENDS= libloudmouth-1.so:net-im/loudmouth
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BROKEN= does not build (error: no member named 'use_tls' in 'struct _XMPP_SERVER_CONNECT_REC')
-
USES= gettext-runtime pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
diff --git a/irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a b/irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a
deleted file mode 100644
index 0a3919917512..000000000000
--- a/irc/irssi-xmpp/files/patch-d56d614b89ecc34845e0f5971c545b893c2c359a
+++ /dev/null
@@ -1,41 +0,0 @@
-From d56d614b89ecc34845e0f5971c545b893c2c359a Mon Sep 17 00:00:00 2001
-From: benaryorg <binary@benary.org>
-Date: Fri, 20 Jan 2017 06:31:28 +0100
-Subject: [PATCH] fix #18 - build with irssi 1.0
-
-Signed-off-by: benaryorg <binary@benary.org>
----
- src/core/xmpp-servers.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/core/xmpp-servers.c b/src/core/xmpp-servers.c
-index 405ecd9..b6d9bd5 100644
---- src/core/xmpp-servers.c
-+++ src/core/xmpp-servers.c
-@@ -151,7 +151,7 @@ xmpp_server_init_connect(SERVER_CONNECT_REC *connrec)
- server->connect_pid = -1;
-
- if (server->connrec->port <= 0)
-- server->connrec->port = (server->connrec->use_ssl) ?
-+ server->connrec->port = (server->connrec->use_tls) ?
- LM_CONNECTION_DEFAULT_PORT_SSL : LM_CONNECTION_DEFAULT_PORT;
-
- if (conn->real_jid == NULL)
-@@ -335,7 +335,7 @@ lm_open_cb(LmConnection *connection, gboolean success,
- g_free(host);
- } else
- signal_emit("server connecting", 1, server);
-- if (server->connrec->use_ssl)
-+ if (server->connrec->use_tls)
- signal_emit("xmpp server status", 2, server,
- "Using SSL encryption.");
- else if (lm_ssl_get_use_starttls(lm_connection_get_ssl(server->lmconn)))
-@@ -470,7 +470,7 @@ xmpp_server_connect(XMPP_SERVER_REC *server)
- return;
- error = NULL;
- err_msg = NULL;
-- if (server->connrec->use_ssl) {
-+ if (server->connrec->use_tls) {
- if (!set_ssl(server->lmconn, &error, server, FALSE)) {
- err_msg = "Cannot init ssl";
- goto err;