aboutsummaryrefslogtreecommitdiff
path: root/irc/irssi
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /irc/irssi
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'irc/irssi')
-rw-r--r--irc/irssi/Makefile5
-rw-r--r--irc/irssi/pkg-plist20
2 files changed, 9 insertions, 16 deletions
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 9c0d0aec5697..a7d4ccb0d900 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -2,7 +2,7 @@
PORTNAME= irssi
PORTVERSION= 0.8.17
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= irc
MASTER_SITES= http://mirror.irssi.org/
@@ -82,8 +82,5 @@ post-configure:
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/irssi/modules
-.if ${PORT_OPTIONS:MPERL}
- @${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
-.endif
.include <bsd.port.mk>
diff --git a/irc/irssi/pkg-plist b/irc/irssi/pkg-plist
index 20680b64795b..8d0e3b86404e 100644
--- a/irc/irssi/pkg-plist
+++ b/irc/irssi/pkg-plist
@@ -115,18 +115,14 @@ include/irssi/src/lib-config/iconfig.h
include/irssi/src/lib-config/module.h
%%WITH_PROXY%%lib/irssi/modules/libirc_proxy.a
%%WITH_PROXY%%lib/irssi/modules/libirc_proxy.so
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Irssi.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Irssi/Irc.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Irssi/TextUI.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Irssi/UI.pm
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/.packlist
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/Irc/.packlist
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/Irc/Irc.so
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/Irssi.so
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/TextUI/.packlist
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/TextUI/TextUI.so
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/UI/.packlist
-%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Irssi/UI/UI.so
+%%WITH_PERL%%%%SITE_ARCH%%/Irssi.pm
+%%WITH_PERL%%%%SITE_ARCH%%/Irssi/Irc.pm
+%%WITH_PERL%%%%SITE_ARCH%%/Irssi/TextUI.pm
+%%WITH_PERL%%%%SITE_ARCH%%/Irssi/UI.pm
+%%WITH_PERL%%%%SITE_ARCH%%/auto/Irssi/Irc/Irc.so
+%%WITH_PERL%%%%SITE_ARCH%%/auto/Irssi/Irssi.so
+%%WITH_PERL%%%%SITE_ARCH%%/auto/Irssi/TextUI/TextUI.so
+%%WITH_PERL%%%%SITE_ARCH%%/auto/Irssi/UI/UI.so
man/man1/irssi.1.gz
%%PORTDOCS%%%%DOCSDIR%%/design.txt
%%PORTDOCS%%%%DOCSDIR%%/faq.html