aboutsummaryrefslogtreecommitdiff
path: root/irc/libircclient
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:11:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 20:11:47 +0000
commita48842ce136a0e26d69664352d55b47ef1dba698 (patch)
tree55939ba6cfa3894cdeaf2335f60b54e664c329a8 /irc/libircclient
parentfa9186211930f0370123c284996a9a411934f4bd (diff)
downloadports-a48842ce136a0e26d69664352d55b47ef1dba698.tar.gz
ports-a48842ce136a0e26d69664352d55b47ef1dba698.zip
libircclient is a small but powerful library, which implements client-server
IRC protocol. It is designed to be small, fast, portable and compatible to RFC standards, and most IRC clients. libircclient features include: * Full multi-threading support. * Single threads handles all the IRC processing. * Support for single-threaded applications, and socket-based applications, which use select() * Synchronous and asynchronous interfaces. * CTCP support with optional build-in reply code. * Flexible DCC support, including both DCC chat, and DCC file transfer. * Can both initiate and react to initiated DCC. * Can accept or decline DCC sessions asynchronously. * Plain C interface and implementation (possible to use from C++ code, obviously) * Compatible with RFC 1459 and most IRC clients. * Free, licensed under LGPL license. * Good documentation and examples available. WWW: http://libircclient.sourceforge.net/ PR: ports/129278 Submitted by: Julien Laffaye <kimelto at gmail.com>
Notes
Notes: svn path=/head/; revision=223549
Diffstat (limited to 'irc/libircclient')
-rw-r--r--irc/libircclient/Makefile38
-rw-r--r--irc/libircclient/distinfo3
-rw-r--r--irc/libircclient/pkg-descr21
-rw-r--r--irc/libircclient/pkg-plist63
4 files changed, 125 insertions, 0 deletions
diff --git a/irc/libircclient/Makefile b/irc/libircclient/Makefile
new file mode 100644
index 000000000000..d030585082fa
--- /dev/null
+++ b/irc/libircclient/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: libircclient
+# Date created: 2008-11-20
+# Whom: Julien Laffaye <kimelto@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libircclient
+PORTVERSION= 1.2
+CATEGORIES= irc devel
+MASTER_SITES= SF
+
+MAINTAINER= kimelto@gmail.com
+COMMENT= An IRC library to create IRC clients
+
+GNU_CONFIGURE= yes
+
+do-build:
+ @${MAKE} -C ${WRKSRC}/src/
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/include/libircclient.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/include/libirc_errors.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/include/libirc_events.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/include/libirc_options.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/src/libircclient.a ${PREFIX}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @(cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO_MSG} "installing additional examples to ${EXAMPLESDIR}"
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/libircclient/distinfo b/irc/libircclient/distinfo
new file mode 100644
index 000000000000..e682db8e52de
--- /dev/null
+++ b/irc/libircclient/distinfo
@@ -0,0 +1,3 @@
+MD5 (libircclient-1.2.tar.gz) = c602e2bebdc8e4b63c2df3c5c818a427
+SHA256 (libircclient-1.2.tar.gz) = c98023d9816f3d7522ecc77e90753c0b66c736be9bd8ae47d03a29d5f6e6c7af
+SIZE (libircclient-1.2.tar.gz) = 274278
diff --git a/irc/libircclient/pkg-descr b/irc/libircclient/pkg-descr
new file mode 100644
index 000000000000..762893cef4c4
--- /dev/null
+++ b/irc/libircclient/pkg-descr
@@ -0,0 +1,21 @@
+libircclient is a small but powerful library, which implements client-server
+IRC protocol. It is designed to be small, fast, portable and compatible to RFC
+standards, and most IRC clients.
+libircclient features include:
+
+ * Full multi-threading support.
+ * Single threads handles all the IRC processing.
+ * Support for single-threaded applications, and socket-based applications,
+ which use select()
+ * Synchronous and asynchronous interfaces.
+ * CTCP support with optional build-in reply code.
+ * Flexible DCC support, including both DCC chat, and DCC file transfer.
+ * Can both initiate and react to initiated DCC.
+ * Can accept or decline DCC sessions asynchronously.
+ * Plain C interface and implementation
+ (possible to use from C++ code, obviously)
+ * Compatible with RFC 1459 and most IRC clients.
+ * Free, licensed under LGPL license.
+ * Good documentation and examples available.
+
+WWW: http://libircclient.sourceforge.net/
diff --git a/irc/libircclient/pkg-plist b/irc/libircclient/pkg-plist
new file mode 100644
index 000000000000..e9ef1183f95e
--- /dev/null
+++ b/irc/libircclient/pkg-plist
@@ -0,0 +1,63 @@
+include/libircclient.h
+include/libirc_errors.h
+include/libirc_events.h
+include/libirc_options.h
+lib/libircclient.a
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/censor.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/colors.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircftp.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/log.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/ircmud.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/log.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/main.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/ircmud.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/config.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/global.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ircmud/config.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/irctest.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/spammer.c
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ircmud
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_type.html
+%%PORTDOCS%%%%DOCSDIR%%/group__common.html
+%%PORTDOCS%%%%DOCSDIR%%/group__conndisc.html
+%%PORTDOCS%%%%DOCSDIR%%/group__contexts.html
+%%PORTDOCS%%%%DOCSDIR%%/group__ctcp.html
+%%PORTDOCS%%%%DOCSDIR%%/group__dccstuff.html
+%%PORTDOCS%%%%DOCSDIR%%/group__errorcodes.html
+%%PORTDOCS%%%%DOCSDIR%%/group__errors.html
+%%PORTDOCS%%%%DOCSDIR%%/group__events.html
+%%PORTDOCS%%%%DOCSDIR%%/group__initclose.html
+%%PORTDOCS%%%%DOCSDIR%%/group__ircmd__ch.html
+%%PORTDOCS%%%%DOCSDIR%%/group__ircmd__msg.html
+%%PORTDOCS%%%%DOCSDIR%%/group__ircmd__oth.html
+%%PORTDOCS%%%%DOCSDIR%%/group__nnparse.html
+%%PORTDOCS%%%%DOCSDIR%%/group__options.html
+%%PORTDOCS%%%%DOCSDIR%%/group__rfcnumbers.html
+%%PORTDOCS%%%%DOCSDIR%%/group__running.html
+%%PORTDOCS%%%%DOCSDIR%%/group__sendcmds.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/libirc__doc_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libirc__doc__faq_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libirc__errors_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libirc__events_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libirc__options_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libirc__rfcnumeric_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/pages.html
+%%PORTDOCS%%%%DOCSDIR%%/libircclient_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/modules.html
+%%PORTDOCS%%%%DOCSDIR%%/pagefaq.html
+%%PORTDOCS%%%%DOCSDIR%%/structirc__callbacks__t.html
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%