aboutsummaryrefslogtreecommitdiff
path: root/irc/miau
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-15 09:30:12 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-15 09:30:12 +0000
commit63d948657c08f2d29beac77c69564105be22d8e4 (patch)
treeaa5b379945e3411d76261b062bc054187c39a16f /irc/miau
parentd40c727fef948c629385c225761767025e777ca3 (diff)
downloadports-63d948657c08f2d29beac77c69564105be22d8e4.tar.gz
ports-63d948657c08f2d29beac77c69564105be22d8e4.zip
irc/miau: Fix IPv6 option, reassign maintainer to submitter
Whle here, de-indent most of the Makefile and fix DOCS option too. PR: 190984 Submitted by: Daniel Austin Approved by: maintainer timeout (2 months)
Notes
Notes: svn path=/head/; revision=364952
Diffstat (limited to 'irc/miau')
-rw-r--r--irc/miau/Makefile55
1 files changed, 32 insertions, 23 deletions
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
index 4e5b05b8e09b..5038ed2bdb35 100644
--- a/irc/miau/Makefile
+++ b/irc/miau/Makefile
@@ -1,42 +1,51 @@
# Created by: Oliver Eikemeier
# $FreeBSD$
-PORTNAME= miau
-PORTVERSION= 0.6.6
-CATEGORIES= irc ipv6
-MASTER_SITES= SF
+PORTNAME= miau
+PORTVERSION= 0.6.6
+PORTREVISION= 1
+CATEGORIES= irc ipv6
+MASTER_SITES= SF
-MAINTAINER= dhn@FreeBSD.org
+MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Fully featured easy to use IRC-bouncer
-USES= iconv tar:bzip2
-GNU_CONFIGURE= yes
+USES= iconv tar:bzip2
+GNU_CONFIGURE= yes
-INFO= miau
+INFO= miau
-CONFIGURE_ARGS= --enable-dccbounce \
- --enable-automode \
- --enable-releasenick \
- --enable-ctcp-replies \
- --enable-mkpasswd \
- --enable-uptime \
- --enable-chanlog \
- --enable-privlog \
- --enable-onconnect \
- --enable-empty-awaymsg \
- --enable-dumpstatus \
- --disable-dependency-tracking
-CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ --enable-dumpstatus \
+ --disable-dependency-tracking
+CPPFLAGS+= -I${LOCALBASE}/include
-OPTIONS_DEFINE= DOCS IPV6
-IPV6_CONFIGURE_ON= --enable-ipv6
+OPTIONS_DEFINE= DOCS IPV6ONLY
+IPV6ONLY_DESC= Enable IPv6 ONLY (disables IPv4)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIPV6ONLY}
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
post-patch:
@${REINPLACE_CMD} -e 's,\$$datadir/doc/miau/examples,${EXAMPLESDIR},g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}
+.endif
.include <bsd.port.mk>